Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.
Get Started

Asked
Resolved Resolved by DJ Sures!

Connection Issues

I can't connect my EZ-B to my computer, and the tutorials are not helping.  I'm able to get the wifi connection running, I boot up EZ-Builder, but the debug log says...

Connection Failed: System.Net.Sockets.SocketException (0x80004005): No connection could be made because the target machine actively refused it 192.168.1.1:23
at System.Net.Sockets.Socket.InternalEndConnect(IAsyncResult asyncResult)
at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
at System.Net.Sockets.TcpClient.EndConnect(IAsyncResult asyncResult)
at EZ_B.EZB.Connect(String hostname, Int32 baudRate)
Disconnected

What do I do here?


Related Hardware EZ-Robot EZ-B v4
AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
#1  
Do you also have a wired connection to your home network, or 2 wifi cards?  This is usually caused by an overlap in IP addresses.  192.168.1.1 is the default address of many home routers.  If you do, unplug the Ethernet connection, or disable the WiFi device connected to your home network until you get connected to the EZ-B.  Once connected, you can change the EZ-B's default address in it's web interface so it does not conflict with your home network.
#2  
"you can change the EZ-B's default address in it's web interface so it does not conflict with your home network."
How do I do that, and what do I change it to?
#3  
without additional networking skills you have two options: 

1) EZB AP Mode
Your PC is a client and EZB (192.168.1.1) creates a wifi network and assigns clients ips: 192.168.1.2, 192.168.1.x
your PC connects to the EZB's 192.168.1.1 and can only access EZB or other EZB's clients, no internet or access to other home computers.

2) EZB Client Mode
Your EZB is a client and connects to your Home/Office wifi, and your Router assigns an IP. 
your PC connects to the EZB's assigned IP

Which of the scenarios you have ?
#4  
@ptp
I don't know which of those scenarios I have.
Synthiam
#5  
1) Do you have an ethernet cable connecting the computer to a router for internet access?

2) Does the EZ-Robot EZ-B v4 make a startup chime when it is powered on? 

3) Does the EZ-Robot EZ-B v4 speak and introduce itself?

4) Did you follow the EZ-Robot connection diagnostic link that's prompted when the connection fails? This is the link: http://www.ez-robot.com/Tutorials/Lesson/14?courseId=4
#6   — Edited
@Bobsheaux .... I will simplify what ptp asked you.... Does your ezb's led flash blue or green when it is on?.... I am guessing blue so you are AP Mode....
#7  
@DJ
1. Yes. I want to get as much information about how to fix so I'm not stuck diving under my desk to unplug and replug it back a dozen times. ;P
2. The EZ-B does chime when powered on.
3. It does speak and introduce itself.
4. I didn't get a prompt for the diagnostic link, but I did follow that link on my own when it didn't work. I ran through it again, but it's still not working.

@Dunning-Kruger
It is flashing blue, yes.
Synthiam
#8   — Edited
To clarify - you didn't get this prompt when connection failed?
User-inserted image


1) Do you have a virus scanner installed as mentioned in the connection diagnostic trouble shooting guide? (https://synthiam.com/Products/Controls/Overview/Connection-Troubleshooting-17520)

2) I'm guessing your Ethernet is on the same network as the EZ-B. That is what's causing the connection failure. Which is a rare occurrence, of why you didn't easily come across the solution. If this is the case, the way to change the default ip address of the EZ-Robot EZ-B v4 is here: http://www.ez-robot.com/Tutorials/Lesson/80?courseId=4

Scroll down to where the title reads "Possible Network Configuration Conflict"
#9  
@DJ
Oh, THAT I got. My bad.

1. To the best of my knowledge, it looks like my virus protection is turned off.
User-inserted image

2. I can't change the address of the EZ-B, because whenever I go to http://192.168.1.1/, I get THIS screen and don't know how to proceed.
User-inserted image
Synthiam
#10   — Edited
The connection diagnostic tutorial mentions AVast or Symantec as a virus scanner or firewall. You should really have your windows defender turned on though, that's built into windows. The windows virus scanner is better than anything else out there. You might have a virus actually - if that's why your virus scanner is turned off?

You could change the network address in the router, since you can access it. That's the easiest way. Log into the router using the instructions that were provided by the webpage that you copy and pasted the screenshot of. Find the NETWORK or LOCAL NETWORK or LAN settings. Locate the area where you can change the network or ip address of the router. It should be 192.168.1.0 or 192.168.1.1 or something like that. Simply change it to 192.168.0.0. 

It's super rare this would happen, because few routers default to 192.168.1.0. I don't know why any of them would, but oh well:)

Once you change the network address and the router reboots, you'll have to restart your computer as well. Then your EZ-B will work perfectly after that
#11  
I can't change the network address on the router. It's not mine to tamper with, and my landlord won't help me change the network address because he thinks it's impossible.

Looks like all I've got here is a $200 paperweight until I find myself a new place to live...
Synthiam
#12  
You could just unplug your network cable, log into the EZ-B webserver, change the address, then plug your network cable back in, no?
Synthiam
#13  
Ha nah, we have another option - which was the original one. We’ll change the ip for the ezb

the easiest way is to simply disconnect the Ethernet cable from behind the computer. Connect to the ezb and change the ezb address. Then, plug the Ethernet back in:)
#14   — Edited
Even if you change EZB lan address.
You will have EZB (AP) assigning a DHCP client IP plus a default gateway, and then you have the OP's router (Ethernet) assigning a default gateway too.
So your computer will have 2 default gateways one is a dead end, maybe you can get lucky, and the the good default gateway route metric is lower.

When I did my EZB4 custom firmware I noticed there is a parameter to disable the EZB's  DHCP client default gateway:
https://technodocbox.com/C_and_CPP/71191432-Bluegiga-wi-fi-software.html
page 207
setting FLASH_PS_KEY_DHCPS_DISABLE_ROUTING

although the EZ-Robot EZB4 v1 firmware does not, so all the networking is routed back to the EZB. 
Is not a big deal, but sometimes small details makes all the difference, same thing with default EZB port 23, not a good choice.
Disabling an Antivirus in machine with Internet access... Does not seem a good recipe.

Why not changing EZB to client mode ?

*** EDIT ***
The default gateway applies to the EZB4 V1, I can't confirm if is still valid for EZB4 V2 (new wireless chip)
#15  
@DJ
"the easiest way is to simply disconnect the Ethernet cable from behind the computer. Connect to the ezb and change the ezb address. Then, plug the Ethernet back in:)"
It worked!  Thank you so much!:D
#16  
So, this is exactly what I said in the first reply to your question, with the additional details of why this works.   In order to help me communicate better, can you tell me what you didn't understand from my response?
#17  
also to help other users, can you confirm you have 2 networks working i.e. cable and wifi ? and what is the address you used for the EZB.
Synthiam
#18  
Ptp, it works fine with two networks. There’s a robot program episode about how to set it up. And it’s how we operate all our robots at the office. All our laptops have a WiFi usb dongle for robots.:)
#19  
@DJ:
Maybe I'm not lucky...
https://superuser.com/questions/735479/how-does-a-windows-computer-behave-when-it-has-multiple-default-gateways

Quote:

If Windows has multiple interfaces connected to several networks that use DHCP, it installs default gateways for all those interfaces.
By default, Windows sets the metric of the default gateways to the same, effectively leading to random selection of default gateway.[b][/b]
When I tried, the one selected was the EZB default gateway (dead end)

I don't like random stuff:)
#20   — Edited
"the easiest way is to simply disconnect the Ethernet cable from behind the computer. Connect to the ezb and change the ezb address. Then, plug the Ethernet back in:)"
lol, it's not that complicated:D you could check https://192-168-0-1.us/routers-default-ip-addresses/ for default gateway address.