Asked — Edited

Connecting A Neopixel Ring To An Iotiny

I'm trying to get a NeoPixel Ring running off of an IOTiny board. On a EZBv4 the TX and RX are connected: D18 Signal Pin on the EZB to RX on the Arduino, D19 Signal Pin on the EZB to TX on the Arduino

Which pins would I attach to on the IOTiny or can I run the ring off of the Tiny? I've tried all of the Digital pins and they don't work.



Upgrade to ARC Pro

Synthiam ARC Pro is a new tool that will help unleash your creativity with programming robots in just seconds!


Might be a stupid question, did you change the code use the correct digital pin? In the sample code.

D19 tx



Thanks merne but there only 8 ports on the Tiny. I thought port D5 might work because it is a UART port the V4 but no luck.


I don't know how your code works, but any IoTiny digital port can transmit uart data. Use the SendSerial() command. manual contains syntax assistance.

Your code may be using UartWrite() and UartInit(), etc... If so, simply remove the UartInit and replace UartWrite() with SendSerial()



I was asking if you changed you code from




The Dxx to what ever the port number on the iotiny.


I know that the Rx port on the Arduino should be attached to the Tx port on the EZB, and the Tx port on the Arduino to the Rx port on the EZB. Looks like we don't need the UARTinit command anymore, though I don't know why. It remains in the EZ-Scripting manual - perhaps that is just a deprecated method...

It is also important to share a ground between the Arduino and the EZB. Mine does because I am powering the logic side from the Vcc and Gnd on an A/D Port on the EZB. The ground of my servo and neopixel display are also shared.

I'm also unable to get my NeoPixel ring to fire via the SendSerial commands and the driving script that is compiling. I've added code to flash the Arduino's led on pin 13 when the first character W, C or S functions execute, and the led never flashes, though I see the Arduino's Rx led blink for each of three dif. SendSerial(W, ... )

So the Arduino seems to be receiving the commands, but not parsing them correctly... more to come, as in why not?


@mayaway - the EZ-Script manual explains what the UartInIt command is for. It's NOT for SendSerial(). It is for the UART commands.

IF you want to know more, look at the example projects included in ARC. Or, read the manual.

If you don't know how to find examples, then click the blue words example projects in this response.

Everything you will ever need is in the learn section in the ARC manual or activities.


I'll get there. Asking is a shortcut... You already know and I have no idea even where to look (and I'm learning). When I search for "Chatbot" and all 113,000 posts come up, I don't have the time to read them all, and someone may have the time to answer my question.

I can say that in two short weeks I have more RELIABLE and predictable control over my InMoov than I EVER had with MyRobotLab (bless their hearts...) Your software is FREE, STABLE, and EVERYBODY is selling hardware... I can't believe all of the unneeded hardware I stripped AWAY FROM my InMoov upon switching to EZ-Robot. This is worth every penny. I'm sure I'll be an Evangelist... I designed EZ ROBOT shoulder plates now on Thingiverse (I think I'll add the logo too...) :