Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Cannot Update Firmware

Hi,
I just got my kit and was attempting to upgrade the firmware (EZ Builder prompted me to upgrade). I start the upgrade application and I can connect to the board. The application says:
Press the HELP menu option to watch a video about this Firmware Upgrade process. Otherwise, press UPDATE when you are ready.

4/27/2013 7:58:20 PM - Sending bootloader
Starting Boot Loader...

4/27/2013 7:58:27 PM - sending ping
4/27/2013 7:58:29 PM - sending ping
4/27/2013 7:58:31 PM - Sending bootloader
I am EZ-B BootLoader. Gimmie Firmware!


4/27/2013 7:58:38 PM - Step 1 of 2) This process will take 2 minutes. The status bar will display progress.

4/27/2013 7:58:38 PM - Updating... (22,656 Bytes)

But I get an error message from windows and the program quits, heres what the windows error says:
-----
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.InvalidOperationException: The port is closed.
at System.IO.Ports.SerialPort.DiscardOutBuffer()
at .(Object , EventArgs )
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
EZ-B Firmware Update
Assembly Version: 2013.3.18.0
Win32 Version: 2013.03.18.00
CodeBase: file:///C:/Program%20Files/EZ-Robot%20Inc/EZ-Builder/EZ-B%20Firmware%20Update.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.1 built by: RTMRel
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.1 built by: RTMRel
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.1 built by: RTMRel
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
EZ_B
Assembly Version: 2013.3.18.0
Win32 Version: 2013.03.18.00
CodeBase: file:///C:/Program%20Files/EZ-Robot%20Inc/EZ-Builder/EZ_B.DLL
----------------------------------------
System.Configuration
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.1 built by: RTMRel
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Speech
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.1 built by: RTMRel
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Speech/v4.0_4.0.0.0__31bf3856ad364e35/System.Speech.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:





When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


-----------------


Any ideas?

Thanks.

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
United Kingdom
#1  
What BTStack are you using? Make sure it's Microsoft's Bluetooth Stack, third party stacks are unreliable and not supported.

Also, if the stack is the MS one, check your power supply is charged and ready to go.
PRO
Synthiam
#2  
Rich is correct. Either you are not using the Microsoft Bluetooth, or your batteries are dead, or you are disconnecting the ezb during update. I suspect the Bluetooth stack:) I doubt you're juggling the ezb while updating:D

Please follow the tutorials. We put a lot of effort into them to help with using the ezb
#3  
Thanks for the quick reply guys. I ended up using one of my other PC's to install the firmware update. I'm guessing that my Dell laptop has installed some proprietary BT stack. Ironically I'm using my Macbook Pro and not having any issues now!:)

Again, thanks for the quick reply! I'm off to make a robot now! :D
PRO
Synthiam
#4  
Sweet!:) glad it was easy

On the dell, visit the control panel and view the installed programs. You will be able to uninstall the stack:)
#5  
Im having a similar issue but not the same

Firmware Updater Version: 2013.03.18.00
5/2/2013 5:46:56 PM - Begin

Attempting connection on COM40
Connected to COM40 at 9600
EZ-B reports EZ-B Firmware V2
Connected

Welcome to EZ-Robot!:)

This is the first time you have used this EZ-B. After this upgrade, we recommend that you take a moment to view the tutorials at www.ez-robot.com/Tutorials. Nearly every question you have regarding EZ-Robot is answered in the Tutorials.

Press the HELP menu option to watch a video about this Firmware Upgrade process. Otherwise, press UPDATE when you are ready.

5/2/2013 5:47:04 PM - Sending bootloader
Starting Boot Loader...

5/2/2013 5:47:12 PM - sending ping
5/2/2013 5:47:13 PM - sending ping
5/2/2013 5:47:15 PM - Sending bootloader
I am EZ-B BootLoader. Gimmie Firmware!


5/2/2013 5:47:23 PM - Step 1 of 2) This process will take 2 minutes. The status bar will display progress.

5/2/2013 5:47:23 PM - Updating... (22,656 Bytes)
5/2/2013 5:47:44 PM - Uploaded

and thats it, it just ends there.
My guess is its the same issue but if I uninstall the toshiba windows stack I just done have Bluetooth at all. I see the drivers are all there. Just Windows 8 does not jump in and decide to run things.

Anybody have any ideas? Or is this even related?
#6  
Hello Rich,

One of my EZ boards cannot connect any longer. This is actually my very first old EZ board, the one I used to learn so much in so little time (you should see how my robot works fine now!:). I first thought it was a pb from the board itself but throuhg USB via TTL adapter I can connect without a problem so I figured this is due to the BT... Any idea which model I should purchase to replace it ?

Best,
Elfege.
#8  
Thank you again for you quick answer. However I should have mentioned I needed to know the exact model reference for the shipping rates in EZ robot store are prohibitive (more than the double of the price in this case, it's absurd) and it takes forever to come from China... I'll see what I can find. Thanks again Rich. By the way, just a question : do you work for EZR ? Just a question that came through my mind since you're on every discussion !;) If so you got yourself the perfect job!:) If not, you should seriously get paid for all what you do for the community. Best, Elfege.
United Kingdom
#9  
No I don't although am asked that often, and always with the same reply which is basically, if this was a job I wouldn't enjoy it anywhere near as much. Helping is it's own reward:) Plus I earn respect (well, from most people with the odd exception best left unmentioned) which is cool and beats attempting to demand it:D

Search for JY-MCU, they are stocked in other stores.
#10  
Ok, thank you. I really admire what you do. This is really great. Simply true and good. And indeed, you do not need to bother about the unmentioned guys... and you and me know that I know at least one of them... He's so funny!
Uganda
#12  
Hi, mine cant update its firmware as well, and I have also realized that the blue led does not light up as well...and yet I just actually received my EZ kit:(
#13  
From my recent experience you'll have to pay for return shipment AND the shipment for sending you a new one... 20$ Each so at the end you just pay almost for a new EZB that you would get much much faster (and at a substantively cheaper shipping cost) from a third party online retailer that ships it from their stock. Therefore it will take like a month before you get the new board because it's being shipped from China... This is the only flaw I found with this company so far, but I think it's a big one because it means that if you get a defective board, since it is close to impossible to prove it was defective from the beginning... you're kind of inevitably going to pay for its defect. In my case they said that the firmware upgrade might have been interrupted at some point while my device could connect twice before it stopped accepting connection, which makes their assumption a simple non-sense. I had not even had the time to imbed it into my project, I was still at this stage when you try few connections and check that digital ports respond properly (since you don't want to figure this out after having wired everything to the board). Basically customer care has to improve and upgrade itself to better standards. I guess this is what happens when a company has yet to reach a higher turnover revenue.
United Kingdom
#14  
@malep, have you successfully paired the EZB to your PC?
Have you tried all COM ports that were added on successful pairing?
What error message(s) are you getting?
What bluetooth stack is installed?
Is there any third party bluetooth software installed?
Is the red light on the bluetooth module flashing, solid or nothing?
Are your batteries charged?
Have you followed the EZB diagnostic tutorial?
Too many questions all at once?:)

Try/check all of the above. If you still have problems use the Contact Us page to report the problem.
#15  
After doing so you can also connect the tx and Rx on your board (after pulling out the bluetooth module) to a USB to TTL module, if you have one, and attempt a connection to your EZB using this device's COM port. If you get a connection then it's definitely your BT that needs to be replaced.
#16  
@elfege, you can order a class 1 bluetooth from Sparkfun.com. Reasonable shipping fees since they are US based.
While on the web site go ahead and order a 6 pin header to solder to the bluetooth module. The center 4 pins are identical to the 4 pins on the EZ-Board.
HERE is a link to the actual bluetooth device.
#17  
Thank you Rich. In the meantime I gave up since it came to almost the price of a brand new EZB, so I ordered one from another site and got it in less than a week. Thanks again.
Uganda
#18  
@Rich, I have done everything on the list to the dot... still not working :-( guess I might just have to purchase another EZ kit
United Kingdom
#19  
Use the Contact Us page and let them know the problem, they should get back to you about servicing it. Be aware that both Alan and DJ are away on holiday at the moment so be a little patient.