Upgrade to ARC Pro

Get access to the latest features and updates before they're released. You'll have everything that's needed to unleash your robot's potential!


Hey, so I am going through these youtube videos of Panda ,how you cut them in to different parts very nicely. So I am interested in using any USB camera with my Panda how you are doing it on the video. I guess this means I could run my regular EZB-4 with EZ cam doing some type of tracking and then also turn on the Panda with another USB cam doing a different tracking since, all of this hardware is on the robot now,just not an extra USB cam yet. So If  my robot is walking around outside it could monitor and track several  objects at a time while roaming on patrol as in security or seek missions etc...Oh my god, the possibilities are endless while using 2 EZB's an Arduino on the Panda with 2 cams! 3D tracking even!

#3   — Edited

I'm trying to do this zip upload part but not sure if it successfully downloaded the first time, Panda ARC would not connect with com5 so I tried the download again several more times and just seems to get stuck at 90% of download and never says done.Did I ruin the panda firmware? It still shuts down and re starts like normal with win10 but still the ARC will not connect to com5? I did check that RTS button in the connections as well but nothing? Do I need to possibly hit the Arduino reset button to clear memory?

Ya it is still just stuck at UPLOADING----10,432 bytes  (of a 28,672 Byte Maximum) But I remember the first time I think it just took a minute and said done.


It is weird I can get the download to finish if com4 or com 7 is matched up but still no connection at ARC, does it really need to be on com 5? It has vanished as an option but when I play around with ports and removing devices sometimes I can get com 5 to show up again, wow this is a real nightmare not as easy as shown in video.

#5   — Edited

The COM port will change based on your lattepanda. It won't always be the same COM port for every lattepanda. Just use the COM port specific to your lattepanda, even if it's COM3 or COM9 or COM1 or COM1923924324 or COM5124124132423535


OK DJ I did try that using com7 and com 4, the downloaded Zip worked but when I try to use ARC(latest Beta) I just get the connection error when I try that specific com port. I remember I had the same issue trying to connect EZBv3 with the Bluetooth connecting on ARC and never figured that out either so I am thinking there must be some kind of missing or corrupt Com/USB files in my Latte Panda. I am using the unregistered Win10 but I see you used that as well in the video. I may think about re installing a newer registered version of Win10 on a jump drive I have.


You may have forgotten a step in the tutorial...

User-inserted image

#8   — Edited

Oh ya I did see that part and checked it. Still no go on connecting. So to be clear , No Ezb4 needs to be attached to do this .As I am assuming panda is converting to Ezb Inside as a 1 unit panda-Ezb-arduino. you also show the alternative method connecting an Ezb through camera port but I am not trying that method.  So nothing else needs to be connected to the panda usb port except power and touch keyboard-mouse.I assume.

Well anyway, no big deal the windows 10 on the robot was the main thing. Much better than mobile cell phone ARC.Thanks for the suggestions.


Make sure arduino ide is closed before connecting to the internal lattepanda arduino with ARC

#10   — Edited

So this ide is something I have not checked or familiar with. Will have a look at the meaning in panda troubleshoot forum.Thanks again DJ! Ah Ok,LOL did not understand the Lingo,I get you now,seems many people have my problem,there are sollutions I can try.