Asked — Edited

Wii Remote Bluetooth Discovery Question Windows 7

I was going to assign a Wii Remote project for my students to work on, but wanted to try it out before assigning. I am using Windows 7 Enterprise Ed on a PC with a USB Bluetooth device. The Bluetooth device is manufactured by Cambridge Silicon Radio Ltd. and does load its drivers properly into Win 7 (at least it looks like they're properly working according to the Bluetooth Settings Hardware tab). The window shows both a Generic Bluetooth Radio and a Microsoft Bluetooth Enumerator working properly.

My problem occurs when I try to get Windows to discover the Wii Remote Bluetooth device. Prior to performing the discovery, I disconnect from my school's network by disabling the LAN port on the PC and disconnecting the WiFi connection. I then try to Add a Device which pops up a new window that displays any Bluetooth or WiFi available devices. I either press the 1 & 2 buttons simultaneously or press the red button inside the battery compartment to place the Wii Remote into discovery mode. In either case no new devices appear on the Add a Device window. I try this scenario over an over either by pushing the 1 & 2 buttons down well after the blue flashing stops on the Wii, or by pushing the red button in the battery compartment. Nothing seems to work. I'm at a loss on what to do next.

If anyone has suggestions on what I can try next, I would be very grateful.


Upgrade to ARC Pro

Don't limit your robot's potential – subscribe to ARC Pro and transform it into a dynamic, intelligent machine.


Make sure you have deleted any existing wiimote devices that have been added. If an existing device driver exists for the wiimote, it won't add again.

You will find a description about having to remove existing devices in the third paragraph of the wiimote manual:

If there are no existing wiimote devices added in your Bluetooth list, then the Bluetooth driver is not compatible. You can also remove the aftermarket Bluetooth driver and use the built in Microsoft one.


No Wii Remote devices have ever appeared for me to select. I checked the Bluetooth drivers and they are both Microsoft drivers. I deleted those and they reinstalled when I plugged in the USB Bluetooth device. I tried the BT discovery process again and the same result occurred - no wiimote displayed to select.

My guess is that this USB device is not compatible with the wiimote I'm using. I would have liked to have gotten this to work, but fortunately it isn't a "must do" project for my students. I will move on to other EZ-Robot tasks. I will still be open to any new suggestions, though, to get my wiimote to work.


make sure you have an original wiimote.i got two who dont connect in win7. on the bottem off the wiimote chould be the original name

not excample move+inside or no name


If you are using mobile apps in any of your projects, if you add a wiimote object to the project and select it in the mobile app, it will use the accelerometer on the Android or iPhone to emulate a Wii. But the app needs to be running on the phone not on the PC so may not fit your needs.



Nomad 6R - I ordered my Wii Remote devices from Amazon. They are the ones without Motion Plus, as specified by the EZ-Robot tutorial. More than likely they are not Wii originals.

thetechguru - Interesting approach. I will try it out to see I can get it to work. Thanks for the advice. I could have saved myself $$ going this route.


i bouth one withs said it was original,but it was not the name.


That's really interesting - I wonder why they wouldn't show up... Maybe there are later versions of wiimote which have protection to not be used on the PC. It may have been something that Nintendo implemented to prevent their controllers being used for third party devices? I am merely speculating because know one else on the forum has come across similar behavior.

It is very unfortunate thah those controllers won't work for you. As Alan mentioned, good news is that you can use mobile device, but that might not be ideal if you're working within ARC in the classroom.

Hmmmm. I recall that your class computers did not have administrative privilege, unless I'm mistaken. If that is the case, have you attempted to ask the technical IT department for assistance with the wiimote? Perhaps administrative access is required.


You could very well be right about Nintendo's actions. As far as the admin privileges go, I logged in as myself as an administrator to connect to the wiimote. I did get IT involved to enable the COM ports on the PCs. Apparently some Bluetooth devices use COM ports to communicate. Even after doing so, I still had no luck discovering the wiimote.


am not sure but doesn the original wiimote color is white ?


The wiimote I'm using is white, but more than likely it is not an original from Nintendo.


My wiimote does not have the "Wii" imprinted on it so it must not be a Nintendo.


indeed, i got two bad ones too.