Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
United Kingdom
Asked — Edited

Vertical And Horizontal Servo Control Movement Bug

After downloading the two recent updates I've come across something which I think may be a bug. When setting up or using a servo in either the vertical or horizontal servo config screen or the interface itself, when I left click or touch the screen to set or move the servo, a drop down window keeps appearing with all the servo values and can no longer slide the mouse pointer of my finger on the screen to move the servo in real time. Is this a bug or new feature (which I hope it's not)?

Thanks.

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
PRO
Synthiam
#1  
1) This is a feature and is only enabled when you RIGHT Click. This will never happen with LEFT Click.

2) Microsoft Windows was designed to simulate a RIGHT Click when you hold your finger for a length of time on the screen in the same position. This is a feature of Microsoft Windows and not ARC. I'm not actually sure where you can adjust the "hold for right click" option. Perhaps the Mouse settings in control panel?
United Kingdom
#2  
This is strange as it was working last week on the same machine, on the same project via touchscreen and track pad, either double tapping the pad or left clicking. I noticed the right click feature in the Auto Position a couple of days ago which is very handy and worked well. I posted up a short video for you to see what's it's doing...

PRO
Synthiam
#3  
Maybe reboot your computer? Touch events are built into the Windows Operating system. There is an event for Left Click and an event for Right Click. If Microsoft Windows is sending the incorrect event, that may because the computer needs a reboot? Sometimes Windows gets confused.

In your video it looks as if the computer thinks everything you are doing is a right click. Reboot your computer and hope Windows smartens up

FYI, when Windows starts doing funny things... reboot. It's kind of an ongoing joke with Microsoft Windows that rebooting fixes it:)
United Kingdom
#4  
Hey DJ.

Well I tried the reboot as you suggested (truth be told I did it earlier also, but didn't heart to try again), system restarted and left/right buttons and trackpad double tap work as they should. But on the servo control... No dice.

I put up another video (after reboot) showing that the buttons and trackpad are working as they should when opening up applications, but not with the servo control...



EDIT:

Just to note, this doesn't happen when I use Auto Position to set up frames. That works fine.
PRO
Synthiam
#5  
Crazy - works fine on my end. Are there touch settings or keyboard programs running? Something that's installed to alter or assist keyboard languages?
United Kingdom
#6  
No, nothing else like that is running or installed. Like I say, it worked fine last week and weekend with no changes to the laptop or OS made since. It is a strange one as I mentioned in my edit, the Auto Position works excellent (as well as everything else, system apps and programs and ARC controls), and the buttons or touchscreen work as they should. I'm not too fussed if I'm honest as I only use these controls for testing or getting servo position values for scripts. But I can use the Auto Position for that. I just thought you might like to know I case it was a bug, but then it works fine your end and there's been no other reports so far. Weird.

Anyway thanks for the assist DJ. Much appreciated.:)
United Kingdom
#7  
Sorry to bring this up again DJ, but I'm now having further issues with this servo drop down menu when using left click/double tap/ screen drag. Now it's not just the vertical and horizontal servo controls doing this, but it is now doing it when creating frames in real time using auto position.

As of last Saturday this was working absolutely fine and I even made and posted a video of some dance moves using auto position. So I went to create some more Auto Position frames and I'm getting the same drop down servo value menu when I'm left clicking, double tapping the track pad, and dragging my finger on the screen. I tried creating a frame with the drop down, and VERY nearly burnt out a servo as the wrong value was selected. I really need some help with this before I do actually damage something, or before I give up completely on using Auto Position all together as it is too difficult to use now. And what I said about not being too bothered about using servo controls for real time testing, as I can use auto position, is now no longer the case.*stress*

One thing of interest I have noticed, is when I disconnect the EZ-B and close my ARC project, when I reopen it (without connecting the EZ-B), the vertical and horizontal servo controls and servo widgets when making frames in Auto Position work correctly with left click/double tap/screen drag. But once I connect the EZ-B, I'm back to square one again. *confused*

My laptop is no different than what it was last week, no added programs, no updates, nothing conflicting running in the background, same project, same EZ-B, and curious to why things work correctly when the EZ-B is not connected (although I do have to close and reopen the project), so I'm REALLY confused to why this is happening, and really taking the fun out of things.

Please help.

Steve.
United Kingdom
#8  
Okay, so I have a further update. It's deffo not an ARC bug as you said, and it's not a problem with my Acer laptop or windows 8.1 as I suspected. I believe it it the project itself causing the headache.

I powered up my old HP laptop with Windows 7, and downloaded the same project from the cloud on an older ARC release, version 2015.01.11.00. Exactly the same problem occurred. So I opened up a new project, scanned and connected to the EZ-B, and added a vertical servo control. IT WORKED. So I did the same on the Acer and it worked as it should too. So there's obviously something in my project that's causing the issue. If yourself or one of the guys at the office, or anyone on the forum could very kindly take a look to see what is causing this, I truly would be very grateful, as I have put a lot of work in to this and would hate to start over, not knowing the cause. the project is in the cloud under Steve G, Victor project 1, and is also linked to below.

Many thanks in advance:)

VictorProject1.EZB
PRO
Synthiam
#9  
For some reason youtube is giving me errors with the video I am uploading from my phone - I loaded and used your project with touch and mouse without problems.

As I stated, there is absolutely zero (none, zippo, nada) code in any windows program to determine mouse clicks. The operating system provides the event on activities, such as mouse clicks. So every time a RIGHT mouse click is pressed, the function event for RIGHT mouse clicks is executed, same applies to LEFT clicks, and every thing else.

In ARC, MS Word, Photoshop, Chrome, anything - it's all the same. They respond to the events triggered by Windows.

I understand that's not what you want to hear - because you want a solution:) However, if it was happening to me.. I would consider a few things.

1) Do I have a virus, Trojan or key logger?

2) Is my mouse/touch driver up to date?

3) Are there any windows updates that need to be done?

4) Is my screen cleaned with windex and a soft cloth? Touch screens use capacitive touch and dirt will simulate right mouse clicks. Turn off your computer and clean the screen with windex

5) Is there a program installed that is for remote desktop or vnc, etc... maybe it is interfering with the keyboard hooks
United Kingdom
#10  
Thanks for getting back to me so quickly and for checking the project.

I have checked everything in your list, and everything checks out as I already checked these most of last night and this afternoon, on both machines. The fact that this is happening on only one project on two different machines, running two different operating systems, both Windows 7 and Windows 8.1 OS are up to date, both computers drivers are up to date, on two different versions of ARC (older and most recent), and only happens when the EZ-B is connected says to me that it has to be project issue.

The HP laptop doesn't have a touch screen and runs on a different OS, yet the same thing occurs as on the Acer. On a new project, fine. On older projects, fine. EZ-B not connected, fine. On the Victor project, the problem occurs. If it was a computer issue, virus, updates ect, then I wouldn't expect the other projects (new or old) to work correctly either, but they do, and work well on two different laptops. All the correct mouse clicks ect work as they should in every program, every application on both computers, except this one project.

This is really bugging me now as you can imagine, and don't want to use ARC right now. I don't want to say that as I love using it, but this simple thing makes things so difficault now and could possibly cause servo damage as I don't now every position value of every servo when using the drop down menu, and I don't want to spend the time making a new project, adding every script, every control ect, one by one to possibly have the same thing happen again.

Do you or anyone else possibly have any other ideas what could be causing this? Agian DJ, I really do appreciate you taking the time to reply and your assistance. I hope I didn't come across too off'ish in my reply, but I'm not a happy boy. If you want me to post another video showing when it all works and when it doesn't on both laptops, I'd be happy to if it helps. *stress*

Steve.
Canada
#11  
Steve,
I tried your project on my laptop (Acer ultra book with touch screen ) and everything seems normal .

The only way to bring up the servo angles list, is to click the left button of my mouse or hold my finger on the screen.

Either touch screen and mouse usage are acting normaly
#12  
I would suggest creating a new project and merge in the objects from the "broken" project.

First, try to merge in everything and see if the problem occurs.

If so, try again, but merging one object at a time, starting with each servo object and see if the problem starts when you add a particular object, and if it goes away when you delete that object. then you can re-create just the failing objects without needing to rebuild all the work you have done so far on teh project.

Alan
United Kingdom
#13  
Thanks for confirming Aerius. Well this gets stranger and stranger. I was just about to jack it in the I thought I will try one more thing. I opened a new project and merged all the controls from my other project. Same thing happened. Some deleted a couple of the recent scripts I added over the past couple of days.... IT WORKS.

I'm in the process now of trying to figure out what I just deleted was causing it. I deleted the PIR scripts and controlcommands and my ping ramp down script, so it was one of them causing the issue. When I figure it out ill post back.
United Kingdom
#14  
@Alan.

Sorry I just read your post (writing the same time as you posted). Funnily enough I did just that. I can now say that I'm officially in The Twilight Zone. So after deleting the three scripts/controls mentioned above, I added them back one by one. Now that they are all back as they were, the servo control sliding STILL works. I have saved the project after every step, restarted the EZ-B every time, and the whole project is back as it was and it all still works. I just can't explane this, but so happy it's working again.

I'll keep an eye on it in case it happens again, and delete one of the newer scripts one at a time and run it for a day or two.

Anyway, thanks for all your input DJ, Aerius, and Alan. I'm very grateful.:D
Canada
#15  
Que la force soit avec toi! *cool*
United Kingdom
#17  
Lol, Longue vie et prospérité à long et à prospérer tout le monde.:D
United Kingdom
#18  
Well I've been testing things for about an hour now, closing and restarting ARC, power the cycling EZ-B, running all the scripts, and everything is still all good. Thanks again everyone. I'm a lot happier now.:D

@Richard.

How you doing bud. I havn't seen you around the forum very much over the past couple of weeks. Is everything cool?
United Kingdom
#19  
I guess not. *confused*