Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by CochranRobotics!

Trouble Hooking Up To Ezb4

Ok, I know it is not EZB4s problem.

First let me tell you my setup. I have EZB3 hooked to COM9 on my notebook connected to my robot on port 0 which is bluetooth.

I have an EZB4 connected to Port1 which is wireless.

I have VNC coming from my desktop which controls the Sunshine Robot Mimo Monitor touch screen.

In the past, I I simply turned on my notebook which fired up the VNC network. I then activated the VNC on my desktop so I could talk to the Mimo monitor screen. This all worked good and I started EZBuilder and operated my robot.

Now, when I try to hookup the EZB4, I don't see it in the wireless connections list. There are many, but not it.

I am following D.J.s steps:

1. connect V4 in wireless setup
2. then connect in EZbuilder.

This should be a piece of cake.

what it does is quickly go back to the Connect dialog and ask if I need to see the tutorial which I have seen many times.

I have a tendency to make things way more complicated than they are. My network is interfering with my EZB4. I think they BOTH have the same IP address. So when one is working and you try to connect, it kicks one or the other off the network.

I don't really know how to fix this. I ultimately want to have 3 v4s and 1 v3 hooked up at once.

I tried a spare one just out of the box. It does the same thing, it tries to connect and then it goes back to connect button.
Help.

#1  
I told you... GOD help us.... LOL.... Tell me one thing, why are you trying to connect a Wifi device (EZB4) to a com port (port 1 you mentioned)....

1) does you EZB4 flash a blue light? (you are still in AP mode, then) and not connected to your PC....

In AP (came shipped that way) mode you can only connect your PC to either your network or the ezb4.... not both... You will need to set the EZB in client mode for that....

You need to go back to DJ's tutorials and follow it religiously.... One step at a time...
#2  
Are you connecting in ap mode or client mode. If you are connecting a mode, I would recommend using client mode. This will assign an ip address from your network via dhcp that won't conflict with your network. To set this up, disconnect the laptop from the network and connect via wireless to the ezb v4 from a Web browser http:\\192.168.1.1.

Input your said and password. Allow it to reboot and it will say "I am connected to your network"

Connect your laptop back to your network and then use ARC to scan for your robot. You should see it and the ip issue should be resolved. You can now also connect to the internet.

Let us know if that works for you.
#3  
Ok, I have both COM ports for the V3. And the Wifi for the V4.

I have narrowed it down to there is NO EZB4 listed on the wifi-channels. Without it showing up, there is no way the rest will work.

I am trying to use the VNC network to talk to the robot from the Desktop even though the robot has it's own notebook for the Main brain.

I will read your posts a little closer.
#4  
I meant that I had the v3 on EZB 0 and I had the v4 on EZB 1.

Once again what I want for my robot:

I have a quad-core notebook running windows 7 or 8, I forget hooked to the v3,v4.
I have a robot that needs to talk to the Desktop.
I have a V3 that needs to control the Navigation.
I have a V4 that needs to control the arms, head,neck,LEDS and chatbot connected to the internet.
I have a touch screen Mimo Monitor (hooked to the notebook) that I control with Desktop hooked to the notebook.

I usually hook up VNC to the Desktop and notebook to control the notebook .
But, we will not worry about the VNC right now.

I have the notebook hooked to the V4. The V3 is cut off.
at this point I cannot see the EZB 4 in the list of wifi option.

I think ......I may have had the V4 to connect automatically the first time I tried to install it. and maybe it is connected but I cannot see it in the list. But, it also does not connect to ARC.

I have taken a very simple thing and made it too complex. :-( sorry. That is just the way my brain works.

At the very first, it connected but It conflicted with the VNC. I did not realize that I could change the port by using "select from the list" and make it find the best way to do it. But, now I am stuck because I cannot undo the setting, I think the best way to fix it is to make the ezb 4 not connect up automatically until I assign it an ip address.

I have disconnected my Desktop all together.

oops . . . .my battery is dead. I will have to do this later. But, I am still open to read all of your suggestions.
I know that having being informed will make an answer come quicker, so that is why I am giving you all of the details. If I could be able to start all over, I believe I could get it working. But, the network is all messed up now because of my settings.

Oh, BTW, I am in client mode because I figure that suits me better. I need to hook up to the net in order to do Pandorabots, etc.

Thank You BOTH, very much.
#5  
Start by using the reset button on the ez-b v4 and then follow the instructions.

To use vnc, you will need to have the computers connected to the network.

If you have 2 network cards with at least one of those being wireless, you can do this in ap mode. If your computer that is controlling your robot only has one network card or on board wifi, you will need the ezb v4 to be in client mode. This is because you will need to be on the network for your vnc session to work.

Follow the instructions above to get your ezb v4 on your wifi network first. From there, you should be able to search for the ezb v4 in ARC. Once you have a connection, then get the V3 connected. From there get vnc going.

It's best to do one thing at a time and determine where the failure is happening. If you have the V4 connecting and it drops when the V3 connects, that will point you in a direction. If you can't get the V4 on the wifi network, that will point you in a completely different direction.

let us know what happens.
#6  
well, I was able to get the v4 to show up. The only problem is I left it on a long time to test it and it did good. I disconnected and now I can't connect it back up. I tried the procedure again and it would not connect. Weird.

I got it to connect after going through that procedure over and over. I hope it will remember where it is now. I had to take my robot apart to be able to access it.

I am hoping to make it automatic where I don't have to take the robot apart to reset it and I don't have to go through those procedures.

Thank You both SOOO much for the support.
#8  
Once you get it set up in client mode and assign it a static IP address you'll be able to connect with a click of a mouse or with some programming have it connect automatically when you launch your file in ARC...