Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by Steve G!

Tight Servo

Hi,

I was at a conference all day today with JD. I had him running the 'pushups action.'
He worked perfectly well for several hours. Then I noticed that the right shoulder servo wasn't moving fluidly and causing the action to fail (JD couldn't stand up).

I recalibrated the servo several times without any luck. When the power is off, I notice that the left shoulder servo can be moved quite easily. The right shoulder servo is really stiff. I removed the black screw thinking it was too tight. No luck.

Any suggestions?

Tom
User-inserted image

AI Support Bot
Related Content
Synthiam
United Kingdom
#1  
@Tom.

I don't have much to say on this, but there were reports of tight servos and I wanted to refer you to this thread which talks about a similar issue.
#2  
Thanks for sending this info. Looks like this is a common problem with early units. I got mine in October.

Tom
#3  
I think I replied too soon. The tight servo has nothing to do with the issues mentioned with the early units. The problem I'm having is with the first exterior servo (in red circle). This is the one that barely moves compared the one on the left. Any other suggestions? Thx.
#4  
Could the cable be binding? I would try removing the lever and see if it operates freely with nothing possibly adding stress, then put the lever back on and test again before assembling back into JD. If it doesn't turn well with the lever disconnected, try opening it up and see if anything looks wrong inside.

Alan
#5  
I did check the cable. No issue there. I did open it up & didn't see anything unusual.
PRO
Belgium
#6  
tom-caine

did the servo make a lot off noise?
i made a drastic solution,also the left schoulder hole is to tigh against,
the endpart.what i did is i took a metal new drill from 14 mm.
and drill the hole off the chest out by hand.bolt.
result no noise or stress.the problem is the endpart is taps and the schoulder,
hole is straight,eacther the inside off the hole is 1 mm to small or the endpart,
1 mm to chort.
#7  
It doesn't make any unusual noise. BTW - I wasn't clear. It's the first exterior servo see the picture. It is too tight within the bracket. The shoulder movement is fine.
PRO
Belgium
#8  
ah.great to hear its solved.
#9  
tom-caine Did you tear down the innards of the servo, (gears motor armature, etc) and was there any resistance felt ?
#10  
I did open it up to look inside, and it seemed OK but I'm not really sure what to look for. The problem must be in there somewhere. What else could it be?
PRO
Belgium
#11  
can you test the servo separt?
it can be a lots off things ,bad bearing,gears ,dry gears,bad pot.
i would change the servo anyway.80´% from the problems comes back.
#12  
It sounds to me like the gears are binding. Perhaps one of the posts is bent or has come out of its hole.

I assume from the description that the diver board and motor are okay.

Take the arm off of the servo and put a horn on the gear if you have one. If not, a piece of tape will work. Connect the servo to the ez-b turn it on. Connect to the ez-b from ARC and add a horizontal or vertical servo control to the project. Click the gear on the control and choose the digital port that the servo is plugged into and click okay. Now, in the min box, choose 1. The servo might move. In max choose 180. The servo should move 180 degrees. If this happens, the servo should be good. The tape or horn should allow you to see the movement. If the servo tries to move but cant, you probably have an issue in the gears of the servo. Unplug the servo. You would need to take the servo apart and inspect the gears at the top of the servo to make sure they are seated well. With the servo unplugged from the EZ-B, you should be able to turn the servo without feeling any binding.

next, look at the teeth in the u bracket that attaches to the servo. Make sure they are not stripped.

If the first works and the teeth are not stripped, move the servo to 90 using ARC. Attach the bracket to the servo. Once attached, see if the servo and bracket will move using ARC as described above.
United Kingdom
#13  
Sorry the link didn't help with your issue.

Apart from the great advice that @d.cochran has supplied, I just wanted to add a small thing and say to check that the screw that goes through the lever bracket and in to the servo gear is not too tight. The screw only acts as a guide that helps to keep the lever bracket to not jump off the gear, not to take strain and physically hold the bracket on to the servo, so it only needs to be pinch tight.
#14  
Ok thanks everyone. Turned out to be a bad servo (the one in the picture.) I took a servo off of another robot and it worked.

Seems like the servo froze up. Is this common?

One more lesson learned!
#15  
@Tom.... I wouldn't say it's common, but servos do fail.... I had 1 servo go in one of my 2 inMoovs... that's about 1 in 52 or so... They are not that expensive so it's not really a huge deal... Maybe a little annoying but that's about it....