Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Text To Speech Voices Revisited

I need some help with getting the Ivona voices to work with EZ Builder. I've downloaded and install the voice pack. Then I visited 'ease of access/text to speech' and made the new Ivona voice the default voice (default was anna). I tested the voice outside of EZ Builder and it works as default. In EZ Builder, I add 'speech synth' and the 'speech settings'. The Ivona voice Brian is available from the drop down but no matter how many times I select it, Anna plays instead.

I understand that Ivona is SAPI 5 and 64 bit (im running win 7 64 bit on mac under boot camp). Interestingly, I looked under programs and programs (x86) and it installed in programsx86, so it looks to install as 32 bit, but there is a 64 bit folder with .dlls?!

Any ideas how to get these two to play together? I'm also going to try on another machine, just in case.

#1  
Got to your control panel.

Then click on Speech recognition.

then click on the text to speech label

you can set your voice here.

i hope that helps
PRO
USA
#2  
Yup did that. Stated that in post.
#3  
Have you rebooted your PC since you installed the new voices?...
United Kingdom
#4  
I had to play around with the voice settings in the ARC control for one voice to work. Using it as default in windows did not work for ARC. In fact the settings were totally different to what I expected them to need to be (i.e. I expected it to need to be set to male, adult but that wasn't the case).

Add the Speech Synthesis Settings control and try every combination until it works.
#5  
i used the ivona till my trial expired.
I believe you have done the right things.
Many programs are written for x86 and just compiled to run on 64 bit. In this case it usually will install in the x86 Dir. so i don't think that's the issue.
I believe its more that your running under boot camp .

sorry i could be of no further help.

good luck.
PRO
USA
#6  
Yup rebooted, same issue. Will try all the combos to see if that worked like Rich had suggested.
PRO
USA
#7  
Tried every possible combo including notset. Nothing. Very frustrating. Really the only voice I want.

I will try on a windows machine, i have an ASUS laptop somewhere. Its 64 bit win 7
United Kingdom
#8  
If you can't find your ASUS laptop feel free to email me with the details of the voice (free trial or the installation files) and I'll give it a whirl on my Win 7 64 bit PC to see if it is a bootcamp issue or just an incompatible voice. Since it'll only be for testing and helping you out it wont be breaking any laws by sending it to me.
PRO
USA
#9  
Ok, ive installed the voice onto 3 machines and get the same issue on all of them. Rich if you have any other thoughts or memories of what you might have done?!?! I shot off an email to support to see if they can help resolve the issue and asked to be sure I had a 64 bit version.

edit: @Rich missed your last txt will send you a link
United Kingdom
#10  
To be honest it only happened on my laptop and I'm pretty sure all I did was tried all settings in the settings control which eventually made it work.

I just checked out the info on their website and can't see anything that jumps out at me saying it wont work. In fact, they claim they are fully compatible with XP and newer so it should work.

Hopefully their tech support will help. The only other things I can think of suggesting you have already done.
PRO
USA
#11  
OK thanks, still sent the voice to you just incase it rings a bell check email.
United Kingdom
#12  
Got it thanks.

Just had a 5 minute play and couldn't get it going in ARC (Win 7 x64) either. It was either Anna (for female option) or Jarvis' voice (for male) even with the voice set as default. I'll have another play tomorrow when I have more time.
PRO
USA
#13  
Thanks. Any help very much appreciated.
United Kingdom
#14  
@fxrtst.

I had a similar issue to what your experiencing a little while ago trying to get a Cepstral voice with robotic effect working with ARC. I found a thread here on post #24 from rgordon that helped me to get the voice working with the effect and it works great now. It consisted of changing things in the C:/program files. Maybe this might point you in the right direction to get your Ivona voice working the way you would like.

Hope it helps. ;)

Steve.
PRO
USA
#15  
Any luck Rich? I'm afraid I'm stuck with an American voice:)
PRO
USA
#16  
I've been chatting back and forth with tech support. And they are stumped. But I got this reply today:

"Hello,

One more question.
Did you try to call the voice with its language code?
Could you please describe how you send the voice request?
In some cases, if the language code is set to en-us for instance, and the IVONA voice is British or Indian English, the app may use another voice available in the system."

Can anyone shed light on how to check on this?