United Kingdom
Asked — Edited

Ssc-32 Speed Control

I'm currently installing and testing my new SSC-32 and testing servos using Servo(V0,xx) script commands which work great, and I'm trying to get a "connection" init script sorted to set virtual servo speeds on start up, but can't figure out how to control speed. A take it that the "ServoSpeed()" commands are not supported for virtual servos as it doesn't seem to be working for me?

One other thing, it's not a problem for me, but may be for others... in the SSC control config menu, when UART #0 is unchecked, I cannot select any other UART ports from the dropdown menu as no others are showing.


Upgrade to ARC Pro

Don't limit your robot's potential – subscribe to ARC Pro and transform it into a dynamic, intelligent machine.


You have to use scripts with uart or sendseial commands instead if you want to control speed...

See my tutorial... SSC-32 Tutorial

United Kingdom

I missed that one. Very helpful and a good tutorial Richard. Another quick question, where you wrote...


$pw = "1500" #1500 = 90, 500~ min and 2500~ max for 1 to 180... $m = "1000" #is speed control

what would be the value for "0" servo release?


I have never tried any value below 500 or above 2500 so I can't say if "0" would "release" the servo or not.... I would consult the manual first before trying, though....

United Kingdom

Okay, thanks anyway.

United Kingdom

Just to note, setting $pw= to "0" or higher than "2500" doesn't release a servo. I just tried and the servo still holds. The manual hasn't been much help is this regard so far.

Last question, what is the "13" value for at the end of the UARTWrite script lines Richard?

United Kingdom

Not bothered about the last question now. I'm ditching the SSC for a second V4 instead, as servo speed will be a lot easier to manage, besides, I need servo release which I have been unable to find a way of doing so far.

United Kingdom

I left a post on the RobotShop forum about releasing servos using the SSC-32, and here's part of their response...


There is no command currently to release a servo from holding a position (basically, to stop sending the pulse output). We will look into this for a possible update to the SSC-32U firmware.

We will investigate this possibility with the current firmware. It is possible there is a debug feature or an undocumented command that could be activated to permit this option.

If we come up with any new information on this situation we will post here again.



so hopefully the will add this at some point.