Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Canada
Asked — Edited
Resolved Resolved by DJ Sures!

Sound Board (Ezb) Control Difficulties

Hello, I just got my EZ-Robot developer kit today, and have been having a lot of fun playing around with it.

I've been having some difficulty getting the Sound Board (EZB) control to work though. I have selected an MP3 and pressed the play button, but there is no sound coming out of the robot.

I can get the robot to make sounds via the diagnostics in the built in web server, and I can also play the same MP3 via my PC using the Sound Board (PC) control.

Any ideas?

AI Support Bot
Related Content
Synthiam
United Kingdom
#1  
It may sound silly but I guess we need to start from the start.

The EZ-B is obviously connected to your network since you can access the web server, and the speaker works as it makes the diagnostic sounds so that's a good thing.

Have you connected ARC to the EZ-B?

Scan for (or manually type in if known) the IP of the EZ-B V4
Click on Connect
User-inserted image


The EZ-B should then chime indicating successful connection.

Once that is done the soundboard (EZ-B) should work through the EZ-B on board speaker.
#2  
Open up a script and type in the following...

Code:


sayezb("I am a robot")


Run the script and see if it plays through the ezb speaker...
#3  
Thanks for responding so quickly!

The ARC is connected to the board, as I am able to get the camera working through the ARC interface.

When I execute the script, I get an error (see below copied and pasted from the console)

Start
1: sayEZB("I am a robot")
> Error on line 1: Value cannot be null.
Parameter name: source
Done (00:00:00.0460026)

When I check the Syntax it says its OK.

This being said, I just tried the Sound Board (EZB) control again and it worked!

Not sure what the issue was before, but it seems to be working now.... weird.
United Kingdom
#4  
The camera working doesn't necessarily mean that ARC is connected to the EZ-B, the camera will work if the EZ-B is connected to the network.

However, it sounds like it's working now which is great. If it does happen again have a look to see if the debug gives any indication as to why sounds aren't playing.
PRO
Belgium
#5  
it looks like your missing this key )
United Kingdom
#6  
@nomad, that's just a forum glitch. If there is a winky face after some code which isn't wrapped in the code tags it generally means a closed bracket was used.

The syntax was correct. Was the code typed or was it copied and pasted? There is/was a slight glitch where copied and pasted code would cause problems. Always retype code.

Valid syntax is this;

Code:

SayEZB("I am a robot")


Which is exactly as Richard's code. Copying and pasting it may be the issue.
PRO
Synthiam
#8  
The original poster was not connected to the EZ-B. Connecting to the Camera is not connecting to the EZ-B. Follow the directions in this video of the Learn Section Tutorials


#9  
Thanks DJ!

I think you are right - the original issue was due to lack of connectivity with the EZB, I mistook the fact that I could see from the camera and access the web server as connectivity with ARC. Now that it is connected, it seems to be working.

Thanks for all your help everyone!
PRO
Synthiam
#10  
That's really great to hear Peter:)