United Kingdom
Asked — Edited
Resolved Resolved by thetechguru!

Smart Arrange And Cheat Sheet Help Needed

I have a couple of problems I'm hoping can be solved.

1.) Smart Arrange.

I'm having issues with "Smart Arrange". I have it disengaged/unticked and the project is saved in this state in both the Cloud and on my C: drive as I want to place where the controls are myself. When I add a new control, it rearranges everything I have done (except for control resize which stays the same) on that window. When I rearrange everything again and save the project, when it is reopened, the new control (say it was saved in window 2) appears on window 1. When I move it back to window 2 it gets hidden and I have to move all of the controls about to find it again. Moving the new control to the correct window and saving the project again, reopening it a third time and the control stays where it should (window 2 in his case). Is there something else I need to do to stop this from happening?

I've check previous threads on the same issue and followed what has been mentioned, but I still face the same problems. It's not a major problem, but can be a pain in the neck and time consuming putting everything back where I want it. I also sometimes get a problem where the tops of some of the controls are hidden behind the menu ribbon and I'm forced to use smart arrange to show hem properly again. It doesn't happen all of the time, just on occasion.

2.) Project Size.

Is there a maximum size for a project or amount of controls that can be added? The reason I ask is that my project, as it stands at the moment, is 2.846.549 Bytes. When I open a project all is well and it opens pretty quick. But closing it can take a while which I'm not that bothered about. My main problem with this, is that when I configure a scrip, half of my Cheat Sheet commands are missing. I scroll half way down and no more controls are on show, and when I continue to scroll to the bottom, the rest of the window is blank. I've done the closing project down/reopen thing as well as restarting the PC. ARC is up to date and I'm running an i5 processor with 8Gig RAM with no other applications running. I have smaller projects and don't have this problem.

Again, any ideas what could be causing this, such as the project size?



Upgrade to ARC Pro

Harnessing the power of ARC Pro, your robot can be more than just a simple automated machine.

United Kingdom

I just wanted to ask something else in regards to the second issue in the above post. Would having a Script Manager with say, for example, 600 scripts in it, use less system resources and/or decrease the project file size than having 20 separate Script Managers with 30 scripts in each?

I have done it the second way for now, using multiple managers, for easier management for finding a script that may need to be edited or manually executed, although I'm thinking mearging everything in to one manager my help to speed up the closing of a large project. Still unsure why half of my Cheat Sheet commands are missing though, and don't know if merging all my desperate script managers in to one would help as the amount of ControlCommands would remain pretty much the same.


@Steve G, I can't answer your questions but I can give you some comparisons - my main InMoov project file is 12,853,640 bytes in size and contains 156 Scripts in a Script manager. All of the Command Controls show up when I scroll either thru the Cheat Sheet or by right clicking in the script window. So maybe its something to do with your computer?

United Kingdom


Thanks for the reply. Deffo not the computer as it does the same thing on another one. Slightly lower spec but same symptoms. So it sounds like it's not file size then, maybe the amount of controls I have in the project?

@DJ and Jeremie.

Any ideas on the issues I facing guys?

United Kingdom


The right click for cheat sheets is very handy and all of the commands I have show up, unlike the scrolling method at the moment. I remember seeing this mentioned in an update release thread but completely forgot about it, so thanks for the reminder. I'm currently going through and merging all of the script managers in to one manager, so hopefully this may help.

Now to sort out the smart arrange issue, as the option is unchecked and is bugging me a bit having to rearrange the controls every time I add a new one.


Auto Arrange needs to be unchecked in three locations. File Open, Open from Cloud, and the project add dialog. (also, if you use shortcut creator to make a shortcut to your project, it will not auto-arrange when the project is opened from the shortcut). It sounds like you need to un-check it in the project add object dialog.

With these settings, when I add a new object to my project, it always appears on the upper left side of window 1 (behind my connection object), so I need t move the connection object to get to it, but then can it where I want. When I move it to another desktop, it moves to the same position it was last in on the desktop I moved it from, but again, behind whatever is there, so probably best while building a project to leave a blank spot as the destination for new objects.

I intermittently have the issue where an object isn't saved where I put it, but not consistently like you, so there is probably something I am doing that saves it "right" most of the time. I do tend to save to the cloud, then save locally often without closing my project so as not to lose work if I have some kind of crash. They are rare lately, but I have been using ARC for a long time and it hasn't always been as stable.



I have the same experience as Alan... new controls appear in the upper left corner when auto arrange is unchecked....

United Kingdom

Thanks guys. I wasn't aware there were other places to check/uncheck smart arrange as well. I'll check it out.


United Kingdom

It was the project add dialogue I was missing which was still checked. It now works as it should (unchecked) and new controls appear in the top left corner as you guys mentioned. It still doesn't save a new control on the correct window wheather it be window 2 or 3 on the first save, but stays put after that so I can live with it.

Thanks Alan, as well as Richard and Bob as this solves most of the issues and marking this as resolved, but if DJ or Jeremie is reading this, I'd like to know your thoughts on why half of the Cheat Sheet commands are not showing up using the scroll method.

Thanks again guys. :)