Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by DJ Sures!

Rss Feed Error

Rich,
Thank you, you have been very helpful to me!
There was one update where I could no longer run your RSS News Feed past the first story without error. I tried "" () marks. Maybe I missed it? Not sure what I am doing wrong?
Thanks
Steve S

AI Support Bot
Related Content
Synthiam
United Kingdom
#1  
I believe the issue was due to the WaitForSpeech command not working which has since been fixed with the updates to the EZ-Script syntax etc.

If I remember correctly, and I usually do, there are no changes needed to the script, just run the latest ARC and it should be OK.
United Kingdom
#2  
In case you changed it and saved it without realising what you changed the complete code is below. It's also on the cloud, just click on my user details and check my cloud uploads.

Code:


# RSS News Reading Script
# Author: Rich Pyke
# Version: 1.0.0
#
# RSS Script for reading news from RSS posts. Adapted from cafasarus
# script at http://www.ez-robot.com/Community/Forum/posts.aspx?threadId=3650

# Define variables
$feedurl = "http://feeds.reuters.com/Reuters/domesticNews";

# Do not change these variables
$sentinel = 0
$storyLn = 0

# Start the code
:begin
# Increment the story line by 1
$storyLn++
# Print the story number
Print($storyLn)
# Speak the story
SpeakRSSDescription($feedurl,$storyLn)
SayWait("Would you like me to continue?")
# Ask if it should continue to the next story
$response = WaitForSpeech(10,"YES","NO")
# If yes
IF ($response = "YES")
# Go back to the start
Goto(begin)
# Otherwise
ELSE
# Say OK
SayWait("Ok")
ENDIF
# End of script
Halt()
PRO
USA
#3  
Thank You Rich for responding so fast.
I performed the latest update and I cannot start my robot project.
When I try to load my project, it will not even load?
The error is "Unhandled exception has occurred."
Variable "Sound value must start with a "$".
Is there a way to download previous versions of ARC?
Thank You for your help.

Steve S
United Kingdom
#4  
post your project file here and I'll take a look and see if I can fix it.
PRO
USA
#5  
Thank you Rich,
My project is probably far from efficient or clean, but I will do that. It is a work in process.
I could not save it to cloud, timed out.
Yesterday I added sound files (soundboard), but it worked today till new update.
I sure appreciate your help.
Thank You
Steve S
PRO
USA
#6  
Rich,
I don,t know if this will help, but I tried my other files, and they also will not load.
I tried a system restore, but it stated system was not restored.
Maybe if I could get the old version that allowed RSS News to go to the 2nd news story? I will research what version it was.
I need the version prior to 2013 07 10, I think it is 2013 07 03
That might work till I get a new computer.

Thank You
Steve S
PRO
Synthiam
#7  
Get the latest ARC and try again. The issue is with the Sound servo variable not being declared correctly.

1) load your project

2) select the CONFIG option of the sound servo

3) add a $ to the beginning of the variable you are using for it

4) Press SAVE

Now save your project. Any other projects with sound servo will need a $ in the front of the variable name.

:)
PRO
USA
#8  
D.J.
That was very fast help!
Excellent and precise instructions.
Thank You so much. EZ Robot and the community are both awesome!
I also added "", for Roomba("init") during connection, I have a few more scripts to clean up.
Robot Captain Ann Droid moves again.
Thank You
Steve S