Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
AI Support Bot
Related Content
Synthiam
#1  
I am liking these new videos you put up today. Very professional feeling.

Alan
PRO
Synthiam
#2  
It's been a while! It's funny because it's the same format as the old ez-robot videos when I worked out of my basement. I'm glad you like them:D

It's time for lots of tutorial videos now that there are lots of features... and more hardware to come as well.
#3  
So during this demonstration towards the end you coded the robot to say see my fancy animation or something to that effect. However it did not say anything in the end video? This is not meant as criticism but I noticed today after updating to 4 18 software during a brief showing of my robot to some children the robot would accept the move forward command but not actually move foreward. When running the script manually from the script editor it worked every time. The only reason I caught it was because when I give the robot a spoken command " move forward" it repeats back to me the said command and then acts upon it. Any ideas?
#4  
For what it's worth none of the spoken commands worked, yet did dictate what the spoken command was. Hmmm
#5  
@kamaroman68 ... It's just the way he did the video.... maybe he removed the "say" command line before showing the result with JD? Maybe it was videoed in segments where things like scripts changed between segments?... It is just a video and you can make videos do anything you want them to do... If it works in the real world it's not really that much of a big deal with this slight oversight, right? Cut the poor guy some slack... He's wearing a million different hats at ez robot...:)

Everything works fine in my projects with ARC so how the video turned out doesn't concern me at all...

Remember your robot is only going to move forward if you have set everything up properly... programming, mechanics, power etc.... When my bots don't work as expected it is 99.9% usually my fault...
#6  
So again my robot worked fine yesterday , today after new software download it does not. There are no new mechanical or programming changes. I also said there was no criticism intended so I'm not sure where cut the guy some slack is coming from. But thanks for the reply Richard
PRO
Synthiam
#7  
1) There are no reported issues with the latest ARC for moving. Please check your robot configuration and wiring. Also check your program to verify it is setup correctly. Perhaps provide us details about what robot you have, what program you are using, and if it is a stock project, what has been changed would be helpful. If you'd like me to look at it, share the project and i'll test it.

2) Correct, the robot does not speak anything in the end of the video even though I coded it in the example - good eye, or ear in this case... However, i'm certain the point of the video is still effective. If not, I apologize. There are no immediate plans to redo the video to add the audio.
#8  
Thank you both for completely reading my entire post. I will again refrain from posting on this site.
#9  
@kamaroman68 Sorry to hear that... Not sure what you are so upset at... I do remember you as being very thinned skinned around here... But really don't you think you are over reacting a little bit?... Not posting here only hurts you my friend....

I promise you my posts had absolutely no malice whatsoever in them... Try not to see so much negativity in posts. Maybe I am a bit sarcastic and ironic, but I am never outright discourteous...

Have you tried rebooting? re-downloading and reinstalling ARC? Re loading your project.... If I had a nickel every time windows caused an issue with software I was using... well you know the old saying...:)

You know I have my share of head scratching issues with ARC. It may seem like I am defending ARC just because I believe in it... Well, yes I do... but mostly because when encountering a problem that I thought for sure was an ARC bug it usually turned out to be something I did... So I am reluctant to post my issues because as I mentioned 99.9% of the time it was something I did or changed or whatever....
#10  
@kamaroman68

Steve had something very similar happen last week. In trying to determine if one of the project objects was at fault he imported his project into a new project and everything worked. Something had clearly become corrupt in the original project file. I don't believe it coincided with an ARC upgrade, but might have.

Anyway, importing your project objects into a new project might be worth a shot.

Did you keep a copy of the previous release you can try to revert to? That would be another good troubleshooting method.



Alan
PRO
Synthiam
#11  
Kam, if you post the project, someone or myself will test it