Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Questions Installing 2015.12.19.00 Version

I am a long time user of EZ-Robot. This is the first time I have had any problems installing a new version.

A bit of history about the computer I am using:
It is a Dell 'Latitude' Lap Top.
I used Windows 7 until last week when I was convinced that Windows 10 would be an improvement.
That was a big mistake for me. The WiFi connections became unreliable. I had to manually connect to my router many times.
I was given the opportunity to go back to Windows 7. I took it.

When I tried to load the latest version of ARC (2015.12.19.00) the download of the ARC Installer went as usual, the icon appeared on my Desktop.
I chose the Complete installation, hit "Install" and got this window:



User-inserted image

I hit OK in that window and got this:


User-inserted image

I hit OK again and got the same window so I hit Cancel and got this:


User-inserted image

I hit OK and got this:


User-inserted image


Help!

AI Support Bot
Related Content
Synthiam
#3  
Justin,
Do you think I should try to delete the 'EZ-Robot Inc folder from my Program Files(x86) folder?
#5  
@DJ,
I jumped through all the hoops,
I went to: http://www.ez-robot.com/Community/Forum/Thread?threadId=8749
Did the steps in: ahttp://www.theeldergeek.com/manually_uninstall_programs.htm
Tried @thetechguru's:
msiexec /i "C:\Users\your windows user name\Downloads\ARC.msi"
None of these worked. In frustration I even did a system restore. Still no joy.
Google came to the rescue with a path to:
http://support.microsoft.com/kb/2438651
This microsoft support "How to troubleshoot Windows Installer errors" shows an option:
Run the troubleshooter to fix the problem automatically.
To fix this problem automatticaly run the "Fix problems that programs cannot be installed or uninstalled" troubleshooter to repair issues that block program installation or removal because of corrupted registry keys.

That went to a window that said,
"Fix problems that programs cannot be installed or uninstalled"
A Fixit sub window has a Run NOW button.
That loaded a program called: MicrosoftFixit.ProgramInstallUninstall.RNP.Run.exe

Running that program worked!
All is now well at the OldBotMaker's lab.
Merry Christmas and happy New Year to all EZ Robot owners, wanna be owners, operators, and staff.
#6  
Awesome. Bookmarking this thread for future reference.

(fyi... Very surprised to hear you had issues with Windows 10. It has been flawless for mw, and fixed WiFi issues on two of my computers)..

Alan
#7  
@thetechguru,
It was the WiFi issues that made me dump W10. Half the time when I turned the lap top on, the WiFi would not connect because the connection could not be found. Had to use the Network Troubleshooter to find and connect.
Others (DJS) have said that W10 does not handle WiFi well on some platforms.
#8  
I guess I have just been lucky. Thanks for posting about the uninstall fixer. That is a great find.
#9  
Almost forgot - this issue has been caused and resolved by Microsoft.
PRO
Synthiam
#10  
I think what's happening is Windows 10 is removing the original ARC installation source file. They are stored in a folder in the Windows folder.

If those files are removed, stuff like this happens. Now what's funny is the installation msi for Microsoft handles all that / so they're doing it to themselves.

Oh well!
#11  
oldrobotbuilder,

I have the EXACT same problem that you had. Except when my uninstaller tries to work, It cannot find the file in the list.
#13  
Thanks Alan and Steve and DJ, I tried everything, but it still won't let me install on Win7. it gets to the point of removing old files. Sometimes it sees the other older file still in there but cannot be erased.


:-(
#15  
I downloaded the newest ARC last night and am having the same trouble oldrobotbuilder is having, I have windows 10 and this is the first problem I've gotten with it. I followed a few threads, but to no avail. I am running an MSI laptop, I-5 CPU, 8 G memory and Nvidia graphics card. Please help.
#16  
Did you see the link in post #15? @Alan has posted a link to a possible solution. ...
#18  
Yeah, missed it as I was typing. Thanks all, I'll see what happens after work today.
#19  
Hi,
Thanks for the help with this problem, I tried everything listed, the windows fixit isn't compatible with 10, I cleared everything pertaining to EZ-B off the hard drive and out of the registry, but, it is still listed on the uninstall screen and still will not install, I keep getting a "Can't uninstall older version. Contact tech support" message. I tried everything I could think of, short of reinstalling windows.
PRO
Synthiam
#20  
Grrrrr Microsoft!

There must be something still in registry - that's where Microsoft Add/Remove Programs keeps the list of installed programs. If it won't install, that's the only thing left is the registry.
#21  
When the install fails, it will produce a log file which tells you exactly why it is failing. See my post a couple up from here. There is a registry entry that does not list ARC that needa to be deleted. The specific entry will be in the log.

Alan
#22  
Thanks guys,
Took some digging, but finally managed to find the log Alan was talking about. Deleted it and everything's running good.