Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by Dave Schulpius!

Question With Servo

Hi,

I am having problems with the JD robot's left foot/ankle servo. It doesn't seem to move as freely as the others. I first noticed when having the robot walk. When I manually try to move it, it feels stiffer than the other servos. Is this just a bad servo that needs to be replaced or are there any tricks that a I can use to fix it myself?

Thanks

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
PRO
Synthiam
#1  
Usually a servo either works or doesn't work. In this case, it sounds as if the screw holding the ankle onto the servo may be too tight. This would prevent the servo from moving freely.

Because the gearing inside of a servo is a high ratio, that increases the ability to "feel" if a servo is stiffer than another. The metal gears internally convert the high speed motor into high torque output. So, when you turn the shaft, you are essentially turning the gears in a direction of a ration that was designed for the opposite direction.

That being said, because a servo either works or doesn't... I would assume the screw may be too tight holding the ankle in place. That is extremely rare because we designed the components to not touch each other even when the screw is tight - however, plastic does have a lot more flexibility:)

A servo motor moves until it reaches the specified angle.

Also, keep in mind that JD doesn't walk perfectly straight due to slipping a little on the floor. This is quite normal for humanoid bipedal robots. We have a new app being released soon that uses 2 additional servos for hips. That helps JD walk a little straighter.
#2  
Thanks for the reply.

However, I think the servo is bad. I tried calibrating (after first manipulating the joint out of 90 degrees), but it does not move. Also I lifted JD while he was walking and that ankle does not move like the other.
#3  
@hihuq, click on the Product Warranty button in the Contact Us section and fill out the email form to send your issue off to EZ Robot. Their service department should be able to get you another servo rather quickly.

For some reason when you click on the Technical Support button it sends you to this Forum . I know that can be frustrating but most of the time the people here can get your issues solved faster then the guys and gals at EZ Robot. *cool*
#4  
Thanks Dave.

I've tried the contact us/ product warranty button, and filled in info, a couple of times now. Every time I try to submit, it comes back with an error.
#6  
What Error? What is it saying?

A couple things you need to do:

Are you doing the Human Verification at the top?
Is your email correct and the same one you signed up with?
Did you select a choice from the drop down menu for a Warranty Reason?
Also make sure your clicking the box at the bottom that your not asking for tech support.
#7  
Its a generic error. Link is https://www.ez-robot.com/error.aspx and text is as follows:

" Error!

Now look, you've gone and broken something!

Just kidding it's probably our fault. The error has been logged and staff has been notified.

If you think there has been a mistake, or you need help, please contact us. "




I've done the human verification, email is correct and consistent with my sign up, drop down menu warranty reason selected, not asking for tech support box is checked.

Occurs with both metro and desktop versions of IE.
#8  
Try switching to another browser like Firefox or Google Chrome or Safari.
#9  
I get the same error on Google chrome on windows 8, as well as on safari on ios. I don't think its anything on my end.
#10  
hihuq Agree, if you have gone through all those browsers then it is evidently some sort of form issue with EZB. I was going to try and make a fake report but decided not to. I'm sure the support folks will be online tomorrow and will provide a solution to this.
#11  
@hihug, Sorry this is happening to you. The gang at EZ Robot is usually very good about checking up here on the forum and also following up with any problems that arise with their customers. I'm sure your issue with the servo and the email form wont go unnoticed and it will be cleared up quickly.

It sucks that this happened to your robot over the holidays. The EZ Robot gang are a small group and they've been spending the past year working to build this amazing product. I'm sure they'er spending some well deserved time off and with their families. However I know that doesn't really matter much when a paying customer is needing help. Hang in there and I'm sure things will get straightened out.

My advice is to try sending the form again in a day or two and bump this thread again if that doesn't work.
#12  
Hi,

Hopefully the powers that be will see this message.

I was finally successful in submitting a warranty request by choosing "Missing Parts in Package" in the drop down for the warranty reason. I had been selecting "Defective Part" and this is what was causing the site error.

Thanks for everybody's input.
#13  
Oh, the reason for warrenty return is a new drop down. Must not have been fully tested before deployment.

Alan
#14  
Thanks for everyone's input. EZ-Robot sent me a replacement servo, and after minor foot surgery, I was able to get everything working again.