Welcome to Synthiam!

The easiest way to program the most powerful robots. Use technologies by leading industry experts. ARC is a free-to-use robot programming software that makes servo automation, computer vision, autonomous navigation, and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by Steve G!

Powering The Ez-B V4

Hey guys,
I just put together my first robot using Lego Technic and some Tower Pro 9g Micro Servos... This worked perfect as a trial and error solution because the servos are exactly fitting into the Lego parts and the material is light enough to be driven by those weak servos!

It is kind of a wobbly assembly but it is good for testing and quit forgiving when it comes to parts bumping together head-on!:D

Sooooo my question is... I experience very jerky movement at some points in my animation.
Most transitions are smooth but every now and then there is erratic movement, which seems to disappear if I notch up the power send to the EZ-B from 7.4Volts to about 9Volts!

Is this a proper solution or will this damage the board?
I am also using a very small and cheap 1.5A Power Supply, should I switch to a bigger one so the servos are being supported better?

Let me know so I don't damage my board!;)


ARC Pro

Upgrade to ARC Pro

Synthiam ARC Pro is a cool new tool that will help unleash your creativity with programming robots in just seconds!

AI Support Bot
Related Content
Synthiam
United Kingdom
#1  
Voltage is not your problem for jerky servo movements, it's the amps they are trying to draw. The 1.5amp power supply will not be enough to power servos for when they begin to move, as they will draw a few amps. Read the tutorial linked below, that explans power supply requirements for powering a servo and multiple servos.

http://www.ez-robot.com/Tutorials/UserTutorials/163/1

You are better off with a LiPo or NiMH battery pack or switching power supply with a much higher current output.

As for the servos, what are the specs for the servos you are using... mainly, what is the voltage range for the servos? If they are rated for 7 volts, giving them 9v could quite possibly damage them. Only use the correct voltage range that the servos are rated for, no more, no less. The EZ-B can take up to 16 volts, but remember whatever voltage you give the EZ-B, will come out of the red power pins on the digital ports.

The link I supplied above, will also give you the details of the EZ-B's power specifications.
#2  
Read this.... Understanding volts vs amps

*EDIT* Disregard... Steve already posted the link...

I find it really strange that volts/amps correlation confuses so many people... And I am not talking average people but people who are advanced programmers and IT gurus.... *confused* You should know this not because of just robotics, but because all electronic devices at work and in your house/car etc... I mean you can't install a simple GPS or cell phone outlet on a motorcycle without knowing what is the difference between amps and volts.... These power questions seem to come up frequently on the forum.... Just sayn'
United Kingdom
#3  
@Richard.

I find that too. Also, the people I speak to, friends, family, old work collages etc, don't seem to see amperage as important as voltage, or disregard current altogether. Like I say to them... It's not the volts that will
Kill you, it's the Amps.
#4  
That's why many people survive lightning strikes.... Millions of volts but very little current behind it... It may be that even a 12V car battery has more current than a lightning bolt? Who knows LOL
#5  
I learned this lesson the hard way when I was 17 working in an arcade fixing machines. Lots of amps in the back of a CRT type monitor or in the coils that make the flippers and bumpers work on a pinball machine. I was thrown back and put a hole the size of my 6'4" 240 lb frame in a wall one day while working on a machine without grounding the screw driver that I used to pop the plug on the back of the cable carrying power to the back of a CRT monitor. It taught me well that day...

I still laugh about this with friends that I know from that time. I am sure I smelt a bit burnt, but the lesson was "pounded into my head" so to speak.
#6  
@David... It's funny now right?:P I did something very stupid too... many years back.... I was testing a spark plug on my motorcycle at the time. I pulled the plug so I could see if it was sparking (because the bike wouldn't start). I put the plug back in the spark plug cable cap with the intention of grounding it against the engine case. Then pushing the starter I would be able to see if the plug would fire or not. Well I was holding the plug in my hand while I pushed the starter... I must of also grounded myself to the frame because I got a nice dose of ~30,000v from the bikes coils... Rattled my teeth... Very stupid lesson learned...:)
#7  
Yea, I have made the mistake of holding spark plug wires also. You know, it is really amazing that we survived our youth. I used to work on all of my own stuff to fix it because I had no money to spend to have others fix things. I used to get so mad at my dad for making me spend the weekend fixing my own car. I remember thinking that when I get older, I am going to make enough money to pay for someone to do this crap. Now that I am older and have the money to pay someone, I enjoy fixing my own stuff. My children, on the other hand don't yet have the appreciation of knowing what it feels like to fix your own things. My wife and I both would rather remodel our own kitchen than pay someone to do it.

How times have changed, and how smart my father is...
#8  
@David... I had a very little supervision as a child .... Yes, it is surprising my brothers and I ever made it past our teens....

I have always fixed my own stuff as well... To save money but also to learn how stuff worked.... We didn't have the luxury of youtube as kids either. So if anything kids now days should be way better at repairing and building their own things...:)
#9  
Supervision, yea same here. When I was 4 I wondered off from home through a forest behind my house. I ended up by the highway and some guy stopped and picked me up. I directed him back to my house and he was amazed at how far I had walked, but even more amazed that I knew how to get back home. He took me to the door and my dad answered it. This man that brought me home was his Commanding Officer. I never found out what happened to my dad, but at the time he was working at the Pentagon designing the communications systems on the E4-B military airplane (google it). I am sure it didn't go well, but he was the first employee on the entire project.

I wondered what he and my mom were thinking when I was in my 20's allowing my brother and I to just roam and experience things. I now appreciate it a lot more. Society has changed so much that now kids can't play in their front yard in most cities. We would be gone all day in 0 degree weather. We would go camping for the weekend when it was -18 degrees C. Now kids don't like being outside when it is below +18 degrees C.

so many things have come to mind that I would never let my children do now that I was allowed to do when I was young. The issue is that my kids don't have a clue what an Amp or a Volt is. If the plug fits the electronic device, it has to be good, right?
#10  
I think we as humans (animals as well) do better if there is some stress and struggle to deal with in life.... I mean "it is the presence of wolves that make deer swift and strong, not their absence"....

Taking away everything that could potentially harm our children would rob them of experiencing life the way we did and our father's did and so on... Bubble wrapping them and putting them in the basement to keep them safe has to be a form of child abuse... My ex-girlfriends kids didn't want to do anything but video games and tv... Any kind of discomfort and they would whine like they had a broken leg or something... Now I know why.... they never had to struggle... If it isn't easy they quit... My grandfather who fought in WW2 would be ashamed...

Anyway, you are right about the changing world... it's different than when we were kids... so what do you do? How do you keep the children safe yet at the same time let struggle a bit and teaching them the awesome reward of "fruits of their labour"...?
#11  
Hey guys, thanks for the advice and the link, I will try to figure out better how stuff works before just putting it together and hooking it up to to some random power source!:D

I was just toying around and trying to figure out how to get those things to work and did not really pay much attention on calculating anything, that is why I bought those cheap servos...which does not mean I was up to damage damage them intentionally!;)

I will go get a better power source from the basement and check how good it'll do!

These are the servos I bought, my current robot has 10 of those...

http://www.micropik.com/PDF/SG90Servo.pdf

So correct me if I am wrong, but I should put 4.8Volts to the Ez-B to power the board which can work from 4.5Volts as noted in the specsheet, plus get me a better powersupply which will provide enough amps for my servos but does not have a higher constant current than 5amps ?

Also one more thing, I noticed that all servos jerk to some weird position once I power up my EZ-B...which is kind of annoying. Is there any way to stop this?

Thanks for your help guys!
#12  
First, the servo question...
Analog servos jerk when power is applied. Digital servos do not.

You have the correct idea about the amps/volts. The v4 can run from 4.8 volts with no issue. The digital ports on the v4 are not regulated, so if you are going to run 5 volt servos, it is best to run a 5 volt supply generally speaking.

Dont confuse digital servos and digital ports. Analog servos still connect to digital ports.

Also, sorry about sidetracking your thread. No insult intended.
#13  
Never mind. Dave beat me to the answer

Alan
United Kingdom
#14  
@Mickey.

Yes, running them 4.8v servos you linked to off an EZ-B running off a 7.4v power source would damage them, and 9 volts will probably fry them pretty quickly.
#15  
@Mickey666Maus yes the ezb can run off of 4.8v... However, that voltage is near the absolute minimum to keep the ezb alive... Any drop in voltage would or could mean constants "brown outs" and rebooting of the ezb4.... I would suggest using a higher voltage for the ezb4... Like 7.4v...
#16  
Thanks a lot guys, that should help me to get going!

I found this old beast in the dungeon...lets see what it'll do to my feeble little lego creature!

voltcraft ps 303 pro

Btw, this seems to be a vital community, where a simple question about voltage sparks thoughts on life, death and wolfs lurking in the forest!
Thanks all!:)

I dont know yet about this kudos system here in the forum so I guess this wraps up the topic and Steve G was the first to answer...am I doing this right?
#17  
Threads go astray sometimes... what's important is that you hopefully got your answer and are good to go now...:)
#18  
Re: Kudos, first or best, your choice. It means real money. Current bounty is $3 in store credit for answered questions (which is why there are some terms of service around marking a question as needing assistance vs general discussion).

Alan
#19  
Ok, good to know...

One more thing, I just hooked up the EZ-B on 5Volts and it gives me a battery is low warning! Any clues why or how to stop this?:)
#21  
Yep... 2 ways... 1) go into the connection control settings in ARC and disable the low voltage warning chant....2) You can also do it in the ezb4 web server, but you will have to be in AP mode first in order to access the web server...
#23  
@Richard R, you don't need to be in AP mode to access the web server. Just need to know the client mode address.

Alan
#25  
Hey, I hope it is OK to post once more to this thread as it is already marked as resolved, I can also open a new one...but since this is sort the the sequel to the stuff already been discussed I thought I might give it a try!

I am having a 5amps power supply set to 5volts so the EZ-B and my servos are getting the specified amount of operating voltage!

My power supply is an old ELC from France, and the EZ-B plus 10 servos are connected, the servos would be Tower Pro SG90 Micro servo 9g.

My movements are smooth and without jittering, but at a certain point the servos are moving erratic, I made some animation using the AutoPositioner in ARC...It seems like every 10th cycle of the animation will get a problem, then it'll go back to normal again!
Also at 5Volts I can hear little crackling noises from the EZ-B, why could that be?
It does not make these sounds when it runs on 7.4Volts!

What would be the solution to this problem, how would I calculate the amps my servo setup needs to run steady, how about spikes?
Should I just try another power supply, or should I try to bump up the voltage? I heard those servos should take up to 7.4volts without a problem!

Let me know how you would takle this beast....;)
#26  
Here is what I suspect is happening and how you can test it out...

When a servo starts to move, it consumes a lot of amps. I suspect that you are seeing are issues when you move 3 or 4 servos at the same time.

Each servo is probably taking about 1.2 amps for a second or so.

Try to start moving 2 servos at the same time and I bet they don't jerk. If you then try to start moving 4 at the same time, I would suspect that they jerk. It would be interesting to know if the sound from the ezb happens when the servos are jerky. I suspect that it is.

Let us know the results.
#27  
You could then add two more and try again. At some point, you will see that the current is too much for the supply. 10 servos on 5 amps is too much draw (not enough amps).

You could use super capacitors to limit the issue. These would be like small batteries preventing this jerky action.
#28  
Thanks a lot for the info...actually you were right about the noise coming from the EZ-B, it happens when those servos start jerking! Sometimes I guess also when there are a lot of servos attached while those servos are supporting some load, could this also be the case?

Good to know these sparking sounds are know, it was kind of eerie!:D

I tried out what you advised and found that the lab power supply I am using is already having problems with only one of the heavy duty servos that ship with the developers kit... so I guess I will have to look for another power supply right?

The capacitor idea sounds also interesting...

The thing is that right now I am still sort of fooling around with the setup and I do not have a specific plan on how the final thing should turn out...so my plan was to invest in a power supply once I know what I will build!

It does kind of make no sense though if I cannot really do anything to my robot because it is having seizures every second move...:D

So what would be your advice on how to power my test model?
#29  
Actually giving it a second thought, I guess the capacitor solution would not make too much sense for me right now, with the given space limitations I think there is no room for all the extra wiring and the volume those capacitors would take...I would have to make a new connection between each servo and connecting port on the EZ-B right?
#30  
You can jsut add the caps to any analog port on the EZB and it supports all the plugged in devices. There is a discussion around here somewhere with the details.

For alternative power, the developers kit does come with a AA battery adapter. If you use rechargable NiMH batteries (I suggest Panasonic Eneloop) they actually handle the momentary inrush current very well. Even better would be to get a 7.4v LiPo battery and charger. Cheaper than an adequate power supply, but does limit your test time since you will need to recharge the battery when it dies. Even 2 batteries and a charger would be less expensive than a good power supply thought.

Alan
#32  
Thanks a lot Alan, I will check this as soon as I do have the time!;)

I was actually looking for a power supply because I tried to power my EZ-B with rechargeable AA batteries but it was really draining them so fast that I thought it will be a mess if I want to get stuff done and I can't because I need to wait for them to charge!

I would not mind to invest in a power supply, but it would be kind of stupid to buy this in such an early testing stage, if there would be something out there that I could use for a long time without needing to change if I work on future project I could go for it though!

The super car mod looks cool, I will check this for sure! Thanks Alan;)
#33  
Yeah, the NiMH AA's don't last long. I bought a box of 12 and an 8 port charger, so I can have one set charging while using the other, but that still didn't give me a lot to work with since the charge time is a lot longer than the use time. LiPO last a lot longer and recharge a little faster, but still.....

Alan
#35  
This looks very good!

It should work perfect for the EZ-B and the servos that ship with the developers kit right?

The only thing is the right now those servos I am using should have 4.8Volts supplied...as though I guess from what I have been reading in reviews they should be able to run on 7.5Volts without blowing up!:D

Should I just get any type of potentiometer, or is there a post on voltage regulation for power supplies with fixed voltage....it seems like you can adjust 10% but this would not let me lower the output to 4.8Volts...

At the moment I could still go brute force, but of course in the process I would like to get the specified voltage to my servos to make sure they last!

Since I am a newbie to robotics I would totally trust your judgement on this and just go for it...seems to be a pretty good deal!

Thanks for helping me out Steve!:D
#36  
@Mickey666Maus Steve gave you a great option... I am actually thinking of buying one myself...:)
United Kingdom
#37  
@Micky.

No problem. Yeah, the supply I linked to will work great with the servos supplied with the Dev kit (I may get one myself too), as they run best at 7.4v (the .1v from 7.5v is nominal and nothing to be concerned about. A fully charged LiPo sits around 8 volts to start with, straight off the charger.)

For the 4.8v servos, an option could be to add a 5v regulator or drop down Buck converter (similar to a regulator) to each one, which would drop the EZ-B's 7.4v supply to 5v. It all depends on your robot setup really. If you did go this route, my recommendation would be to make sure that the regulators can supply at least 3 amps.
#38  
In the 'Specific Recommendation For Power Adapter' post where also the use of super caps is discussed someone found this step down voltage regulator....but it only allows 2.5Amps, should I used this one or search for one that supports 3amps?

https://www.pololu.com/product/2852

Also correct me if I am getting this wrong...the voltage regulator would be linked between the power supply and the EZ-B right, not between the EZ-B and the servos? Because you wrote.... 'For the 4.8v servos, an option could be to add a 5v regulator or drop down Buck converter (similar to a regulator) to each one,'

This part confused me a little...

My current test setup has only those 4.8Volts micro servos, but I plan to use the heavy duty servos that shipped with the developers kit very soon!
#39  
OK...found it! They cannot really handle enough current ,so I would need one of the regulators for each servo then I guess!
United Kingdom
#40  
I'll answer the second question first. If you put a regulator between the power supply and the EZ-B, every digital port power (Vcc) pin on the EZ-B will only get the reduced voltage. Drawing too much current from the regulator will probably damage it. Using a regulator this way might suit some projects, but may not for others. Putting the regulator between the digital pins and each servo for example, will only reduce the current and voltage to that servo.

The thing to remember... you can supply a servo 100 amps or more, but the servo will only draw what it needs.

As for the first question, it really depends on the servo in question. You may get away with 2.5 amps per servo (just to cover the inrush current which is when a servo starts to move), but personally, I'd say the higher amp output for a regulator, the better. Better to have too much than not enough.

I hope that clear things up a bit better, but if your still not sure, don't hesitate to ask.:)
#41  
Thanks Steve....I am on it, trying to work my way thru the tutorials!

Thanks a lot for the help, it could be that I'll bother you again with some noob stuff soon!;)

It really fun so far!:D
#42  
Noob stuff is great. If you have the drive to learn and push yourself, in no time you will be providing the answers. I am impressed that you are pushing yourself to understand the answers. Good job!
#43  
I'd like to clarify something. You can place a regulator between the power supply and ezb. It Won’t chock the amps you need. However, what will happen is your device will pull all the amps it needs and if that regulator isn't rated to handle the current being drawn through it then it will burn up. Same principle with your wiring. If they aren't big enough to carry the amps being pulled through them they will heat up and maybe even melt. Go ahead a install a regulator. Just make sure it's rated for the load that all your devices will pull. I can recommend a nice BIC that will handle up to 10 amps if you're interested.
United Kingdom
#44  
Sorry, I got caught up with something. Thanks for clearing that up Dave (post corrected).

Yes I could have explained that better. Bottom line is, make sure any regulator that is used is able to provide enough current/amps that the attached device will need.

I explans it better in this step of my tutorial.

That'll teach me to multitask.;)
#45  
That was actually the thing I was digging thru right now Steve!:D

You guys are a great help! I am having a great time...super stoked!

You only get to build your first robot once in a lifetime right?:D:D
#46  
@Mickey666Maus... I like you man:) Now just be careful not to release the magical blue smoke and I am sure your bot will be awesome....:)
#47  
The magical blue smoke is not to be released yet the golem needs to be awakened!:D
#48  
"You only get to build your first robot once in a lifetime right? Grin Grin"

LOL, This is so true! I've been building my 1st robot now for about 4 years! I've had such a blast with it I just cant bring my self to finish it. :P It's truly an ongoing project. "A B9 Robot is never done."
#49  
I ordered that power supply, it's in the mail already!
Let's see if I can get to make her move....cause you are totally right about this Dave, it should stay an ongoing project! I am having the feeling that the more I get into it the more ideas on what I would like to try out I get!:)

And naming your robot is the best part of it....I was trying to come up with a good name, and have been rolling all these know robots around in my head, also what kind of features they are having, how human or machinelike a name can be and still work!

The HAL 9000 is still my favorite for having a spaceship as a body and being a total sociopath....and obviously nothing beats the best robot duo ever, where one does not have a facial expression but awesome body language, while the other one does not even speak at all but we all all drawn in emotionally at such a great deal which makes us wonder how we can feel so much for something that is quoted by his partner as nothing but a 'nearsighted scrap pile':D

So I am sort of tending towards K8 [kate] or KD [katie] to still be sticking to a machine type name but also being able to adress the robot with a name!

Let's call it a working title for now!;)
#51  
Dot Matrix
Pixel
Velma Staplebot, from The Lego Movie (2014)
MsTAKE
Ping
Iris
ED, EDI, EDE (Eaddie)
BL, BEL (Bell)
ANI, ANE (Annie)
VKI, VKE (Vickey)
BNI, BNE (Bunny)
JNI, JNE (Jenny)
JLI, JLE (Julie)
BKI, BKE (Becky)
KRN (Karen)
MRY (Mary)
MRI, MRE (Marie)
NCI, NCE (Nancy)
KAT
HLN (Hellen)
ELN (Ellen)
IDA
NAN

And then there is the Robot Name Generator
#52  
How could I forget Marvin... *stress*

Don't blame you," said Marvin and counted five hundred and ninety-seven thousand million sheep before falling asleep again a second later.
#53  
Hey guys, I am just trying to figure out something here and I thought I'll just put it up here before starting a new topic...correct me if this is getting too messy and I should just open a new discussion!

I just got me IFTTT to get my robot interact better with me and its enviroment, I was thinking to trigger events with FitBit data or just get the robot to know it's me who entered the flat....also it could warn me to take an umbrella in case it is raining!:D

So just for testing purposes I wanted to set up a DO button which triggers a Maker Channel event....in this case just moving one servo a a testing scenario!

So I put

192.168.178.94/Exec?password=admin&script=Servo(D23,90)

to the URL field, chose GET as a method and left the other fields blank!

Am I doing this right or do I need to add this secret number, I connected to the maker channel but did not receive the number....any clues?
#54  
You'll need your public IP address, and have your router port forward from your public to private address to the port running your EZ-B web server (80 by default) amd of course you'll need the web service active in your project.

I believe the maker channel key is only needed when you want to have your EZ-B (or other device) us the Maker Channel as the "This" not the "that" in your recipe (I haven't tried it yet. On my todo list).

Alan
#55  
So if I use something like http://www.whatsmyip.org/ this would be my public IP adresss I guess....how would I find out my private ip?

So I will have to port forward public ---> private ---> port 80
#56  
Your private ip is the ip of the computer running ARC. Open a command promp and type ipconfig to find it.

You should probably set your router to always give you the same ip address (you could do the same for the EZ-B itself so you don't need to search for it every time you turn it on)

Alan
#57  
OK, lets see if I can get this done....but I guess I should!
I guess a fixed ip for the router necessary otherwise I would have to redo the whole thing daily right? How would I get to have my EZ-B set to a fixed ip address?
#58  
You would do this by assigning a static DHCP lease to the mac address of the EZ-B or any other device that needed a consistent IP in your router.
#59  
I am on it guys...thanks for the info, it's a bit messy so I hope I will not get too confused!:D
#60  
If you get stuck, post the make and model of your router and I'll find an online manual and provide more detailed instructions. I have been throwing out quick answers to guide you in the right direction because I have a lot to get done today, but I could sit down this evening and give more detailed instructions if you can't make it work.

Alan
#62  
SORRRRYYYY.....It works, I forgot that I had to put the public ip into the code of the DO button!

Thanks for your help! Now I can tweak my IFTTT stuff and make the robot correspond!

AWESOME!:D
#63  
Thanks Alan, this has been great help! I saw you being involved in some questions about IFTTT in other discussions here on the forum, but those did not cover getting it connected to the EZ-Bs web server....

Thanks you so much for responding so quickly although you are having stuff to do, I really appreciate it!
#64  
Cool! Be aware that your public IP will probably change if your router reboots. You can sign up for a service like http://dyn.com/dns/ that gives your ip address a name (and you run a client on the pc that keepz the service up to date). Dyndns used to free but is now $40/year. There may still be free services. I use zoneedit, but I have my own domain, and it is not as simple to set up and manage. I think new accounts are also not free anymore.

Alan
#65  
Thanks for the info Alan!:)

I heard about dyn.com while researching on the topic....I do have a domain, so if there would be a workaround to skip yet another subscription I would be grateful!

I will try to check if there is a free service available!
I thought if I'd fix my laptop with a static ip this would be good enough, but good to know there might be another thing to take care of!

Hope you'll get your stuff done...the EZ robot is so good for procrastination, it keeps me from doing my tax paperwork like a charm!:D
#66  
Hey guys, one more thing....do I even have to try to get the SpeakTwitter script command to work, or should I just find something else?

I read in an old discussion that the discontinued their RSS feed requests and there is no workaround yet. Should I try to get it working or just find me some RSS feeds to play?;)
#68  
NOOOOOOOOOOOOOO!

Talking about the magical blue smoke!

RIP, my first robot just died! May his servos rest in peace!

I got that power supply today and hooked up to my EZ-B, I ordered the right one...also on the invoice it said it is the one I ordered and being so eager to test it on my robot I wanted to get it to work!

Well it only worked one time....they send me a 15Volts by mistake!
This will teach me a lesson I guess!

Good I had these cheap test servos hooked up....10 servos down in one go!

Guess I will call it a day, get them to send me the right power supply and order new servos....I'll fix me a drink guys, to all those dead servos! *stress*
#69  
Ouch.... Glad they were cheap servos. I think most of us have seen the blue smoke a few times. Usually when overly tired or excited to try something new. Lesson here is to check power supplies (and step down regulators) with a voltage meter before connecting everything.

Alan
#70  
Yep, I will validate Alan's statement; Always check your voltage level (or lack of it) before you work on or operate your device.
#71  
Thanks for your condolences guys....just ordered new servos, and yes it's my own fault I should have!

Guess I needed to learn this the hard way, well the EZ-B is alive and kicking so it's not as bad as it could have been!

Will sent that power supply back and try to to resurrect my poor dear K8!:)