Asked — Edited

Need Help Testing The Elechouse Tlg10ua03 Uart-Wifi ?

After Midnight Thursday, 14 March 2013

Good Morning Hardware Team !

 Last week I received my ElecHouse UART-WiFi Kit, and got it Connecting to my Home Router with help from Robot-Doc, who  led me to the TLG10UA03, 

ElecHouse UART-WiFi

 I have attached my Screenshots and Test Procedure, "13-Mar-2013 ElecHouse WiFi UART Serial Terminal Loop-Back Test.doc", and my ARC File of the same name.

 I am using DJ's New Serial Terminal within ARC; seems to WORK GREAT, but I need to LEARN MORE on its proper use ?

 My Question is, Exactly Where Do I Loop-Back the WiFi Module; I tried Tx-to-Rx with No Success ?

Thank You All & Best Wishes,, 602-246-1246(H)



Upgrade to ARC Pro

Stay on the cutting edge of robotics with ARC Pro, guaranteeing that your robot is always ahead of the game.


Hello DougPope,

Do you know anyway to hard reset to factory default the module ? I can't get access to it throuhg port COM anymore due to a wrong TCP setting. It's flashing like it is connected but it is not (I checked from the router).


United Arab Emr

Hi elfege,

I still struggling with mine.:( If you have the USB to UART connector. You can use the UART-WIFI configurator and you

  1. exit transparent transmission by pressing Exit.
  2. You search again for the your module.
  3. You can reset or simply change your configuration
  4. Modify.

This is what I did with Mine. However, I managed to configure it .

  1. I can see it from the Router.
  2. I can Access the webserver on the Module.
  3. Not sure about how to connect it to EZ-B Card. GND-GND,VCC to VCC,TX to TX,RX to RX!
  4. I did that but the white Led flashes and The WIFI card does not Success.

I am not sure what to do , but I will need some time or Someone from the community may jump in soon with an Idea.



The power and ground leads are correct but the Rx and Tx leads need to be reversed so that the WiFi Tx connects to EZ-B Rx and EZ-B Tx connects to WiFi Rx.


Friday, 29 March 2013

Good Afternoon El Fege !

Welcome to the UART-WiFi Club !

Mine works OK, but I like working with EZ-B better, because it's a better match to my current experience level. Beginner !

Please See The Long Posting Adding Wifi To One Of My Existing Ez-b's in Hardware ?

Thanks to Robot-Doc for talking me through the Final Test Procedure, I was able to learn A Lot !

NOON Thursday, 21 March 2013

Good Afternoon Hardware Team !

Last week I received my ElecHouse UART-WiFi Kit, and got it Connecting to my Home Router with help from Robot-Doc, who led me to the TLG10UA03, ElecHouse UART-WiFi ! ElecHouse UART-WiFi

This morning, Robot-Doc talked me through the ElecHouse UART-WiFi Test Procedure, and guess what, IT Now Works ! You can make something Fool Proof, but you can never make it DAMN FOOL PROOF !

The Procedure :

1-Applied 3.3 Volts to the UART-WiFi from Pins on the EZ-B.

2-Using Internet Explorer I immediately Logged In to its Local Router WebPage at its Default IP Address of

3-On its WebPage, Robot-Doc had me set the Default Baud Rate to Roomba's 57600, and Save It.

4-I then Enabled HW Virtual Serial Port to COM8, and Verified its presence in Device Manager.

5-I opened ARC's Serial Terminal to COM1 and using iRobot Create's DB-9 to Roomba Cable, I started receiving Roomba Battery Charging Data when I plugged the Roomba Charger directly into its side Charging Port.

6-I then disconnected ARC's Serial Terminal from COM1, and connected the UART-WiFi's Serial Cable to the Roomba.


8-THANK YOU ROBOT-DOC !, 602-246-1246(H) El Fege, Please Call Me If I Can Help !


Concerning the power issue I connected the USB adapter to one of my USB ports on my battery so I have the right current needed.

I still don't know how to deal with HW Virtual port. I can't get a COM port to be created. It says it is connected to the Wifi module and then repeats the same sentence, something like "Sending do not disconnecte message" over and over; but no additional COM port in the device manager.

Once I succeed and if I succeed to get a new port, should I then connect ARC to EZ board through the same window connection window or should I use serial terminal ? ? I know absolutely nothing about COM ports, never had to use COM requests / codes before. What language am I suppose to use ? Do you know any lexic of COM codes that can be used ?

Thank you very much.

PS : for now I gave up on the wifi

United Kingdom

Yes. Once you have a COM port for the WiFi module it's as simple as selecting that COM port in ARC connection dialogue. Adding the COM port seems to be the main issue that I've seen for the WiFi modules (and the challenge of doing so is a large part of the reason I ordered one).

However, and this may not work but I was thinking that since ARC can connect to another instance of ARC over a network by typing the IP address in the dropdown for connection, can you do that with the WiFi module? No COM port needed? Just an idea that's been in the back of my mind for a while.


If ARC can connect to another instance through IP then I don't need the wifi module since I wanted it only so I could do an IP forward and take control of the robot from any computer with ARC installed and of course a virtual port created. What you just mentioned raised my enthousiasm... how do you proceed ? I'm gonna try while you have time toanswer, you said : by typing the IP directlyinto the dropdown... humm... let's try.

United Kingdom

You need to enable it in the connection settings, I forget what its called (server I think) on the ARC which connects to the ezb then any can connect with the IP.

DJ has done a video on it. I'm on my tablet in bed at the moment though (almost 4am here...) so can't look for it easily but have a look for it in his videos.

United Kingdom


Rich, replying to your post 3 up, I am 98% positive you can just enter the ip. Address and port in the com port dropdown. Ie

You define the port number for serial communications in the setup software of the wifi board. You only need a virtual comm port to communicate with other devices (like Roomba) and it responds to telnet on port 23 for command and control of the Wifi board (cli).

My board should be waiting for me when I get back to work Wednesday, and i will test and hopefully put up a tutorial on Thursday.



Thank you Rich, I could make the connection quite easily as a matter of fact. But I'm struggling with the port forwarding. I did everything fine but I cannot point to my local EZB from outside my network. I'm trying with a vpn but I'd like to find what I could have done wrong with the port forwarding in my router... I'll try having internal port and external port set on different numbers... we'll see and I'll let you know.


Is there a Mac Version of EZB by chance ? Juste thinking... I have an old iMac that runs exclusively for videosurveillance so I thought I could use it as a permanent Relay.


I can't get to connect from outside... confused

United Kingdom

Check port forwarding

United Arab Emr

Hi DougPope,

I am glad that you succeeded with the WIFI module, you should have more coverage around the place to work with.

I did Config my WIFI board and it is detectable on the Router and I can ping it from other devices. I did use autowork mode to auto connect....not sure if this is ok.

also, I can take care of the pin swapping issue using 4 wires cable male-female + additional power sourcing to cover the extra power needed for the WIFI module as using the 1.5A 5V power supply could not handle EZ-B and the WIFI Module.

I have couple Questions to you and @Robot-Doc.

  1. What did you do with the power issue?

  2. how can I create Virtual Serial Port to my Window 7 machine and access my EZ-B?

I think after that ARC should do the job.


United Kingdom

@thetechguru I'm glad you are so confident, as so am I. None of this virtual port rubbish :)

I'd like to know if anyone has tried it though. It would sure close around 4 different topics on the subject if it was that simple.


About port Forwarding (To Rich) : The thing is that you cannot ping a computer located behind a firewall and, in the same way, I cannot reach my computer specifically from outside, unless I go through a VPN (such as the one that TeamViewer, or any remote control software, creates for its own purpose). I can of course use the VPN I already have (Hamachi) but for that I need EZ Bldr to work on the VPN address and not the local address. The thing is that EZBldr would need to create its own VPN for this solution to work from outside. I guess I will have to go throuhg the good all static routing table...

About WIFI : It's clearly the best solution but, Dougpope, you will indeed need more than 1.5Amps for your robot.

Now, to everyone who might be interested : I have a night vision ipcam on my bot. It takes overall up to 1.5 amps. It tended to crash everything down. I added a separate battery but I also installed a netgear wifi to ethernet adapter (found on Amazon long ago). It allows me to separate the network interface's power consumption from the ipcam consumption because the cam needs a very steady current. I'm also about to install two new batteries so overall I should have like 8 amps... (not all 8 amps going to the EZB, of course, 'cause I think to remember that 5 amps is its limit), is that right ?

Other question : anyone knows a way to reduce wifi interferences ? The thing is that I have 3 wifi sources on this robot...:) And its docking station is near a door with a metalic frame, I think this plays a role. EZB camera just can't handle the interferences, only my netgear wifi to ethernet interface seems to carry on.



Once you download the Virtual Serial Software and install it on your Win 7 computer just populate the fields on the form using the IP address discovered during the creation process of the WiFi board.

User-inserted image

United Kingdom

@Robot-Doc Have you tried using just the IP in the connection box rather than the virtual com port? Going by your screenshot

User-inserted image


@Rich, due to grandkids heading this way for egg hunts and eating, my workshop area has temporarily been re-purposed as a gathering area. In theory, your suggestion should work. I'll certainly attempt to establish a connection when time permits.


Sunday, 31 March 2013

Good Morning EZ-Robot Folks ! Happy Easter ! Joyous Passover !

@Rich, @Robot-Doc :

Atached are Screenshots of UART-WiFi and HW Virtual Serial Port SUCCESSFULLY CONNECTING to ARC, COMPLETE With The NEW DEBUG Screen !

Yesterday was a GREAT DAY for Phoenix Washington High School Robotics Car Wash !

We raised enough money to purchase One EZ-Robot Personal Robotics Complete Kit with EZ-B V3 Robot Controller from

Price: $169.00

Local Texas Distributor A Pro Hobbies

Best Wishes From Phoenix,, 602-246-1246(H)


Ok it happens again I get stuck with wifi module being undetectable my UART WIFI application even though it appears in the device manager on COM7 and even after uninstalling reinstalling drivers and all sort of things. the "Exit transparent transmission" gives an error message than just ask me if I would like to quit the application. I can connect through serial terminal but I would need to knwo what I can do from there to, for instance, hard reset the device.


Please, heeeelp ! stress :)

I think I really messed my TLG10UA03 UART-Wifi module... It worked at first but then I don't know what wrong config I did (using UART WIFI config) but now It can't find it anymore while I can still connect to the COM port through terminal. However I know nothing about the language I'm supposed to use... nor if there's a way to reset the adapter to default settings while I can't access it through UART WIFI config any longer... If someone knows what I'm supposed to do, please, help me... I'm sure there's a way to reset the chip from terminal since there's always a reset input in a chip.

Thanks, Elfege


Monday, 1 April 2013

Good Morning Elfege !

Your TLG10UA03 UART-Wifi module is wishing YOU Happy April Fool's Day !

I had a similar problem last month and Robot-Doc talked me through it.

His Included Documentation was slightly different than mine, so I have attached my version of UART Serial Wifi_test.pdf.

Please reconnect your Included USB-TTL Module to the UART-WiFi Module as shown in Fig-1, Page-2.

Reconfirm that your WiFi Setup Did Not Change, or better yet, set it to the Illustrated Local STATIC IP Address of 192.168.119, PDF Page-5.

Please see my previous Screenshots above, and try Retesting ?

Best Wish & Call To Chat,, 602-246-1246(H)


Thank you DougPope but I can't access the module in anyway, the config application does not recognize it any longer, for some reason that I can't explain. When I click search, it just doesn't find it, while I can connect through serial terminal.

United Arab Emr

Did you press exit first usually it gives me exit from transparent mode Than search finds it.... Do not ask me why. It happens to me


I did that and it works once, then I reconfigure everything but something obviously went wrong since now I can't access it any longer.

United Arab Emr

Try to quit config tools reinsert the USB and restart the software ...I am sure your tried.... but just may be is something I always do with windows!


I even tried on a differrent computer... I'm desperate now. Does someone know what the jumper is meant for ? Is pulling it off a way to hard reset the module to its factory settings ?


You might be able to reset the module by connecting Gnd to pin 4 then apply 3.3Vcc to the module for a second or two then disconnect pin 4.


Thank you so much. Just a question... where can I find a diagram showing which pin is pin 4 ? And are talking about the ground on the USB adapter board or the Ground on the Wifi board ?

I guess pin 4 is not VDD otherwise it would create a short. Unless you mean that I should connect the Ground pin on the wifi module to the VDD on the usb/com board and then reconnect the jumper on 3.3 volts for two seconds, is that what you mean ?

Thank you again.



The diagram is in the WiFi document that is downloaded from the website where you ordered your unit.

User-inserted image

User-inserted image

User-inserted image


Nope, couldn't get anything out of this... I give up. This device sucked from the begining. Just one regret : I did not see this other product (link below) before I purchased this expensive poor quality module....


All these modules work basically the same way. The only difference is the vendor. The one in your URL is also from China and takes about a month to get here. I ordered one just to see what the provisioning process will entail.


You're right but I can use Amazon customer service if there's anything wrong and it's a LOT cheaper with FREE DELIVERY. I don't even want to remember how much I was charged for this waste I got before.

United Kingdom

No offence but there may not be anything wrong with it. Most of the time problems with items like these are down to user error.

Put it to one side, stop looking down at the problem, take a break from it before it sends you insane and then look for the solution.


I guess you're right, initially it might come from a user's error...I can even say I'm quite sure of this. I just don't know what error, nor why there's no way to restore to factory settings. This last fact is not my error, but a conception's mistake. And, on top of that it is an expensive product compared to the other one I found and that have factory reset option. Sorry, I'm French... can't help it.:) I'm not good in electronics but I'm quite experienced in computers and networks and, seriously, never seen a wifi hardware that cannot be restored without software access, which is a MUST for a wireless device. I'll try this new hardware when I receive it then I'll let you know. If I still can't do better, then I'll buy you a bottle of Champagne*

*this offer is purely rhetoric... :D

United Kingdom

Both myself and Alan are about to fit these modules, mine hasn't arrived yet but once it does I'll be able to give better help as currently I am only going by other posts, manuals and assumptions.

Hang in there, we will get it going for you :)


Mine was waiting at my desk when I got to the office today. Unfortunately, I have plans with friends tonight, but I'll start working with it tomorrow night and post a tutorial as soon as I have it figured out.



I DID IT ! I FINALLY HARD RESET the module! Oh my God! It took me sooo long!

All the specs I used (including serial commands codes) are HERE


Well, that's the complete PDF document, what pages did you reference and what commands did you use ? Were the commands used using the USB-ttl adapter or via WiFi and AT+ command mode ?


Sure, here are the main infos that saved my a... : go to page 121 and if this is not sufficient to reset to default, use command instruction table in section 6.2.1

I did that using the USB ttl since I could not access the wifi card at all.

I finally got a connection btween EZB and wifi card but it did not seem to receive any command... and the connection took forever to establish...


I don't know if you knew that already but I found it was worth saying it in case you didn't : don't use the same tcp port for accessing the UART wifi web interface and the uart wifi server mode. In auto work mode you must define a different port than the one used in the advance menu. They call it "web server" while it is just the web service which is not the tcp to com service. These are two different things. I'm not 100% sure of what I'm saying (for the difference of ports, not for the difference of services) but I know for sure you cannot use the same port for two different services and this is the only way I could have the autowork mode operational. Otherwise it just doesn't seem to connect to my router.


I sent an email to the tech support group that sells this WiFi unit and asked them if there was a hardware wiring solution to force a factory reset on their device. I received this response:

There is no method to do hardware reset.

Best Regards Wilson Shen Tel: +1 (224) 993-9188

So, the only way to perform a soft reset is to gain access via WiFi or USB to the circuit board and send the AT+ command-(USB) or button click-(Web page of WiFI)

I've also noticed that sometimes when populating the various pages of the WiFi device some fields get populated with invalid values which will then cause issues with establishing a connection to the board. Double check all values in every field before using the "save" option to flash the WiFi board.


There is a method and it is described in the doc... the guy who answered you just didn't want to bother with his own ignorance. You just need to send a low digital signal into the pin 4 for few seconds then you gain access again through USB/TTL via terminal debugging and can send the restore to factory defaults AT+RSTF command...

It shows anyway that this company has no customer service. I'm facing the same problem with sainsmart, they just don't know their products because they are not developed in their country bu probably in India or Korea.


Ok now I'm still struggling in trying to connect EZB to wifi. I created the virutal com port but it doesn't want to connect to it. I'm receiving this message from EZBldr :

Attempting connection on COM3 Comm Err: The operation has timed out. BbytesToExpect: 1

Received: Disconnected Connection Failed: System.Exception: Controller Not Responding at EZ_B.EZB.Connect(String hostname, String tcpPassword, Int32 baudRate) Disconnected

Any clue ?

United Kingdom

Time out errors would suggest that the connection from the PC to the device is broken. Ensure the WiFi module is connected to the WiFi network Ensure your virtual com port is set up correctly, with the correct IP etc.

If all else fails, reboot the PC, power cycle the EZB and try again, Windows has a habit of just not working sometimes.


elfage that is how i reset my wifi is with the AT+ commands but but this time it won't work so i took a week off and did not touch it at all. I will have to try it now.

as for the errors i would get the same thing. Rich is right,try to reset and if that does not work i changed com port and that would help most of the time(don't know why)


I'm lost... by reversing TX and RX pins I got a successful connection to EZB through wifi and com emulation, which is weird by itself. However, no command controls will go through... Rich, have u been successful in your attempt ? Who has ?

United Kingdom

I haven't even got my WiFi module in yet. Waiting on delivery (hopefully tomorrow).


I hope you get it soon and fix all our problems

I just got it to reset AT did not work i tried +++RSTF,++RSTF,+RSTF and one of them worked

Here we go again :D



So, guys, you need to :

  1. invert the tx and rx connection.
  2. do not select the external NVT command port in HW virtual port (don't ask me why either)
  3. still in HW VP in the settings tab select ONLY the following options : Connect to device even if Virtual COM is closed Strict Baudrate Emulation (and of course you Log Enabled).
  4. DO NOT ASSIGN the same port to the web server and to the Auto Server mode.

Now, the quality : I just tested it a little. It tends to disconnect at regular intervals, perhaps a timeout thing to deal with but any way it doesn't matter to much since it's easy to reconnect, in worst case scenario you just need to kill and recreate the virtual port. I mean that's not the actual worst case scenario but that's also why my robot is entirely mounted on a Rovio from Wowwee so I can always bring it back to its charging station in case of total failure of the EZB... which happened quite a lot with the bluetooth... by the way.

I don't know about you but I feel relieved that I know for sure that this is a working solution and that I didn't waste my money.



what wpa key converter are you using


WPA2, if I get what you mean by WPA converter...

United Kingdom


invert the tx and rx connection... don't ask me why
RX needs to go to TX and vice versa... TX sends, RX receives. So TX sends something from device A, it needs to go to RX on device B to be received. Just to clear that up for you.


any one knows if there's a way to use the bluetooth from EZB to connect it to an Arduino ? Is it pre-programmed for EZB only or can it be used otherwise ? If it can't I'll leave it on EZB and use the wifi for my arduino (for a second project on my second Rovio, to allow it to reboot when it gets disconnected).


Rich : humm... lool. There's a time to discovery for everyone I guess ! Thank you Rich... now you say it, it seems so obvious...


The EZ-B bluetooth is a class 2 (33 feet) device and the only thing preprogrammed in it is the device name. It can be used elsewhere if needed.


I started working on hooking up my Elechouse WiFi module last night in order to write a tutorial, and I have had limited success. I did confirm that ARC will connect without a virtual serial port by specifying IP Address and port number instead of a com port in the connection dialog. You will be asked for a password, just leave it blank and click OK. The problem is that it takes several minutes to connect and then does nothing. However, with a virtual com port I can't even get a connection at all at any baud rate.

I noticed that the main LED on the EZ-B was going out once a connection was established, so it lead me to think I might be getting a brownout.

In researching this, I found this old thread.

It appears that my connectivity issue, and the slow response and disconnect issues being discussed in this thread are because the EZ-B doesn't supply enough amperage on the 3.3v pin and you need to run alternate power to the WiFi board in parallel. It was quite late when I found this, so I haven't had time to test yet, and the other thread just ended without anyone claiming success, so I am not 100% sure that is the answer, but I will try it again as soon as I can and post results.


United Kingdom

While your experience wasn't exactly a complete success it has eliminated a huge problem with that God awful virtual com port! Something I expected to and was hoping would happen. Virtual anything is never a good idea, whoever though up and recommended it needs shooting :)

You just reminded me to see if mine has turned up yet, haven't checked if I've had any post (mail) today yet... Edit: YES it's here :)

Good find for the 3.3v issue, that saved me a headache when I fit mine... hopefully.


The other thread mentioned that it should work on 5v as well, but I had even less success using the 5V lead on the EZ-B. LED's on the WiFi board wouldn't even light up.

You will still need virtual port unless you want to switch back to Bluetooth (or I assume, but haven't gotten far enough in testing yet the USB TTL) when you want to upgrade Firmware. The firmware updater does require a com port number.

Also, projects like @Doug Pope's needed it since he is trying to use it to connect to a Roomba, not the EZ-B.



Oh, one more thing to save you a headache... When hooking up the TX and RX on the USB-TTL, you hook TX to TX and RX to RX. They appear to be mislabeled on the USB-TTL. The Elechouse manual has a totally different serial board so finding that was just trial and error.



For the 3.3v issue I had just connected the power to the original USB adapter which was attached to a USB power port available on my project. Everything worked fine for several days, using the settings I recommended in my earlier post on this same forum. However for some reason the wifi module just stopped working at all and I couldn't, this time, hard reset it using the method I had used before. I wonder if we shouldn't link the ground to both the alternate power source AND the EZB's ground port. I'll receive a new module in few days and I'll see. I'll let you know.

I never succeeded in connecting through IP directly in a reliable way even though I had the correct amount of amps so I don't think this is the issue. I had control over the robot while connected through direct TCP but it was responding with a long lag. HW virtual port works fine though once you enter the proper settings and most of all once you use direct baudrate emulation.

Best, Elfege


I should be receiving my WIFI UART soon. I am wondering what is the maximum rated current from the EZB's 3.3v pin. I will need 300ma MAX.


One more more thing. (this may be usual, but I was confused for a bit). The diagram that identifies the pin numbers of the WiFi board is looking at the board with the pins facing down. I did confirm that hooking up power backwards doesn't seem to damage anything before I figured this out :)



If you flip the WiFi board over, you can see the 3.3 v and Gnd markings stamped next to the corresponding pins.

User-inserted image

United Kingdom

They don't make it easy, or am I just too tired and in too much of a rush to read all 122 pages of the manual and have patience with this thing...

How on earth do I get the thing to connect to the network? All connected up to the USB, settings entered (all correct), scans fine and finds the network but connect just wont work... Any ideas?

Also, is it just me or is half the text missing from the app? It's as if the page needs scrolling down or resizing.

And, when I search and select the module I get a note: Parameters get error, could not support! Is that just me?

Lastly, has anyone had success using Windows 8? The USB gets installed but cannot start (code 10), the manual says this indicates a counterfeit unit although that's total BS, works fine on Windows 7.

First impressions on a quick 15 minute look at this and I'm not at all impressed by any aspect of it. I'm not surprised it raises so many questions.


Yes, I get that parameter error. After entering all of your network settings, click the Modify button and it will update the board and when it reboots, it will be on the network. You can then connect via web browser to port 80 (user name admin, password 000000) and the interface is better than the crappy software. I thought the usability issues were from being on a Netbook with limited screen real estate.

There are some warnings on the site you download the USB drivers about Win 8, but I ignored them, so not sure if there is something to see there or not.



@elfege Can you post what you determined are the correct HW virtual port settings? Never mind. I re-read the whole thread and see that you already did that.



I shouldn't mess with electronics when I am short on sleep. In all my messing around, I hooked the WiFi board up wrong one too many times, and now it is fried.

Off to order a replacement. :(

I am thinking about trying the one that @elfege found on Amazon and @Robot-doc said he was ordering. @Robot-Doc, did you receive it yet? Any success? I can't tell from the Amazon description if it even does TTL or only RS-232 and I can't find a manual for it.



@thetechguru, I ordered the WiFi module using on 4/1 and it shows possible delivery on 4/25. It took 10 days to change status from Ordered to Shipped.


Maybe I'll wait and see how you do with that before ordering a replacement for the board I just cooked. I found a (really bad) manual for it here about 10 minutes ago. Didn't answer the question about TTL, although searching Google for TTL Wifi Module finds a bunch of hits for the same device from different sellers.

Sparkfun also has one, although even more expensive, it claims to boot really fast and be ultra-low power, which given the 300ma draw on the Elechouse board could be a good thing.



The exact same UART wifi TLG that you just fried is available on Amazon. If you're ready to spend 50$ for shipping you can have a new one in less than a week. I ordered my new one on sunday and it arrived today. This one comes with a wifi shield for Arduino which I find cool since it's just 31$ for the whole kit. I do not intend to use it with my EZB any longer but with my Arduino which is linked to a relay that allows me to restart my other robot when it gets disconnected from its built-in wifi. Actually I already have this relay available through Ethernet shield with Arduino and the ethernet is connected to a Netgear ethernet/wifi adapter. It's less of a smart assembling (beside for the arduino's programming part) and it consumes more power than using an actual wifi shield (since it uses 5v instead of low 3.3v) but with a 10000mah lithium battery pack it seems to hold pretty well.

Anyone could explain me why most people in robotics seem to prefer nimh batteries rather than lithium ? I really can't figure this out. I know some stuffs about the difference between these two kind of batteries but I don't seem to know THE detail that seems to make people prefer the old and heavy slow charging nimh technology.

Best, Elfege


I'm thinking... to save power you may be able to set it on 802.11b... just a suggestion.

United Kingdom

That's unlucky Alan, how did you fry it? I don't want to make the same mistake.

Still couldn't connect to the wifi earlier this morning which is odd. All settings are correct, security is all OK, Filtering set up correctly (and have even tried turning it off with no luck).

I'll post some screen grabs later when I'm home as I may have missed a step or two although I can't see what.


Thanks, @elfage. I am also looking at a device from Roving Networks that use the chip that Sparkfun sells but on a developer board so I can plug into pins rather than soldering on an IC. A bit pricey, and command line interface only, but very good documentation and very low power requirements but with a wider range of optios too.

@rich. I am not sure how i cooked it. I was really too tired to be messing around. I probably gave it too much voltage.

For getting Wifi working, in the config gui, don't set the auto workmode at first. Get your settings for Wifi right, then go to the test page and hit the connect button to see if you can get on Wifi. Once you can, then go back and set work mode to server, set your port and timeout, reboot and it should auto connect to WiFi.

United Kingdom

I'll give it another go when I'm home from work. Lucky it's Friday, I get all week to wrestle with it.

Just remembered I have team viewer so here's how my config looks...

[Wireless Set]
[Net Set]
PPP UserName=
PPP Password=
[Auto Mode]
[Uart Set]
[Advance Wireless Set]
[Advance System Set]

Looks like AutoMode is enabled, I guess that need disabling.


At least for testing, Auto-mode should be disabled. Once you can test in the GUI, then it should be enabled, but you will need to define it as server, tcp, a port to connect to for TTL, and passtime (120 seems good). I don't have my configuration with me, and the computer it is on is turned off, but I'll post it when I get home. (note: if you set auto-mode to client, and it doesn't have an actual address and port to connect to, it will reboot every couple of minutes, and it is very hard to connect to via TTL, although you should be able top connect via the web interface.

It seems all of the text I wrote for my tutorial so far as I was going along is getting written in these posts. Maybe I should clean it up and post what I have so far since it looks like it is going to be a couple of weeks while I wait for a new one, and I may even decide to go with a different model.

I am liking the looks of this:

or this

or maybe one of these so I get a choice of antennae and no soldering for the TTL connectoin.

although not the prices.. Documentation is excellent and clearly written by someone whose primary language is English not one of the Chinese dialects. Looks like it can easily be powered by the EZ-B, and has a 3-12v input range, so less likely for me to fry it by accident. Costs more than an EZ-B though :(



Indeed Rich you just need to have it connected while still connected to USB adapter and then activate the auto mode under the web page. Just in case, don't forget to set a different port for web server and for the auto mode server. You can actually leave the port 80 for the web server since you can still define an external port from your port forwarding in your router.

Let me know if you get a proper connection through IP directly without using virtual port because everything I tried so far was not good. Port forwarding works fine though. However I get disconnected pretty often which might indicate a power issue so I put the wifi module on the side for now until I can figure out what coudl do that because I don't want to fry another one.

Good luck Elfege.


Btw, anyone knows something about the difference between lithium and nimh? I mean, any idea on why people seem to chose nimh batteries rather than lithium for their projects ?


@Rich welcome to our headache good luck



Lithium (either LiON or LiPO are higher energy density than NiMH, meaning they will last longer while providing higher power output for the same size battery, and are lighter weight as well. They have better power falloff behavior as well in that they will continue delivering almost full voltage until shortly before they run out, and then fall off quickly, while NiMH will steadily decrease voltage over time (NiCad where even better for falloff, but hardly last, and are an environmental disaster so you don't seem them used much anymore).

On the other hand, NiMH are safer. You can overcharge them and they won't catch fire. Lithium of either type need a smart charger to make sure they don't over-heat, and LiPO you need to charge before they are completely dead or they stop taking a charge.

Any of them will last for thousands or charges, or about one to two years regardless of number of charges. NimH will start to lose power after they are charged and will lose about 10% per day until they start to hold at about 50% if you don't use them. LiON will hold a charge for weeks to months without losing anything. I don't know how LiPO perform in that area.

Anyone feel free to correct me if I mis-stated or under-stated any of this.


United Kingdom

@pitcom, thanks... I think.

Still having problems getting the little blighter to connect to wifi let alone anything else!.. Everything I try says it can't connect. Tried 3 different wifi connections and still nothing. Checked all settings, nothing... Just googling for more info on it since I'm about to throw in the towel again, take a break from it, watch a bit of Spartacus then try again.

Edit: Scrub that, I'm connected!.. Stupid thing. Changed it to connect to an open portable hotspot on my phone, connects. Changed it back to my home network, everything as it was before, connects... Now, on with the fun! :)


Hi @Rich, I'm using two LI-ion 1600 mAH cell phone batteries connected in parallel for a total capacity of 3200 mAH. A standard 5 vdc cell phone charger can be used to charge the twin cells since the charge/discharge protection circuit is built into each cell phone battery.

Now on to your WiFi binding issue. I assume that the first steps when you connected your WiFi module to the TTL/USB were accomplished and that you received the IP address that your Router should have assigned to the WiFi MAC address of your WiFi board and were then saved . Let me know if you got this far.

United Kingdom

@robot-doc that's the bit I struggled with... I can't figure out why since it is working fine now after basically re-entering the settings for the 3rd time! But it's connected, that's the main part. (I expect I had a setting wrong somewhere however I checked them all over and over again... Who knows, who cares, it's sorted now)

I haven't tried anything further yet. I need a break from it again before it sends me around the bend!.. Will replace the bluetooth module on the EZB later and try connecting etc.


Here are a couple of shots of my WiFi board menu of parameters. I got these by just putting in the basic IP address that my Asus Router assigned during the startup procedure.
User-inserted image

User-inserted image


One more important bit of info..... The WiFi board MUST be flashing its LED (Top right of the board) opposite the antenna connector. This indicates the board has established a connection to your WiFi router. It can only do this when the Auto Mode box is checked.

User-inserted image

User-inserted image

United Kingdom

Yeah I'm that far now.

You have DHCP enabled? Personally, unless your router reserves the IP for the MAC address I'd change that to static... in fact, all of my IPs are static but then I forward a lot of traffic to specific PCs. It just makes it easier should it disconnect/reset and be assigned a different IP.

If only I knew where you lived I could use your wifi now :)

But mine look much like that. Which is great.

I'll be doing a write up and photos etc. when I have finished... I also found my problem, darn security type was wrong so it was not connecting. I must have earned thousands with connecting and setting up WiFi networks and I make a rookie mistake like that.

I'll be hitting this one hard over the weekend and trying it out on testbot so hopefully (wishfully) we will see an end to the slow wifi issues etc. soon. But first, the penultimate episode of Spartacus is calling me (and so is the coffee in the kitchen)!


About rookie mistakes, don't worry Rich... I even had forgotten on how to cross the RXD and TXD wires the other day, remember ?:) I still feel stupid about this one!

Thank you Alan for your full description. I knew about all this already, beside for the fact that lithium batteries can catch on fire ! I have a tenergy lion/lipo charger on one robot with batteries that have built-in fail-safe circuit that shuts them down when it reaches a voltage below 2.xx V. However on my other project I use a built-in Anker charging circuit connected to its original batteries that I've however stripped out in order to access the 8v current directly and I don't know if they have a built-in fail-safe circuit independant from the Anker's charging circuit (since I'm taking power from batteries directly instead of taking it from the built-in 9v output because), I'll check on that.

Tank you again Elfege


Lol @Rich, that WiFi router is my test environment and connected to a slow 2-wire DSL. My fast WiFi is using a cable modem and set up a bit different.

United Kingdom

@thetechguru I just did the same as you and connected VCC & Gnd around backwards so don't feel bad about that one...

OK so it's connected to the board but it wont connect to the WiFi while powered by the board. I assume there isn't enough current for the board.

Now I'm about to read all the datasheets, manuals etc. to see what the board needs and what the EZ-B gives. I'm guessing that using a 3v3 supply with more juice will solve the issue. I did connect the power to the USB and plug that in but since it doesn't share a common ground I expect that is the reason for the "firmware 8.5" error.

Slow progress but it's still only Friday night, I got two whole days to get it sussed out yet :)


The board requires 300 ma and I think the EZ-B provide 240 (the thread I linked to above had the specifics).



Be careful I just found out what probably made my first module to fry : according to the doc provided by elechouse you cannot send more 300mA into the module and if you use Arduino board and wifishield they simply say that you have to use an external low amperage source... but if you send a little bit less it won't start therefore any other device attached will make it fail in a way or the other, either by pumping out too much current or by not pumping enough!

see the last page.

Clearly it seems that this module is just BS... any power variation might make it fry or just not kick in... it is not really compatible with arduino and not compatible with EZB either. For now it works on my EZB but I'm sure it's gonna fry sooner or later since my USB power supply is arround 2amps and the constant disconnections might be due to its complete intolerance to the slightest power variation.

I think DJ should read our posts and try to advise his customers on another device from now on. This one really sucks.


United Kingdom

The module should only pull the current it needs, if there are 300A there for it it should only pull 300mA if memory serves me correctly (it's been 15 years since I did DC theory). Please correct me if I am wrong.


@Rich, you're correct. The WiFi PCB requires 300 mAH to fireup and run correctly. I'm using 3200 mAH LI-ion packs for power and have not had any problems with the board working. One thing that must be done however is that the WiFi PCB and the EZ-B must share a common ground.

United Kingdom

Yeah my testbot is on 6xAA batteries that probably need changing. I've been tempted to swap out the board in Melvin and test on him but can't be bothered yet if I'm honest, it's already 9:30pm here and I've not eaten yet!.. I'll try that tomorrow.

I'm tempted to throw a voltage divider on my 6V circuit to drop it down to 3.3v and provide an external constant 5A 3.3v supply, that will eliminate any power issues associated with the speed of transmission. But that's plan B, plan A is to give it enough juice so it connects.

There are reports of this working and it is also on the tutorials page under hardware compatibility (I think) so it must work. We will make it work :)


You're correct indeed, max amperage of a device defines what it will take from the power supply. However, is not a robot inductive ? and this device has no protection against any kind of power variation. I'm trying to figure out what happened. Perhaps the fact that I had not connected it to a common ground with the EZB.


@elfege, lack of common ground is very likely the cause. Mine was over-voltage I think, although like I said I was so tired I couldn't even focus my eyes properly, so I had no business playing with delicate electronics.

It was an expensive mistake but at least was not a total loss. I am able to use the USB-TTL adapter for direct connection to EZ-B and it works like a charm. (note, the tx/rx on the USB TTL are not labeled in a standard way. you DON'T want to swap TX and RX when connecting the TTL adapter to the EZ-B. TX goes to TX and RX goes to RX). One of my two EZ-B's will be in a bot with an on-board computer, so this is better than Bluetooth for this machine.

I am trying to decide whether to throw good money after bad and try the Roving Networks adapter I found, which looks to be very high quality (at least if the documentation and web site can be used to judge) or just give up and decide to stick with Bluetooth for the smaller bot without the built in computer.

Maybe I'll save my money for now until I see what EZ-B Revolution is going to be.



I think the onboard computer is a great idea since it offers tons of software based possibilities that we have to hard-wire and hard-program otherwise, such as remote control over the Internet, etc. However, from a personal perspective, I'm reluctant to do so, otherwise I'll go straight back to what I already know (I used to work as IT until I could realize my true professional dream) and it would be less fun and, moreover, less learning for me since at least now I wrote my very first C++ based programming on Arduino thanks to EZB which is the perfect introduction to the fun before the real work ; all this also allows me to discover more about the hardware itself, even when I fried the module since I have at least one credible hypothesis... I'm however so frustrated not to really understand why the common ground was so necessary. I imagine that the RX and/or TX data had to build up some kind of mass because I figure that it might work like network data, needing outstreaming of empty data, free electrons that do not correspond to actual data, like a kind of natural waste of the process that could not leave the circuit, running in circles or something. If you know about the physics behind this, I'd love to hear about it!:) I'm veeery curius in nature so forgive me if I'm a little bit off topic! :)

Can you send us a picture of your module ? Because I had to swap RX and TX in order to have it functioning so I'm wondering if it's not coming from your specific piece. Otherwise I'm really curious to know how you got it working that way.



Unfortunately someone else will need to explain the need for common ground. It is one of those 'things I know' but the knowledge is so old I don't know the answer origination or reasoning. It is either from being in IT long enough that I used to use a lot of serial devices, or from the little bit of electronics I learned in high school physics 30+ years ago.

I know I have seen other equipment (including boards that cost upwards of $5k destroyed by bad grounding.

II'l post a picture of the USB TTL sometime this weekend.



I learned early on that the devices connected to the EZ-B ALL need to share a common ground. You will notice that even the H-Bridge devices require the same ground treatment.

I tried the WiFi board connected directly to the 780 Roomba com port @ 115,200 k and would receive nothing but garbled characters until the WiFi board shared the same ground plane as the Roomba.

I also experienced an expensive lesson on powering the 3.3vdc required input to the WiFi board by using a 3.3 MOSFET regulator that was rated at 1amp output with a voltage input from 9 to 30 volts. The regulator worked for 30 seconds then passed the entire input battery voltage (16vdc) into the WiFi input leads.......Poof. Good thing I had ordered 3.

United Arab Emr

Common ground is a must in any integrated electronic circuit as you have to have common baseline for both circuits . In our case the Wifi module and EZB else you will not have a reference for your TTL signal levels between both circuits.


Thank you all of you! By the way, since I installed an H-bridge (before that I was using modified servos's circuits to control my Rovio's motors from EZB but they fried one after the other after a while... I know, I'm the Wizard's Apprentice kind...). Since the Hbridge is installed I get one motor running faster than the other, whether I drive from Rovio's hand or from EZB's controls. Of course I tried to swap the connections on Hbridge in order to check if it was coming from it but it seems it's not the bridge.


I think I found out why I should not use lithium batteries. The magic word is trickle charging : lithium batteries don't last long with such a charging method. So who ever has, as I do, a robot with docking station should not use such batteries.

United Kingdom

Using the correct charger in the correct way is one of the most important things to do with Lithium batteries, if not the most important. Incorrect charging can lose you more than just the battery.

I was under the impression that any charger made for charging lithium based batteries shut off once charged and balanced since it's dangerous otherwise. What charger were you using?


I use LI-ion cell phone batteries in the Roomba robot, the EZ-B, and the Wifi board. All of the batteries have built in Power control boards that monitor charge and discharge and will open each batteries electrical path if exceeded. That way I get to use the standard NiMH, NiCD power supplies. You can buy bulk cell phone batteries for about $1 each and a lot of them have 1200 to 1600 mAH capacity. Then it's just a matter of series/parallel arrangements to obtain the voltage and current needed for your projects.

United Kingdom

I plan to do similar on my next project, do they have auto cut off circuits to stop over discharge too?

I'm working on an auto cut off circuit for my current batteries since they don't have them built in (which seems stupid to me for the price of a diode, resistor and mosfet)

We digress from the topic, perhaps this should go into it's own one...


Hello Rich, nice hearing from your expertise again ! :)

On one robot I'm using amultivoltage (5V USB at 2amp max, 9v / 12v) battery pack form Anker so it does the job perfectly and it's been working for days now so I think it's fine. On the other project I use a smart charger from Tenergy and the batteries are from ultrafire. Both batteries and charger have overcharge/overdischarge safeties. Actually they already got upset and turned off twice because the charger does not provide enough juice. Indeed this charger sends only 500ma constant charge current and I need at least 1.5 amps since I have an ethernet shield on arduino + netgear ethernet to wifi adapter running constantly in order to power up / donw / reset the Rovio when it's needed. Therefore I ordered another Tenergy model which sends 1.5 amps constant charging current instead. However I wonder if it will be enough since I fear that arduino+shield must take something like 500 mA and I know that the ethernet to wifi adapter takes 1 amp (the Rovio takes more but has a sleep mode and anyway I can remotely turn it on/off). I think it should be enough since the other Rovio (the first project) works fine with more equipment and a 1amp charger. It seems though that li-ion indeed don't like trickle charging (does trickle mean that you let the device plugged on the charger constantly, I'm not even sure actually. And if the charge happens while devices are running and constantly taking power out of the batteries, shouldn't it be fine then ?).


United Kingdom

Trickle means that once charged it will still send a small current into the battery to maintain it's charge, it's not really needed on LiPo/Li-Ion since they don't lose charge very quickly when not in use. Such chargers should not be used on LiPo/Li-Ion batteries. At least that's what I've read.


Ah ok ! I had looked into Google translate so I was a little bit confused and I thought it meant exactly what I'm doing : leaving the batteries connected to the charger while they still send current to several devices.



Has anyone eventually accessed his EZB through direct TCP connection ? Mine is still not responding after connection is set.

thanks Elfege


You may have better luck if you remove power from the EZ-B and then reconnect it. Sometimes something locks up the board and the connection cannot be made. You may also observe that the blue LED goes out when attempting a connection and to clear that condition requires the power to be removed and then connected again. You will finally get rewarded with a connection like this: User-inserted image


ok but definitely not what I need since I use this robot remotely to check on my cats...:D I cannot afford a system that needs to be power-recycled to work properly. Thank you anyway.

By the way... I must have done something wrong again with my new TLG10UA03... I can access it through the config app but cannot make any modification or restore. Anyone knows where to find the firmware ?



I hope I am not throwing good money after bad, but I just ordered one of these (specifically, the RN174U since I have the antennae from the fried Elechouse board I can use with it). At $79 + shipping, it sure isn't cheap. You can get just the chip for less, but it is surface mount, so a lot more work and parts to make it usable which I am not ready to do. This dev board should be just about plug and play.

I'll let you all know how it works.



@thetechguru I was looking at rn172 to,i will wait to see how you make out before i buy one good luck

United Kingdom

I'm still holding out for the Tlg10ua03 but the issue with not enough current is what's stalling my progress. Hopefully I'll get a solution to that soon - I'm yet to try it while running from the 2S LiPo due to limited time.


This device sucks... There is a low current device on the market made by Saint Smart, a wifi Shield for Arduino that theoretically should be compatible with EZB. According to those who successfully set it up on their project it really takes very low current. But I couldn't even get it to run with standard arduino wifi webserver programm and I could not access it through serial/usb either so I returned it. I think we should all look forward to finding a device explicitely sold for its low current consumption.

United Kingdom

Cost is a big issue I like to based solutions on though. While it's not always just because it's cheapest, or because I can't afford anything more expensive I'm driven by helping as many others as possible and that includes those who are on tight budgets (naive people, I was one once before I started building robots). So I will continue to pursue this option and find a solutions (or try to) for the power issue. I have some ideas.


@Rich, I am pretty sure you'll be able to get it working with alternate power. Robot-Doc has repeatedly reported success with that board. If I hadn't blown mine up, I would still be trying, but since it is problematic, I figured I would go another direction and try it.

The Roving Networks boards can be had for less. $29 for the chip, and I saw a developer board at RadioShack yesterday for $8 that the label said worked with surface mount chips and minimal soldering., so if you are skilled with a soldering iron, it is competitive to the Elechouse. I decided to go more plug and play for now, but if it works well with the developer board I ordered, those on a budget would have some options.


United Kingdom

I'll have to look in to that one sine my hatred for soldering has turned to a near love now.

My plan is to find a 3.3v regulator that'll do the job if powering the ezb with the lipo doesn't work. I need more time in the day though, another 20 hours would be nice!


@Alan : indeed it works and I could make it work too, not through direct ip though. However it seems pretty precarious for a permanent solution since it needs some regular intervention on the device itself such as power cycle. Perhaps I'm doing something wrong but this is the second one that stopped working properly on my side... :)


One point I may have forgotten to mention is that I am powering the WiFi module using standalone LI-ion cell phone batteries. Each battery is rated at 1600 mAH. I wire two together in parallel for a complete battery pack that provides 3200 mAH at 4 volts dc. I just got some dc to dc converters from China that can operate with a dc input of 9 to 30 volts and provide 3.3 vdc at 5 amps output. I plan to modify the LI-ion pack and add more cells to increase input voltage so that I can test these new regulators. I would like to make sure that the slowing down of the application is not due to power input to the WiFi device.

Although I can connect most of the time without issue I'm now finding that there is an issue with transmission capacity that degrades with the addition of more than one IR or ultrasonic device to the screen.

United Kingdom

If/When I get it working and stable you can expect to see a step by step guide on it. I'm sure you're aware of the level of detail and clarity I put in to such things so if I can do it I'm confident we will get yours stable too.

Having had mine powered by USB on the PC for over 24 hours with no issue I don't see that power cycling will be required once it is powered correctly, with enough current to maintain the connection. Hopefully this doesn't offend you as that is not my intention but I am leaning more to the side of user error than a problem with the module.

On the other hand, I don't accept sub standard kit so it could go either way but I wont give up until we have a definitive answer on this module one way or the other :)

@Robotdoc, how often is it checking the IR? I know there can be issues with checking multiple ADC ports frequently. My bluetooth benchmark shows it can read from ADC 25 times in 1 second, so if it's set to check every 200ms it will be capable of reading 5 sensors (5 sensors, 5 times a second each = 5x5 = 25). It may pay for you to run a benchmark (benchmark control is in general in ARC I think) and see what the limit is. That is important to a lot of builds and if WiFi is low it will be worth noting for anyone looking to go down this route.


It's checking the Sharp IR radar at 500 ms and the radar scan at 250 ms. All I did was add one digital and one analog port taking the defaults from EZ-B.


Don't worry Rich, none offense to be taken since I'm perfectly aware of the fact that I suck! I'm just who I am : French! I'd rather accuse the second module I burned than myself !:D Looking forward to reading your tutorial !


By the way... I suck so much that I cannot make my new robot to turn, (I burned the old rovio eventually because of my two system in one... I know, I know... you told me:) ) so I put everything on a 4WD platform with an HBridge (I strictly followed DJ's tutorial for that part) and the only way I get the platform to run is by stripping out the rear wheels from their rubber so there's less friction and it can turn. It seems that while given the order to turn the Hbridge runs the wheels on both side at the same speed while the wheels on the inner side should run much slower than the wheels on the outer side, is that correct ? If so, do you know what could possibly allow me to have the inner wheels to turn slower beside using PWN each time I want to turn ?


@elfege, it looks like you went off topic for this thread. You may get someone to answer your question in a new thread.


@elfege Hello i have read your post. like you i am also stuck with wifi module i have made some changes to use webserver on this UART-Wifi module i have achieved it successfully. Now i am not able to connect it again with UART-Wifi configuration software. I am getting error "no valid com found". i tried to hard reset the module by connecting pin 2 to 5 and then 4 to GND temporary. but no result. I have followed your post and apply the solution as per the pdf you posted(on page 121). but still my module is not responding. Now i am also not able to configure it over WiFi. so how can i achieve Hard reset? can you please help me?


Hi taher, could you help me to exit of the auto-work mode please, I have tried to exit unsuccessfully. could you put some images of your configuration, please. confused



I've been reading your thread with interest, I'm not using my wifi model for robot at the moment, but I thought I'd share my experience and learnings.

  1. The firmware in these modules seems to vary depending on where you get the module from. Most documentation states the data rate is 115200, however I've found that the default rate is often 9600 not 115200

  2. Web admin page address is not always this varies with the firmware. To find my web admin address I had to connect via wifi on my laptop, then use the windows ipconfig command, to get the address assigned by the module to the laptop, then use the gateway or router address shown by ipconfig

  3. As well as the web admin, some devices have a text user interface on port 23. Windows users, need to enable the Telnet program, and the at the command prompt type Telnet 23 I,e if is the IP address of the module The login using password 000000

  4. On my module when i did a factory reset AT+RSTF the ,module reset to a different set of parameters to those that it was supplied with. It came back on with SSID. Was wifi-socket, so I suspect that the module I have, and many of there out there, looks like it was destined for wifi controlled mains socket. If did some research and there are several Chinese products and one uk product that does is. There are also wifi controlled inline lamp sockets which these modules are used for.

  5. There doesn't seem to be a way to do a factory reset via any of the connections. With the wifi socket product, it has 2 push buttons on it, and according to the docs for that product, holding in one of the switches causes a factory reset, but I tried holding reset low for 10 secs but that didn't reset my module. However I've not tried holding cts or link or rts low or high for 10 secs, after power up, so anyone with a bricked module, should probably try that as a last resort. But connect the pin to GND to Vcc via a resistor e.g. 1k

  6. According to the pdf docs, the module can be put into config mode, by holding cts low for at last 300ms after doing a hard reset. However this doesn't seem to work on my module. But it could depend on firmware.

  7. On my module, it was impossible to disable Auto Work Mode. Changing this setting in the web admin, wasn't saved after pressing save. Though I didn't try doing it via AT commands

  8. The PC UART Config exe, seems to assume the module is in command mode and doesn't send +++ the best way to get the program to work is to use a separate comms program to send +++ to the module then when its in command mode, then close the comms program and run the config program.

  9. My module didn't seem totally compatible with the Config exe, I got a message of command not supported, but it generally seemed to work.

  10. I found a reliable way to initialise a module is to take rest line LOW then wait around 5 seconds, by which time RTS line will go Low, High then back to Low, when rts line is low again, send +++ and you should get +OK

  11. You can't type +++ in hyperterminal etc enter command mode, the timing is critical. There is a free program called Hercules which seems to be part of the software bundle for this module. I used this, as it has a send option, where you can enter the +++ into one of the three boxes at the bottom of the screen and then press send to send the +++ together with no gaps.

I have found some Arduino sketches that puts 60ms delay between each + but I have written Arduino sketches that send without delays and it always seems to work. So I don't think the delay is necessary

  1. For Anyone thinking of writing software to use the module, eg using Arduino. I have found in my module that some commands don't seem to work. Eg creating a network socket as a server e.g. T receive data, doesn't seem to work. Creating sockets to send at a I.e as a client does appear to work

Anyway I hope this helps anyone trying to use this module as I think it can be useful but is quirky;-)