Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by thetechguru!

Jd Profile Does Not Load Properly

A pair of students in one of my Robotics classes has problems loading up a previously working JD Profile. I took the JD to my computer and tried loading my JD Profile. After 2 tries, it worked on my PC. I then took JD back to their PC and it worked for my JD Profile after 3 tries. This was yesterday. Today, when they tried to use JD, the profile would not load. I took JD back to my PC and tried. It would not work. Something strange is happening. I just don't know what it could be. I have uploaded the different profiles being used. My profile is "JD-Profile-TayZack." It worked when theirs wouldn't. Now it doesn't work either.

JD-Problem-Profiles.zip

#1  
I was able to open all 3 profiles with the version from 1.6.2016. I will update ARC to the latest version and let you know if I have any issue loading them.
#2  
I had no issue loading them after the update.

I assume that they are fine but without knowing what to look for exactly (I dont know if the setting are correct) I can only speculate.

User-inserted image
PRO
Synthiam
#3  
abrown, what do you mean by "wouldn't load"? Was there an error message?
#4  
When the students first showed me their problem, an error message did appear in ARC. The error message was not recorded, but I believe it had something to do with an unsuccessful load (I could be wrong here). The next day I tried to reproduce the error message, but was unsuccessful. The default profile would not load either, or at least it did not result in JD going to its default position. I had the same result on my PC. JD would not return to its default position. Both PCs have the latest version of ARC loaded.

I have another JD that I will test on Tuesday to see if I get the same results.
PRO
Synthiam
#5  
There is a very very very small chance that the file was corrupted - we've never seen that happen, but windows has been known to corrupt a file or two in it's day :). If that is the case, you may need to spend 2 minutes and create a new profile.
#6  
Today I discovered that the students' JD was not fully charged so I charged it before they got to class. When they came in, I had them try their default profile again. It did not work again. I then took JD to my PC and tried it. There was a response when connected, but the positioning was totally off. This was a profile that worked for this particular JD before. The profile positioning had JD's arms extended, but the shoulders were rotated (almost) 90 degrees. The rest of the body appeared to look correct for the profile.

I began creating another default profile for JD, but that made the shoulder setting values get pretty large. I decided to stop since it did not look right. Could there be something wrong with this JD's body or EZ-B?

My students are pretty frustrated with this and asked if they could switch robots. I could see where they were coming from with all this inconsistency, so I assigned them another robot - Roli. Hopefully they will have better luck with Roli.

In the mean time, I will pursue getting to the bottom of the problem with this JD. Any help is much appreciated. Thanks.
PRO
Synthiam
#7  
The two issues that you are experiencing are incredibly unique - one of a kind. In tens of thousands of these, there's never been these two scenarios befor. If the profile is off, I would have to assume it has either

1) file incorrectly named
2) servo wires are connected in incorrect spots

A servo profile, in reference to the howto video, should take less than 2 minutes. If the servo profile is "that out of whack", I wonder if the servos are not connected to their proper ports.
#8  
I will start from scratch myself and check the wiring, and then create an new profile. There is no telling what the students have done to that JD, if anything. This way I can be assured that this JD has been assembled correctly and profiled correctly.
PRO
Synthiam
#9  
Okay - keep me in the loop. You got us puzzled:)
#10  
I had zero luck with JD's profile today. I disconnected and reconnected the connectors for JD's shoulders, which is where the profile has the biggest problem. I tried creating a new project and then attempted to create a new profile, but anytime I connected JD, its shoulders always snapped to a horizontal position. When I attempt to set JD's shoulders to a vertical position, the values got large (>90) and to a point where the servo did not move closer to vertical. This did not seem right, so I did not bother saving any new profiles. I also did a hard reset of EZ-B, but that did not help.

I have attached a picture of JD when it connects. As you will notice, the shoulders are horizontal. Since I cannot fine tune the shoulders enough to get them to a vertical state (with what I have worked with thus far), is there something else that I might be able to try?

User-inserted image
#11  
Servo profile should only be used for a couple of degrees at the most. If you need to adjust by 90 degrees, the arms are connected incorrectly.

Remove the arm at the shoulder, turn 90 degrees, and reconnect the clip and play connector.

Alan
#12  
D'oh! Something so simple that slipped by me. Thanks Alan.

I do still have problems with consistently connecting to JD and loading its profile. This occurred more often on one of the classroom PCs. On my PC this happens only occasionally. Since the students are now working with Roli, I am not as concerned with the JD problem anymore. The horizontal shoulders was the real worry. I will consider this problem resolved.