Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

It May Be Me. But I Cannot Create A Shortcut

It may be me. But I cannot create a shortcut

I tried on two computers, but it did not work. It was a GREAT idea to have.

Thanks for all of your hard work.

Mel

PRO
Synthiam
#1  
One other person is having an issue. Not sure what causes it - because generation of the LNK fie is a generic windows function.
#2  
It creates an Exception Error. Maybe I can find another way to do it. If it is a windows problem.
#3  
Here is some more info if it helps.

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.IO.FileNotFoundException: Could not load file or assembly 'Interop.IWshRuntimeLibrary, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.
File name: 'Interop.IWshRuntimeLibrary, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'
at EZ_Load_Creator.FormMain. (Object , EventArgs )
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].



************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
EZ-Builder
Assembly Version: 2012.8.19.0
Win32 Version: 2012.08.19.00
CodeBase: file:///C:/Program%20Files%20(x86)/EZ-Robot/ARC.20Installer/ARC.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
EZ_B
Assembly Version: 2012.8.19.0
Win32 Version: 2012.08.19.00
CodeBase: file:///C:/Program%20Files%20(x86)/EZ-Robot/ARC.20Installer/EZ_B.DLL
----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Speech
Assembly Version: 3.0.0.0
Win32 Version: 3.0.6920.1109 (lh_tools_devdiv_wpf.071009-1109)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Speech/3.0.0.0__31bf3856ad364e35/System.Speech.dll
----------------------------------------
Microsoft.DirectX.DirectInput
Assembly Version: 1.0.2902.0
Win32 Version: 5.04.00.2904
CodeBase: file:///C:/Program%20Files%20(x86)/EZ-Robot/ARC.20Installer/Microsoft.DirectX.DirectInput.DLL
----------------------------------------
WindowsBase
Assembly Version: 3.0.0.0
Win32 Version: 3.0.6920.5011 built by: Win7SP1
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/WindowsBase/3.0.0.0__31bf3856ad364e35/WindowsBase.dll
----------------------------------------
Microsoft.DirectX
Assembly Version: 1.0.2902.0
Win32 Version: 5.04.00.2904
CodeBase: file:///C:/Program%20Files%20(x86)/EZ-Robot/ARC.20Installer/Microsoft.DirectX.DLL
----------------------------------------
ugrxyfne
Assembly Version: 2012.8.19.0
Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:





When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
#4  
It seems that the assembly binding is turned off. Don't know why. I tried to set the fusion to a value of 1, but could not find the key.
Canada
#5  
I can't seem to get it to work either.

It craps out with an error and then locks open the .EZB file so
I have to re-name and save my file as something else.
#6  
OK, Lumpy, here is what I did to make it work.

I created an autoconnect script that called init.

then I right clicked and sent the shortcut to the desktop.

then, I dragged the shortcut to the start bar.

then I dragged the shortcut to the Start-up folder.

Now, when i turn on the computer and EZB, the robot starts and initializes and waits for verbal commands.

Oh, i had to place connect Robot please
and disconnect robot, please to the speech recognition script.

Look at the auto connect script under examples.

I finally have my basic finished robot and she works good. I just don't have a suitable place to operate her because I have no room in my apartment.

yeh!



:D
PRO
Synthiam
#7  
Do you have 32 or 64 bit windows?
Canada
#8  
Running 32 bit Windows here.

I'll do some screen captures tonight.
#9  
I am running 64bit win7. But, as I said above, I went another way and I was able to accomplish the same thing.
Canada
#10  
Make sure your antivirus did not block the reg edit, since the shell extension is registered during the installation. If you see the debug calling for the registry its usually a sign that the shell extension failed. In such case disable any A/V or spyware apps and either do a repair or reinstall.

I have seen this with some of my apps and its usually been the above or registry permissions set on the reg hive do not allow the installer service to write to them.

If anyone is really interested in seeing what happens during the installation and where the failure occurs you can enable MSI (windows installer ) logging and look through the logs for failure or fail

Trevor
PRO
Synthiam
#11  
@tklass, the wscript isn't installed during the installation. It should be part of the windows installation, but for some reason many issues arise around it. So the release for tomorrow is the interop IShell interface to create LNK's instead.
Canada
#12  
I do try to search the forum before asking:) but alas, didn't find a solid answer about this issue... Has it been solved? I am running latest release 2012.10.09.00 & Win7 Ultimate 32bit.

I just tried it today for the first time but am unable to click on the final button "Create Shortcut" as it is grayed out.
User-inserted image

Clicking the other button crashes something:)
User-inserted image
Canada
#13  
Figures... Hours of searching/reading, a few failed attempts and finally posting my question, and then right after clicking reply, I think of something else to try...:P

Even though all the folder and file options defaulted to the correct choices, If I manually select them anyhow, then it works...

So, not quite right, but workable:D
PRO
Synthiam
#14  
Ah perfect, thanks for that error checking. That button is now greyed out too in the next release. They only become active when all of the pages have successfully been configured. Verify you have no items in RED on any pages.
Canada
#15  
Thanks for the feedback DJ. All items are green, but I found that I only need to manually select the project file, even if it is the one already loaded, has all the correct info and marked as green.

Now something that may or may not affect the situation is that I have redirected my user folders to my D: drive (thus this is what I see, but still must select the same file manually)...
User-inserted image

Not sure if that would have any affect or not on how the shortcut program looks at things? Hope this info helps.