Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
United Kingdom
Asked — Edited

Introducing. Me!

Hello EZ-Robotiers!

So my kit arrived today and I thought it is now the best time to say a quick greeting, pass on my initial observations and ask about an extremely minor issue.



Me: So I'm an IT professional by trade with a long established love of technology and somewhat passionate about understanding the world around me. I'm a complete robot amateur but plenty of experience with programming. I'm likely to need help with components and electronics while likely to help with coding and generalised issues.

EZ-Kit: So, like I said I just got my EZ-Robot kit and it's fair to say the excitement and creative juices are rife! Everything about this product is excellent; the price, features, presentation, contents, delivery time... everything! Just a small note on the power cables for fellow UK residents though, you will need a travel adaptor to accompany your kit.

Small Problem: I ordered the bench power supply but when I plugged it in (via the travel adaptor with the supplied kettle lead) the LED on the pack didn't light up and no power to the EZB:( I whipped out the batteries and connected to battery pack and the board is fine (phew!) so thinking that either the power cord or pack is faulty, I connected a standard UK kettle cable but the pack still doesn't come to life. Any suggestions what I can try next? I thought I'd ask here before cracking it open and prodding around. We're 230V mains voltage here in the UK if that makes any difference.

tl;dr I love my new EZ-Robot kit:)


User-inserted image

#1  
Use a multi-meter and measure the power output of the power supply.
United Kingdom
#2  
Hey man, can't say i can help with your problem, i'm pretty new to this stuff myself, but just thought i'd say hi and nice to see a new brit on the boards:)

Best of luck getting everything up and running.

Matt
United Kingdom
#3  
Welcome to the EZ-B world
United Kingdom
#5  
Hello and thanks for the warm welcomes:D Where are the Brits from then? I'm from sunny Staffordshire.

@robot-doc the kettle lead (from the plug socket to the pack) seems ok, the meter shows voltage but I'm not getting a reading from the bit that connects to the EZB from the pack (barrel connector?). Any other ideas? Cheers *blush*
United Kingdom
#6  
I've still had no joy with this, I'm thinking it's DOA :( I tried emailing into Tech Support but it seems they're too low on staff to take queries direct - any other ideas or shall I cut my losses and crack the power pack open for a good old fashioned diagnostic?
United Kingdom
#7  
Hi I didnt get a bench power supply as my EZ-B orders were pre this. Is the lead from the power pack to the barrel connector all sealed? and where did you measure the voltages? I would also cut off the 2 pin plug supplied and stick on a standard UK plug its a 240v compatable device and it eliminates another potential problem with adaptors

About the only thing that you could replace yourself would be the barrel connector which may not have been made properly. A switched mode PSU like this cant really be fixed a trip to Maplins will get you something to replace it fairly cheaply or just a replacement barrel to solder on if thats the problem. Normally the EZ-B guys are pretty good at sending replacements for DOA parts check your junk inbox
United Kingdom
#8  
The supplied kettle lead works, I ruled that out by sticking the plug into a travel adaptor and connecting it to my monitor, which powered up. Connecting my monitor cable to the power pack has no effect, so I think I can safely rule out the power cable at fault. I'll try to take a photo of where I'm measuring the voltage on the barrel from, I'm not sure I can articulate it nor am I convinced I've even done it right *blush* I placed on end onto the outer metal (which I presume is the ground/negative?) and the other inside the barrel (to the little pin that I presume is the live/12v feed). The barrel seems in fine condition and there are no obvious kinks in the cable itself.
I've checked my Junk but I wouldn't have expected a message as the Contact form wouldn't allow me to send, predefined notice when you go to the Contact page... That said, I appreciate the cost of shipping a replacement would hit the EZ-pockets, I'd rather they get a refund from the supplier and use the cash to keep up the great work:D

Am I understanding this right that if I had any 12v DC pack that supplied 5A (and a barrel that fit) it would be ok to use as a replacement? I've got an old 'universal' laptop pack that might well do the trick if I snip the existing barrel as you suggested.

Thanks for the help and advise, I'll try to grab a photo this weekend.
United Kingdom
#9  
Hi a pic would be useful

Almost anything from 7v to 12v DC and say 3 to 5 amps would do as long as the polarity is correct and the barrel is the right size. Check the barrel is the same size (if you can?) as the battery pack one
#10  
i would check connections with a meter first from power supply to barrel
center pin is postive and outside barrel is ground,second did you check the voltake at the barrel without plugging into the EZB ,might be a short
second you might have the voltage backward witch would short out and give you zero volts
second is there a current limter control on your bench supply ,mostly only need less then 500 ma for to power the board
i am electronic engineer so can help you slove the problem,have a make and model of the bench supply
you may have a current problem without the specs and if it runs on 120 volts instead of 220 volts
there is a simple design to make it work on 220 volts and there should be a plate for voltage and sometimes a switch to switch between 120 volts and 220 volts ,called voltage selector switch
first i would disconnect from ezb and use a current meter on the barrel

i would recheck the EZB with battery connector,since you did say it work and now it might be shorted out,the fuse should take care of it,depending where the fuse is the circuit,so check the fuse,if bad your connections are reverse that would bring it to zero with it plug in,the barrel connector also could be bad,it may have a bad solder joint ,but if using the one on the battery pack, it is fine