Asked — Edited
Resolved Resolved by DJ Sures!

Inmoov Battery Question

Hello fellow Ez-Robot Users,

I am in need of some help, I have been building my Inmoov for several months when I have the time and came across this issue. I first had a e-fuel power supply 12v at 30a which I found out very quickly that it was too powerful to power my ezb4's (two that I have).

I now have a 6v 50a power supply. When I connect to the network and have both running, it does not move not of my servo's? I have tried using 5 at first then down to one, Then I disconnected the first Ezb4 and tried my second one, still nothing, I then cranked the voltage up to 7.4 to see if it would make a difference and it doesn't.

I'm scratching my head here? When I test the servo's with my ezrobot 7.4 bower battery it seems to work fine.

All the help is much appreciated.


Skip to comments


Upgrade to ARC Pro

Synthiam ARC Pro is a new tool that will help unleash your creativity with programming robots in just seconds!


Post a link to your power supply... If you are using Hitec 805bb servos DO NOT USE VOLTAGE ABOVE 6V you will burn your servos... I use a Meanwell 6V 50A power supply will no issues... What type are you using? Maybe you have destroyed your servos using 12V?


I have a Meanwell 5v 90a I was using at first with no success, I then unboxed a power supply 6v 50a from China which Gael recommended from the Inmoov website, I believe the name is Wenzhou or Sense I cannot find a name on the power supply or the link of it?


So the 6V/5V power supplies would not work to move even 1 servo?... Do they at least run the ezb4 and camera? Do you have a picture of these power supplies? Maybe the supplies are not outputting what they are supposed to... Stick with 6V max on Hitec 805bb (if that's what you are using) or you will damage them... Do you have the power supplies wired correctly to 120V AC (hot, neutral and ground wires)?


Have you disabled the lipo power saver if only running 6v? No I/o will work if the power saved is on under the specified default voltage.

The ezb will repeat over and over forever "my battery is low". In which case, no I/o will work until disabled.


So just to be clear; you tested the servo's with my ezrobot 7.4 bower battery the servo works fine? However when you use one of the power supplies to test the same servo you get nothing?

Are testing through ARC or just hooking the servos up to power? There is a setting in ARC that won't let your servo to move if your under voltage. You need to disable this setting before ARC will move your servo.

Have you re-tested the servo on the battery after you tried the power supplies? If not you could have damaged the servo with to high voltage or using to low voltage and the servo won't move. I'm concerned you may have damaged your servo when you first supplied 12v to it.

I don't see anywhere in your posts what servo you're using. What are the specs and model of the servo are your using? If it requires more than 7 volts it may not move.

As RR mentioned, make sure all your wiring is correct, your supplying power within the proper voltage range per the servo's specs, and all your settings in ARC are correct when testing. If you are supplying voltage to the servo without using ARC to move it, you may not see it move. The only way it may move is if it's not centered when voltage is applied. Then it may move to center when powered up. If already centered then it will not move. However It's possible that it may hold position at center when leverage is applied after power up without a signal from ARC but I'm not sure. RR may be able to say. He's got a great understanding of servos and how they behave.

Your power supplies are more than capable of supply the amps needed to operate this one servo. You can't offer a motor to much current. It will draw what it needs. However you can starve a motor and it will draw more amps then can be supplied. This can damage the power supply or motor or melt wiring and connectors. eek Proper voltage is important. DC motors are tolerant of over (by a little) and under voltage. However when you add a control board to them and turn it into a servo then you must keep the voltage within specs. The little components controlling the position and speed of the servo need to operate within a certain voltage range or they can be damaged. Sometimes in a spectacular way. eek Then sometimes you don't even know. tired

After you are sure you have your supplied power within the proper range and all the connections and control methods are correct you may have to test with a new known working servo. ;) Good luck. :)


I think @DJ may have the right answer... Servos won't run if the LIPO voltage monitor override is not active and the voltage is below a pre set value (7V is default). In other words If ARC thinks you are using lipos and the override is not active, servo movement will be disabled if battery voltage is 7v or less..


Thank you everyone for helping,

That is correct Dave, I have tested the servos after the incident with the 12v power supply using the with my ezrobot 7.4 bower battery the servo works fine.

I have disabled the battery monitor override in the settings. When I first connected the power supply it kept repeating low battery and I read a response someone had the same issue to disable it. Is this the correct way to disable the lipo power saver?

When I first used the 12v I had to replace two hs-805bb servos in my shoulder and bicep, unfortunately I fried them. My right hand forearm, bicep and shoulder were not completed yet. I'm using new ezb servos for the fingers for my right hand and hs-805bb for the rest all tested using the my ezrobot 7.4 power battery. Still no response from my servos on my right side using both power supply's.

Thanks again everyone for your help,



I managed to figure out my issues.

First thing I did was disable the lipo power saver, then I tested my right arm. Unfortunately, the servos in my left arm (fingers) are fried and now have to get some new ones, but at least my power supplies are working and moving servos.

I'm just happy things are moving forward again.

A big thanks to everyone for helping. What a great community EZrobot has here.



Ahh, so I was right. You did have bad servos. Sorry for your loss. stress Or did you manage to figure out how to disable the low power safeguard?;)


Hi Dave,

You were right, the servos are gone. I already ordered new ones and I did manage to disable the power safeguard as well.

A big thank you for your help, It is much appreciated.



No prob Rob. LOL. :) I just was curious what the final problem was. Sounds like it was a cobo. It's always harder to figure out problems we there are more than one.

United Kingdom

I think JD hit the nail on the head regarding not disabling the low power safeguard’ for the Lipo battery.

I’ve falling for this a couple of times on my InMoov using the 6v SLA battery when creating a new project on ARC and not disabling the low power safeguard’ Also having the audio turned off on my Amp, so I don’t hear the warning message. stress