Welcome to Synthiam!

The easiest way to program the most powerful robots. Use technologies by leading industry experts. ARC is a free-to-use robot programming software that makes servo automation, computer vision, autonomous navigation, and artificial intelligence easy.

Get Started
Asked
Resolved Resolved by DJ Sures!

Inmoov Multiple Servo. My Power Supply Will Not Power My Servos

I am going to try to configure this robot using the EZ-B V4. I'm currently trying to power 6 servos for the right hand. The servos are MG996R, they require 6V. I purchase a power supply ( DROK 48V Power Supply, AC 110V/220V to DC 0-48V 10A 480W Buck Converter, Adjustable Variable LED Adapter Regulated 5V 12V 24V 30V 36V 48V Volt Voltage Transformer 10A Amp Charger for Lab CCTV Radio). It can regulate 6Volts of DC output. As I understand from previous conversations in the knowledge base. I will connect the signal cable from the servo directly to the EZ-B. And connect the servos power cables to a bus bar positive and negative from the power supply. I do not have the bus bars yet. But I am testing 1 servo directly connected to the power supply. When I connect it I cannot control the servo it seems like is has no power. Than the servo will start up on it's own moving back and forth uncontrollably. I can measure 6V coming from the connections of the power supply. I do not think the lack of bus bars is the issue. Here is the link to the power supply that I purchased: DROK 48V Power Supply, AC 110V/220V to DC 0-48V 10A 480W Buck Converter, Adjustable Variable.

Any input would be greatly appreciated. I have a second power supply with no adjustable output of exactly 6V. It does the exact same thing as the other. This is for an inMoov robot. Any links of the correct power supply or configuration would be greatly useful. 

Thank you!


Related Hardware EZ-B v4

ARC Pro

Upgrade to ARC Pro

Synthiam ARC Pro is a cool new tool that will help unleash your creativity with programming robots in just seconds!

#1  
I forgot to mention that the servo is in perfect working order. I can power it and control it when it's connected to the ZE-B power and signal. But when I leave the signal cable connected to the EZ-B and I try to power the servo with the power supply it will not work. It turns sporadic to the left and the right with out stopping.
#2   — Edited
Hello @Monterdur,

Does the MG996R servo have a large load that it is trying to move or are you testing it with no load?
Try testing with no load at first.

Does the servo move back and forth with only power connected to it (signal pin to the EZ-B unattached)?
This will allow you to determine if the issue is the power supply or a floating signal sent by the EZ-B. 

When is the servo moving uncontrollably? Before the EZ-B is connected to ARC or after? If it's still happening after you connect to ARC, try sending it a servo signal (using the horizontal/vertical servo skill or a script). 

My hypothesis is that your servo does not like a floating signal, so I think that once you send it a signal you should get control back over the servo. You can test this also by connecting the signal to ground.

It is difficult to tell with MG996R servos as there are a lot of knock-offs and low-quality servos out there. If you are having too much trouble I would recommend switching to the EZ-Robot HDD servos which are known to work perfectly with the EZ-Bv4. They also have more torque than the MG996R.
#3   — Edited
Funny (not really), I was testing this exact model of servo on my robot last week. I found it was moving a bit when powered up or other servos were commanded to move by ARC. It turned out to be a grounding issue. I was pulling power for the servo from a different part of the robot then the EZB the signal wire was powered. Not sure if I was pulling power from two different voltage converters ( I have many in this robot) but I'm sure there was no common ground between the two points of connection (voltage/ground and the device I had the signal wire attached to). I solved the problem by running a common ground wire from one of EZB's Digital port ground pins to the ground wire of the servo (while keeping the servo's ground wire attached to the original power point I was drawing from). 

Short answer; try running a common ground between an EZB digital port's ground pin (anywhere you have the servo's signal wire plugged in) and the servo's ground wire. 

I don't know how you have your robot wired or powered but things like this happen when you have floating grounds or ground loops.

Quote:

My hypothesis is that your servo does not like a floating signal, so I think that once you send it a signal you should get control back over the servo. You can test this also by connecting the signal to ground.
I found Jer's insight to be true. I also found that once I sent a command to move the servo, it would settle down and wouldn't jump around anymore. However the common ground solves all this.
PRO
Synthiam
#4  
I’m guessing he doesn’t have a common ground across both power sources. 

But those servos will work fine with the ezb power. Just connect your 6v to the ezb and connect the servos directly. The battery monitor in the ezb will need to be disabled using 6v
PRO
Belgium
#5   — Edited
hi all 

remember the MG995/MG996 do not have the full range off 1 to 180 ,
but more like 5 to 175 . today they work tomorow you dont know .
when using these have spare servo's . sometimes they stop working ,
whithout any warning . also they not protected to burn out .
#6  
Gentleman, thank you all for your input. All of your suggestions worked. I did not think to mention that the power source to the EZ-B was not the same as the power source to the servos. Still with this limited amount of information that I provided. You were all able to target the issue perfectly, Impressive. I ended up connecting the EZ-B to the same power source as the servos for a 6V from the power supply. Issue resolved. Thank you all. I will surely return when I start configuring the 5 servos in EZ-B to close and open the hand. I do not use EZ-B very often so I’m a beginner. Thank you all again for your amazing support.