Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by bhouston!

Help Stop Spasm

When I first received my JD, I contacted EZ-Robot support because when connecting to the example actions, he would violently jerk and twist. The neck servo broke the second time I executed (EZ-Robot quickly shipped out a replacement).

Jeremie provided information about calibrating & fine tuning the servos and although completing the steps did improve performance quite a bit, I am still getting a violent spasm when executing the actions on the 1st exe. only. All additional executions work fine.

My router is only a few weeks old. We have the fastest residential internet Comcast offers, I never have any issues with connectivity on any other device.

I just put together a quick video showing the spasm issue: http://www.screencast.com/t/5vphNsQCC2N0 . Please review to see if you can point out what I am doing wrong. I show my settings and JD reacting to execution.

Video of JD Spasm

#1  
Look at your individual servo controls... They may be conflicting with your servo Auto Position movement panel...These individual servo controls may be causing your problem... Open up JD's sample file and see how that works or remove the individual servo controls and try again... Just my guess, however....
#2  
You need to give the robot a position to go to when you connect to it. In Settings in Connection you can put a command in the "Connection Established Cmd" box. Put the position you want the robot to go to upon connection there.
For example, if you have a "Rest" position created in" Auto Position" and that's the position you want it to go to when you connect to it, put that command control in the "Connection Established Cmd" box. You might also want to try and leave the robot in this position when you disconnect from it.

I hope this helps you out.
#4  
Hi, I'll try;

In the upper left hand corner of your ARC screen is the 'Connection" window, Click on Cogged wheel icon. On this screen you see "0 - Connection Established Cmd" click on the pen icon. This takes you the "Event EZ-Script Editor page, click on "Cheat Sheet". Find you script for your "Start Position" , click on that and it will put it on the left side of the page, click "Save". Now you should see that command in the box beside "0 - Connection Established Cmd" click Save. Now when ever you connect to your robot I should go to this position.

For more information you can also do a search for "init" or "initialization script" in EZ Script on the Community Forum page, there are a few more examples there.

Let me know if this works for you.
#5  
@bhouston thanks a million. That worked perfectly. I have not connected with the mobile app yet, but when I do is there anything special I should know to prevent the spasm? I don't know if there will be Cheat Sheet.
#6  
Glad to hear that worked for you. I have not used the mobile app, I am waiting for the iPhone version. Post that question and I'm sure someone who has used it will advise you on how to set it up, there is also a tutorial under Learn to get you started.
#8  
Mobile version will execute the same on-connection script and work the same way.

Alan
#9  
@thetechguru thanks for the confirmation.
PRO
Synthiam
#10  
The example JD project has no "spasm". It sounds like you are not using the JD example project. If you don't use the JD example project, you won't be able to share animations with others because the servo configuration will be different - also you will experience strange things like "spasm". Please use the example JD project:)