Asked — Edited

Help! I Can'T Get Y Camera To Work

I have the EZ camera and hooked it up just as described. My computer uploaded the drivers when I plugged in the dongle and it shows up in the dropdown list. When I select it, nothing. I get the red grid but no images. I have a digital set control set to the DO of the camera and turn it on. Still nothing.

What do I do?


Upgrade to ARC Pro

Synthiam ARC Pro is a new tool that will help unleash your creativity with programming robots in just seconds!


Is the light on the camera? Did you charge the battery for an hour or two before using it?


Crossing my fingers its a simple fix , I still been cutting and fabbing the structure of.omni 2000 and haven't tested anything yet , I hope its ok Bret


@DJ The light is on, but no, I did not charge the battery. Do I need to? How do I do that - thru the EZB?

@jstarne1 - Thanks! I made the mistake of mounting everything before testing. Be sure you don't do the same lol


Charge that battery for.about.4hrs for.its.first charge.Brett , and for.the.first couple charges don't recharge till its dead. It trains the battery to have max capacity. Take note they aren't anything nearly as bad about initial charges as nicad so you should do charge it now.:)


@ Bret , there was a USB adapter its white with mine, plug in the household USB adapter and plug the mini USB cable into to USB on the camera. That's how it charges. ;)


I did not receive that white cable with mine. Only the black one that I cut up to attach a connector to.


Maybe they left it out? But you got the USB ac adapter so just get a mini USB cable , last year they.were popular for cell phone chargers and data cables.


okay, it is charging. I'll let you know how it goes. Thanks Josh.


Speaking of charging I should charge mine so I can bench test it tommorow. :)


Charged for 4 hours and still nothing. The webcam on my computer worked fine and shows my smiling face in ARC, but no luck with the wireless. Not sure what to try now. I tried with both my desk top and laptop and the same result. The cameras in my computers work fine and show an image. But I get nothing from the wireless.


Awe man ! That sucks. Hopefully if its the cam as the problem they will exchange it . You haven't modified it or taken it out if the case?


Got it working!!!! I bypassed the usb connection and wired it as described by WINSTN60 in another post. The camera is tied directly to the red and blk wires of the connector. By passes the battery completely. Only thing is, my image is upside down LOL. I guess I will just have to figure out a way to remove the hot glue and rotate it 180 degrees. Unless anyone has a suggestion? hahaha


Huh? So your camera will not work wirelessly? Or its not possible to have USB plugged in while in use? What mod specifically did you do? Did you open the case?


It works wirelessly. I had opened the case and wired it to the EZ-B as DJ had described, making the mini usb port on the camera tie into the EZ-B. via a servo cable. So now I do not use the mini usb plug on the camera and instead tied the wires from the cable right onto the camera's board as described by winstn60 in another thread. It works great now. But I guess I mounted the camera upside down in omni's head so now I have to cut it loose and reposition it somehow.


I havent found a solution yet. So you soldered the power wires from the ez-b directly to where the battery used to be soldered in? Just want to be sure before I start taking it apart


Camera is working but I guess I mounted it upside down. Any ideas out there how to loosen or remove all the hot glue without damaging the camera so I can rotate the camera 180 degrees?


what do you mean by its mounted upside down? is the image upside down? if it is invert the image in the config function of the camera in EZ-B. I just got mine off, I posted so pics on it ....


I didn't see a box to invert the image - yes, it is the image that is upside down.


a stupid question, did you mod the camera? if so, do you know where is the top of the circut after taking it apart?

User-inserted image


Yeah, I mounted it in the head upside down - it fit better that way. I never even thought of of the image being upside down, I kinda figured you could invert the image. But no such luck. I guess I will have to remove it and remount it. What a



Thank you


@robot56 - you're welcome, but the real thanks goes out to winstn60 as he was the first one brave enough to try this.