Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

H Bridge

Hello to all and Happy New Year. I am having an issue. When I turn on my H Bridge it not only runs the motor it is supposed to but it also runs a modified servo that is not connected. If I change ports for the H Bridge control it changes the modified servo that it also controls (sometimes). Is there a solution such as a draw down resister on the modified servo ports? Any help would be greatly appreciated.

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
#1  
DJ,
Can you chime in on this issue. Why would the modified servo activate when an H Bridge is activated?
PRO
Synthiam
#2  
Can you provide more detail? Are the hbridge and servo plugs against each other? Maybe its picking up noise? Are you certain there is control that is using the Modified servo port? Maybe a Radar Control or something, with the port set.
#3  
I am using two modified servos but not as drive motors. I have tried moving the H Bridge port and it starts the other modified servo. I swiched out the modified servo ports and I still get one of them moving when I turn the H Bridge on. Very strange.
#5  
I am running the TB6612FNG. I think I will try capicator on the motor. That sounds like it just might do it. I will let you know. Thanks for the prompt responce and great advise.
#6  
I just took a look and found a couple of 103 ceramic disc capacitors that I think are about .01 uf. Do you think that should do it?
PRO
Synthiam
#7  
only one way to find out
Canada
#8  
Hi Bookmaker, did you try the capacitors out, did it help? I have some weird problem of my own with this Hbridge, I posted it over in the main topic for it if you are interested. Maybe you have the solution I'm looking for:)
#9  
Hello Sirlal,
Yes, the capacitors did the job. On your other issue the h-bridge is left nutral when you start up EZ-B and only goes to a 0 state when you connect. So the solution is to put a switch on the power supply to the H-Bridge and leave it off until you connect the blue tooth.