Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
United Kingdom
Asked — Edited

Frustrations With 2013.03.18.00

I'm really struggling with this version 2013.03.18.00 anyone else got these problems? and yes I realise some of these changes have been with us a while in earlier versions but ARC stability and connection stability is getting worse. It used to be really rock solid now I'm getting screen freezes and odd behaviour that was never there before.

1. Controls panels move all over the desktop and sometimes they freeze and you can't drag them to where you want while others you can
2. The constant popping up of the connection dialogue screen is a real nuisance
3. The worst thing though is the Horizontal and Vertical servo scroll where you have to drag with your mouse to control a servo position. I realise this is probably great for touch control screens but it takes nearly 3 full sweeps to get from on end of the servo travel to the other.

I much preferred the old servo control sliders. (If I could request just one thing it would be this)

Neil

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
Canada
#1  
I'm having issues but I'm running Vista.

Windows 8 upgrade is arriving tomorrow.

Constant screen freezing, dropped connections, no processed video.

Hoping newer Windows will resolve some of these issues.

What are you running for OS?

Kris

P.S. The servo scroll drives me batty too!
United Kingdom
#2  
Hi Kris,

You should be much better off with Windows 8 than Vista. I'm on Windows 7 on 2 machines both of which behave the same. I've seen your threads on no processed video so thats an odd one? be very interested to hear if 8 clears that up and maybe resolves other issues. Keep us posted

Glad you agree about servo scroll
United Kingdom
#3  
1. I haven't seen this problem and I've spent the best part of 50 or 60 hours in ARC in the last week. When you say they freeze can you not move them at all, ever? If they jerk around and start/stop when dragging it could be indicating a performance issue. I Have noticed the performance has been reduced on my HTPC which I use when testing things out, I can no longer listen to music and use ARC at the same time and the camera is much less responsive than it was 3 months ago however that could be computer related not ARC related.
2. Are you talking about the debug box? It should only pop up when connecting or if there is a problem not constantly.
3. Mine move from 0 to 100 in pretty much the width of the "Getting Started Tutorial" control. Try moving your mouse slower, it seems to make a difference on mine (just tested it out).

Not much help but more info on the points raised.
United Kingdom
#4  
Hi Rich,

1.The connection panel is the most common to get stuck but its random and I would agree its related to machine resources. I spent a few hours on this today and kept trying to alter the desktop layout something I used to be able to do with ease BTW and some panels now could not be moved at certain times while others could? My laptop is an i5 and used to run ARC with ease now if I say change camera resolution it will often appear to stop and I have to wait for the application to eventually respond or it completely freezes. Interesting what you say about your camera

2.Yes the debug box I'm running a few simple things now in the background and the box is staying hidden (great)if I do something more complex like moving a servo its popping up all the time with comments like 'disregard incoming buffer this should never happen'. I guess we need a hide always tick box

3. Yes just tried a slower mouse movement that seems to work actually good tip

Perhaps ARC has just got a lot more resource hungry
#5  
I have been having problems with the control boxes freezing in place once in a while. The only way I've been able to drag them around after this happens is to make a different control box active by ckicking on it a few times then go back to the one I want to move.

The Control boxes moveing around by them selfs may be because you have the Auto Arrange ticked in the Add Control section.

I also have been having connect issues but I thought it was because I have 3 EZBs sending info through a cheap BT Dongel. I was going to up grade them all to a XBee.

I dont like that Debug screen popping up at the bottom either when I'm connecting or didnt connect. It's a pain and the project always auto scrolls down to see it.

The only time ARC compleatly freezes for me is (just sometimes) when I save and exit. Then I have to bring up Task Manager to shut it down.
United Kingdom
#6  
I will try that next time it happens Thanks

Just turned off Auto Arrange in the add control section

Lately I'm always bringing up task manager click on ARC then it says its waiting for a response from me and the close ARC dialogue box becomes visible I click no and get control back again
PRO
Synthiam
#7  
If you can share more details of what you are doing when causing the issues - we can look into it. Unless we are aware of the situation, there is nothing we can do:) ... We require you to share your configuration and experience.

Also, if the pop-up debug is displaying often - then we need to know why. If you could paste your project and a copy of the debug log, that will be helpful.

As for changing the camera resolution - you will have to wait as that is not an issue with ARC, it has to do with windows and memory management. Remember how much processing and how many processes must be running to achieve what we offer in functionality. Every time a fundamental value of the supporting framework is modified (ie resolution), the entire system needs to refresh itself to compensate for the memory paging and allocation changes.

If changing the resolution is something you do often, I can not understand why:) But sadly, you will continue to experience the momentary lock-up during the change.

So in order for us to help understand what issues are caused by your specific configuration, we need more information from you:) .. We need specifics of what you're doing, share the project, and paste the debug message.
PRO
Synthiam
#8  
On one of our test computers, I was able to produce a "lock up" in ARC. It would lock up on the camera control occasionally. Specifically when adjusting resolutions...

After some testing, I was able to isolate the incident. On some computers the capture device releases the handle before the processes have completed executing. I've added some code in the next ARC update which will compensate for that.

In short, it means I've fixed that issue for any one experiencing it:) ... It'll be in the next release - which will be near the end of the month. It's a big release, so it's taking some time
United Kingdom
#9  
Thanks for looking at this DJ
PRO
Synthiam
#10  
No problem:) Can you provide me with a sample project that raises the debug message "Disregard incoming buffer" ?
United Kingdom
#11  
This is the message I get (edited below) I also uploaded the project which is a modification of Rich's Pingoroam.
One other thing this is a V2.1 board might try my V3 board later.

Just noticed it says 'disgard' not 'disregard' incoming buffer if that helps

It starts off all ok then just gets progressively more problemactic

Attempting connection on COM8
Connected to COM8 at 9600
EZ-B reports EZ-B Firmware V16
Connected
Disgard incoming buffer (This should never happen)
Disgard incoming buffer (This should never happen)
Comm Err: The operation has timed out.
BbytesToExpect: 1

pingroam-634988802282187500.ezb

Just chucking some more amps into my Omnibot for some more testing.
PRO
Synthiam
#12  
excellent. Man, I can't believe you're running a v2.1! That is so awesome:) You've been around here for a while!

I have a v2.1 in my Omnibot also. I think I only have 2 of them... which is kind of sad because those are the ez-b prototypes - might be worth something someday!

I'll take a look at the project and see if I can find out what "disgard" meant to me in 2011:D
United Kingdom
#13  
Yes people may come and go but I'm still here

Just tried a simple project for a few hours and it all worked flawlessly. No camera though I'll add a camera control tomorrow and see what happens

:)