Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by Rich!

Facial Recognition Question

Hi,

I've been through the tutorial on facial recognition. Two issues:

1) I'm getting 'false positives.' Roli see's my face and moves (Enable Movement Tracking is checked) Works great. When I'm not seen by the camera, he often responds. What setting is off? I've adjusted the grid & changed rooms assuming lighting could be an issue.

2) I'd like Roli to watch me as Omnibot does with DJ Sures's tutorial video. I checked servo Tracking but there's no response. I can see the square around my face so obviously the camera sees me.

I guessed that it might have something to do with the ports. On the configuration screen, I selected ports 9 & 10 (horizontal & vertical) but still no response.

Any suggestions are appreciated. Thanks in advance.

Tom

AI Support Bot
Related Content
Synthiam
#1  
@Tom... Do you have any other types of tracking enable as well?... Like colour or movement? If so disable all tracking except for facial and see if that helps... I also notice that if I use tracking in a cluttered area I get a lot of false positives... The ports you mentioned (port 9 and 10) should correspond to the x and y servos in Roli's head... So those will have to keep enable.... So one type of Roli's tracking is when the entire robot moves in order to track... (movement tracking). The other type is servo tracking where Roli will only move his head (camera) to follow your face or a coloured ball.... etc....
United Kingdom
#2  
False positives are usually a result of poor lighting. All of my cameras have trouble tracking faces due to low light conditions.

Add more light:)


Servo movement - check the grid. Only if that yellow box isn't in the centre square will it move. Also double check the ports, the options (inverted movement etc.) and that servo tracking is enabled. Relative tracking needs to be disabled for Roli in his/her intended configuration.
#3  
Hi Richard,

Only Facial tracking is checked. The x servo is port D9 and the y servo is D10. Enable Movement tracking is deselected. Track by Relative Position is selected. I only want Roli's head to move as I move.

I also tried different rooms to see if lighting was an issue. Still no response.

Just to confirm, Facial tracking works when Enable Movement Tracking is selected.

It doesn't seem like the signal is reaching the servos when Track by Relative Position is checked (Enable Movement Tracking and Enable servo Tracking are deselected.)

I've attached a screen shot of the configuration window. Are the settings as they should be?
User-inserted image
#4  
Rich,

Yes, I discovered that poor lighting and clutter in the room results in false positives. So that's cleared up. Thanks.

Tom
United Kingdom
#5  
@tom.caine.

Quote:

and that servo tracking is enabled. Relative tracking needs to be disabled for Roli in his/her intended configuration.


Rich mentioned that Reletive needs to be disabled and servo tracking should be enabled. Looking at your picture, you still have "Reletive tracking" enabled and "Servo tracking" is disabled. Have you tried it the way Rich mentioned?
#6  
yeah, relative tracking is used for a stationary camera. It is to move other things in relation to the camera position (like DJ's video of eyes in a head following him based on what the camera sees - video in the help for relative tracking).

Alan
#7  
Actually, in my quest to figure this out, I have selected/deselected both. I've selected servo Tracking and deselected Track By Relative Position. The only time I get any response is when Enable Movement Tracking is selected but obviously this is not what I want.

So to confirm - servo Tracking is enabled and there's no response.
United Kingdom
#8  
Servo Tracking - Enabled
Track By Relative Position - Disabled

Also, change the max and min values of the X and Y servos, both are set to 90 so the servo can't move.

If it's Roli, open the example Roli project and check out the controls.
#9  
Success! Rich that was it. The min/max were set to 90. I didn't understand that part. So I changed them to 1 & 180 and the camera now follows me.

Everyone else, thank you. I am a newbie to this and finding it difficult to connect all of the dots.

Tom