Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Germany
Asked — Edited
Resolved Resolved by DJ Sures!

Ez-Builder Version 2016.05.17.00 - Soundboard Noises - Bug Or Bad New Future?

Hi there!

I updated to the newest Software: Version 2016.05.17.00
If I playing Soundboard V4 MP3s the robot speaker makes bad clicking-noises.
first I hear a click, then play the sound..

I deinstalled the software and used an 1 month older version..
now its without any click-noises..

I updated to the newest software again..
the bad click-noises are back! *stress*

is this a new future or a bug ?

Smarty

AI Support Bot
Related Content
Synthiam
Germany
#2  
@ Dj Sures

thanks for the fast response.

here the video:



first you hear my mouse click, then the soundboard-click


cheers
Marty
PRO
Synthiam
#3  
Sorry, I need an Example Project so I can replicate the issue. If I cannot replicate the issue, I'm unable to know what I'm fixing. Hope that makes sense.
Germany
#4  
now the Example Project is online and ready to download. I shared it with my old account name: "asimo"
PRO
Synthiam
#5  
I will require a filename or a link to the project. Is it in the cloud? You can also upload to this forum using the attach file option.
Germany
#6  
its in the cloud/ file name: "soundboard 4.0 bug"
shared by asimo
#8  
I am having the same problem as Smarty, Getting "clicking" sound before speech starts. I don't have the problem with a ARC version from a few months ago. We had this problem awhile ago but I can't find the thread. I believe it was related to the Talk servo control. You fixed it DJ.
#10  
Thanks DJ, the lastest release fixed the problem.
Germany
#11  
big thank you @ DJ Sures
Germany
#12  
Update:

the soundboard works fine but sometimes I can hear the clicking noise..
the problem is not completely fixed.

example:

my robot follows his red ball..
every time he locates the ball he says: "my red ball"..

if the sound plays in in quick succession it makes a click noise..
(If I change the ball position fast)

regards
PRO
Synthiam
#13  
The code is original to what was there before. This is fixed as it was. The click is most likely due to the fact that the volume between the two sounds at the sample point is dramatic different positions. You can research how audio works to understand further, as you are playing multiple sounds not a single sound.

For example, if the last sample of the previous audio was the value of 208, and the first sample of the next audio is 54... there will be a click while the DAC jumps between the two voltages.

That's just how it works. You will have to accept that click between samples if you do not let the audio completely play, assuming that the audio ends with 127 and the next audio starts at 127.

The value of 127 is 0db on 8bit audio
Germany
#14  
@ DJ Sures

oh okay, thanks for the lesson :D

cheers
Marty
PRO
Synthiam
#15  
Anytime:)

I have been thinking of different ways to remove the click, but no success yet. One day i will come up with an idea:D