Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by JustinRatliff!

Ez-B V3 Question

Last night I broke open my ez-robot kit that is older than the one you can purchase now. When I started my old version of ARC it said I needed to update the software. I updated to the latest version. I then tried to connect to the ez-b board and it said I needed to update the firmware. I did this as well. Now when I connect it, it works great but none of the servos work from the board. I selected the boxbot project which I have made in the past and set it up the exact same way I did before and everything looks different in the builder. To assign the servo control it shows the new board and not mine. Any idea why my servos wouldn't work. I have used them maybe 4 times and the board is lit up etc. The new builder is very confusing since it shows everything for all your updated products and none of the old. Is there a way to set it back so I looks like it used to or at least allow me to see my ez-b board and not the new one. Please help.

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
#1  
1) First are you sure you are connected to ARC (not windows)? Is the led on your ezb3 board pulsing or is it solid?

2) check to make sure servo min is 0 and max is 100 (not 180)

3) Download and reinstall ARC and try again...
United Kingdom
#2  
Follow the diagnostics checks for the V3
Ensure you have power on the Vcc pins, bluetooth is working etc. etc. etc.

If all else fails, send it back to EZ-Robot and get yourself $50 store credit towards the newer, better V4:) The V3 will become obsolete and unsupported soon (ish). All updates to ARC focus on the V4 and will not be rolling backwards to the V3. There may be some older versions of ARC around which are V3 orientated however I couldn't tell you which version is the latest and who has a copy of it.
#3  
@Gearbox It sounds like you are doing things correctly. I have several v3s and can use them with the updated software. You can overlook the new pictures, d1 is still a d1, you know what I mean?

When you click on "Connect" you are selecting the correct Bluetooth serial port in the drop down box first correct? And when you click on Connect, it shows connected with out an errors, rights? I just want to make sure it is connecting first for you.

Which BoxBot project are you loading specifically? Which servos are you trying to control? There are head and wheel drive servos in that project. When I click on the controls for them I don't see pictures of either the v3 or v4, so I'm not sure where you are seeing them. My last advice for now is make sure the ports match in the controls to where you have them plugged in on the v3 board...ignore the picture of v3 or v4 just make sure if you have a servo plugged in d12 that the control reflects that also.
#4  
Thank you all for your comments. I have tried everything listed here and I still get nothing to work.

1. Bluetooth is connected. Solid blue light on EZ-B and when I connected to the board it said at the bottom that I connected successfully.

2. I loaded the EZ-BOXBOT-JOYSTICK.EZB project from the examples and hooked the serves up to the board. I went into the joystick area and made sure there were values from 1 to 100. My joystick shows it working but I get no motion from the actual servo rotating. I am using the SG4NF STD servo for the wheels and they are not working.

Not sure what else I can do to get this to work. I feel like I upgraded and now cannot use my product t hat I spent 400 dollars on at the time. This is horrible. Any other ideas would be greatly appreciated.

ARC Version: 2015.01.18.00
Firmware Version: 16.6
United Kingdom
#5  
Have you followed the diagnostics I linked to?
Have you checked the voltage at the VCC pins of the digital ports?
Have you set the digital ports to high/on and checked the signal voltage?
#6  
Ok I figured out the issue. Stupid me, I had the connections on backwards. I didn't know it mattered but when I turned the cables from the servo the other way it worked!

Thank you all for your help.
#7  
Oh my yes....don't plug it in backwards....that's very hurtful! It's great the your solved though and probably learned a lot in the process. Have fun with your boxbot!

Young Frankenstein "...until, from the midst of this darkness, a sudden light broke in upon me. A light so brilliant and wondrous, and yet so simple. Change the poles from plus to minus and from minus to plus. I alone succeeded in discovering the secret of bestowing life."