Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Ez-B In Wall-E Still Failing.

once again, I have tried to run wall-e and the ez-b turned its light off again, disconnected from my laptop, and sent the servos berserk.
How ever, the software did not freeze up this time. this time it failed when I tried to drive forwards. Custom Movement Panel configured to work with him right. I pressed forward, he went backward, and I pressed stop. bam. the ez-b disconnects, and goes berserk.

This is deeply bugging me as I really want to have wall-e up and running again. could we please take a look into this issue? Dj sort of dodged it last time.

Here is the debug:

Code:

EZB 0: 
EZB 1:
EZB 2:
EZB 3:
EZB 4:
TCP Server stopped
TCP Server stopped
TCP Server stopped
TCP Server stopped
TCP Server stopped
Camera Disabled
Camera Disabled
Camera Initialized: Wireless Video Device @ 160x120
TCP Server stopped
TCP Server stopped
TCP Server stopped
TCP Server stopped
TCP Server stopped
Speech Recognition Culture: en-US
Loaded speech recognition successfully
Attempting connection on COM15
Connected to COM15 at 9600
EZ-B reports EZ-B Firmware V16
Connected
Comm Err: The operation has timed out.
BbytesToExpect: 1

Received:
Disconnected
Disconnected
Comm Err: Not Connected
BbytesToExpect: 1

Received:
Disconnected
Disconnected

AI Support Bot
Related Content
Synthiam
United Kingdom
#1  
Have you got any object avoidance running? If it detected an object in front of it then it could reverse before turning which may be the cause for moving backwards when you hit forwards.

Post your project and let me know which ports run which servos and I'll double check your settings.
United Kingdom
#4  
Your project looks OK (although why use a custom Movement Panel when you could use the modified servo movement panel? To reverse a servo I think you can tick the box, if not set the minimum value to 100 and maximum to 1)

Triple check all of your wiring and servos. There is no way for the EZ-B to control anything randomly without ARC telling it to. Disconnect everything and add each thing in one by one, test each control after you add it. Also check the underside of the EZ-B and make sure you aren't putting it on anything conductive.

I'm pretty sure a problem with the EZ-B wouldn't cause the issues you have mentioned. If your wiring is OK try running your project on a different PC if possible, it could be something on the PC causing the problems.
#5  
ill make a vid of him failing.

the ez-b sits on the back of the battery pack(plastic.)

tried to use the modified servo movement panel, but left and right kept mixing up.

all wiring was check 3 times.

will try recreating the project file AGAIN.

my other pc does have ARC on it. if its not the project file ill try running it off of that.
#6  
I attempted another project file. I only set up the head and arm servos. he once again failed.

I will send the new project file to my other computer and see if the failure happens there too.

If it does, its the ez-b.
#7  
due my other computer been slow, I left the ez-b on so it could connect. I come back up to find the ez-b off and plugged in. I unplugged it and plugged it back in and the blue light sparked, but that was it. no fuses have gone. no capacitors or anything are blown. it appears my ez-b is dead.
United Kingdom
#8  
Not necessarily, it could be a servo. Your wiring could be OK as far as you can see but inside the servo a wire may have come loose or something.

Honestly it doesn't sound like an issue with the EZ-B since it shouldn't be able to move anything unless told to do so.

If you think it is the EZ-B check the voltage of the signal pins (if you don't have a multimeter you can connect a flylead from digital signal to ADC signal and read the ADC value to get the voltage. The signal pins should have 0 volts on when not being used, if you have anything different then it's probably an EZ-B issue but if that was the case you would always be having "crazy servos". At least from what I understand of how the EZ-B works that would be the case.

Edit: This was in reply to the post before the one above it.
#9  
and if the +5 is reading 0 volts its either a battery or ez-b issue.
United Kingdom
#10  
VCC should always read 5v when the board is powered up, even if not connected to a PC.

Go through the diagnostics tutorial and check the board out properly before assuming it dead. It's probably best to do that when relaxed and with a clear head.
#12  
It appears that the ez-b is not dead. After unplugging everything it powered on fine. I will see if just running it is causing the failure.(not likely) then I will see if one of the servos is causing the glitch. Unfortunaty my other computer is too slow for Bluetooth. We will see if the problem involves just the ez-b tomorrow.