Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Netherlands
Asked — Edited

Ez-B Does Not Power Up.

if i connect power to the ez-b the leds don't light up. yesterday i had the same issue, and fiddled around a bit thinking there might be a loose connection. Randomly it did power up, but today i cant get it to work anymore. What could be the problem here, i cant see any obvious disconnections, how should i diagnose?

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
United Kingdom
#1  
Read through the diagnostics tutorial

A few things I would check first are;
1) Check the fuse on the EZB (between the regulators)
2) Check the power supply, or use a different supply - make sure the power supply is actually giving a voltage of between 5v and 17v dc.
Netherlands
#2  
1) the fuse is fine
2) i have tried all batteries i have, all are giving a voltage of 7-9 volts.

I have followed the diagnostics tutorial you linked.
The bluetooth part is in order.
On the next part tho, i measure only 1.3 Volts.

Again: as soon as i connect batteries, the leds do not light up.
Canada
#3  
Give the barrel jack a good wiggle and double check your connections to the barrel jack.
Netherlands
#4  
the problem is not the barrel jack. I can measure the battery voltage on the back of the board where the barrel jack is connected.
Also there is 5 volts between Gnd and 5V for all the ports D0 - D19 etc.

Also measured on the pins where it sais MCLR:
The Vin is correctly giving battery voltage.
The 5V is giving 5V (or 4.9)
The 3.3 is giving less then 0.6V tho...

And now i have popped the fuse by accidentally connecting pins that i should not have with the volt-meter...
PRO
Synthiam
#5  
Watch this video at the 2:00 mark and forward: http://www.ez-robot.com/Tutorials/Diagnostics.aspx

*Do not perform the tests prior to 2:00 because they do not pertain to your issue.

Do you have power on the pins that the video recommands you test?

Also, you may wish to provide a clean bright lit photo of the EZ-B bottom. Perhaps there is a rare solder short.
Netherlands
#6  
I have just replaced the fuse.
I had already done the diagnostics when RichMR2 suggested it.

As i have stated before: i am getting 1.3 Volts on the suggested pins after 2:00 in the video: Not 5 or 4.9 like shown in the video.

This is with a 7.2V Ni-Cd battery - actually giving 8 Volts to the barrel jack.
Like i said before: many or all pins that should have 5 Volts do have 5V. Maybe one of the voltage regulators is broken? The one furthest from the barrel jack, VR2, seems a bit loose.

I cannot make a photo of the board at the moment, but as it has worked before, i do not believe its a solder short.
#7  
You might consider applying some solder flux paste to the connections of the loose voltage regulator and reflow some solder to them.
#8  
Yea a cold solder on a power or ground will cause lower voltage output due to the additional resistance.
Netherlands
#9  
I do not want to start soldering on the ez-b if im not entirely sure this is going to fix the problem.

restating the problem and test-results:

If i connect power to the ez-b, nothing happens: the leds do not light up, and i cannot connect to it from ARC.
The fuse is fine and there seem to be no loose connections/soldering errors.
(the loose regulator i spoke of is actually connected properly, its just the heat sink thats not entirely stuck in place. Still it might be that the regulator got damaged?)
The part from the diagnostics video where you measure 5V is only giving 1.3 or so volts.
But the servo ports all have 5V on them.

So: after 2:20 in the diagnostic video, my lights do not turn on.
At 2:45 in the diagnostic video, you measure 4.96 Volts, but i only get 1.3.

Could it be that the firmware got corrupted? Apparently it gets power, but just wont start up...
Thank you for all the replies at least, but i still haven't found the problem.
#10  
Have you tried wiggling the loose part while power is applied to the EZ-B ?
Netherlands
#11  
Yes i have.
#12  
Without re-soldering loose joints further troubleshooting is futile.
Netherlands
#13  
@ Robot-Doc,
I am convinced there is nothing wrong with the soldering.
One of the heat sinks is a tiny bit loose on its metal pin, but that pin is perfectly well connected to the board. This makes me able to bend the three connections of the regulator a little bit, but this is as well connected perfectly to the board.
Forget i even said there was something loose.


Any thoughts on the 1.3V instead of 5V in diagnostics: what does that mean? what can be the cause of that?
Can it be firmware related that the board refuses to start up or something?
#14  
Thanks for the further explanation of the term "loose". At this point you should contact support and share your voltage measurements with them.

I had a similar issue with the center pin on one of my EZ boards but it was a poor solder joint. Also it never had a power issue just a loose heat sink mounting.
#15  
If you are getting .6 volts on the regulator, here is what i do first ,remove the chip from the board and dont bent the pins and check if you get 3.3 volts

If you dont the regulator is bad,or not grounded or bad filter cap

same with 1.3 volts try it too,1.3 volts is the reference volt of the regulator it meens may be gound is off

I design circuits like that.
#16  
Also, when i got my stuff in, my green power connector was flaky. I had to replace it. It was making and breaking. BrandNew , but defective. I am sure that D.J. will make this unit good if defective.
#17  
I removing my jack,one reason it sticks out,second can came out easy
so best it use pcb mounted screw terminals
Netherlands
#18  
Problem solved, @Robot-Doc was right all along, but i was being stubborn.:D

It turned out that the pin from the heatsink was not well attached after all. Although i could not see this because it had come loose 'underneath' the droplet of solder on the back of the board.

I re-soldered just this pin from the heat sink, and all is working fine now.
The part from the diagnostics video where i measured 1.3 instead of 5 Volt, is now properly at 4.98V.

Thank you!
#19  
yes that what i tought a gound was missing ,thats why you only read 1.3 volts its the reference voltage of the regulator .
glad to see you got it fixed
mostly grouds are are to find ,but easy to fix,loose ground or causes resets and more
AT work when i design circuits i use whats called SPG single point ground
same idea for robots also