Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Cutting And Pasting Into Ez Scripts - Why Does It Not Work?

I am trying to do a simple cut and paste of code from the community forum into a an ez script. However, even though I try cut and paste with various methods (control C, Control V, edit cut, edit paste, etc) it does not work. What is going on? Without the simple ability to cut and paste code, its very hard to build on what others are doing ---- I don't want to retype everything.

Any help would be appreciated.

AI Support Bot
Related Content
Synthiam
#1  
You posted with this same problem a couple weeks ago. Are you still having this problem?

This is a Windows function and it does work in all the versions of ARC. I can only assume it's your operating system or a problem with your computer. Maybe you have a bad key on your Keyboard?
PRO
Synthiam
#2  
1) Highlight the selected text that you wish to copy or cut

2) Press CTRL X for cut, CTRL C for copy

3) Press CTRL V for paste

You will find the User Tutorials (ie LEARN section) verify useful. The EZ-Script lesson will explain the built-in Microsoft Windows shortcut keys: http://www.ez-robot.com/Tutorials/Lesson/23
#3  
LOL... @Dave and his memory.... This guy Problem with cut,copy,paste seems to be having the same problem
:P

@mstephens_42 I do it all the time (copying code here and pasting it into my projects)... No problems so far....
#4  
Guys I know my way around a computer very well. I understand cut and paste. 26 years of electrical engineering under my belt. It does sound like some kind of issue with settings, etc on he computer. However, I can cut and paste just fine to and from any other app (I.e. Web page to note pad, etc).
#5  
Hmmm, not sure what to tell you... I just tried it 30 seconds ago... Found some code on here... highlighted it all, pressed control+C to copy.... I then opened ARC, loaded a basic script and pasted the code into the script (Ctrl V) ... no issues... It does however, take a few seconds to appear sometimes... Maybe your computer isn't that speedy? Maybe you need to wait a second or two longer to see if it appears?

Have you tried copying the code from here then open a window's notepad file and seeing if you can paste into that?
#6  
Copy paste does work in the app from sources outside of ARC and even from one script to another inside of ARC. It isn't ARC that has the issue, but you do have to use the keyboard shortcuts to copy, cut and paste as mentioned in this thread. Right mouse click paste isn't an option.
#7  
All, problem solved. I uninstalled ARC, restarted, and re-installed latest version. Something must have either been hosed in the computer or solved with the re-install.

Thanks!
#8  
Ah ha! Sweet. Well done.

Believe it or not your solution was going to be my next suggestion. *cool*
United Kingdom
#9  
The solution was the third post of your previous topic...;)
PRO
Synthiam
#10  
Ah, well we all have our gremlins - and Microsoft has the most! Not surprising considering the amount of code for the Windows Operating System. Usually a reinstall of the ARC, or reinstall of .Net solves all issues.

You will be surprised what a simple reboot will accomplish ):