Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Coverting Project From V3 To V4

Hi,

I am converting a project from V3 to V4.

Few Issues

1. Servos not positioning in same position. If servo centered before it in certain position it is way off now.

2. Servos not releasing. Same script in V3 no issues.

3. Servos jumpy. Not as smooth as V3

Wireless router right next to project.

No change in script just moving jumper to jumper same pin configuration.

Any ideas.

BTW - similar problems with other small project with similar problems.
Try different V4 modules same results.

Any ideas?

Thanks.

#1  
V3, servos had 100 positions. V4 they have 180. This will effect the center position, max position, and how far incremental steps in scripts and autopositions move.
#2  
Hi,

Ok so then I have rewrite all scripts then?

How about the releasing?

V3 was pretty smooth. These seem to hang.

Using auto release on all servos set one 1 second.

Thanks.
#3  
I don't know. Release works fine for me and everything runs as smooth as my V3 did. I am using all EZ-Robot heavy duty servos except for one pair of rotation servos on my boxbot. Not sure if that makes any difference.

Alan
PRO
Synthiam
#4  
Post your project and we can take a look to help. Also, it's a good idea to review the tutorials on the learn section, which were created for educational purposes - such as this.

If you are experiencing network issues, consult your PC manufacturer, check for bandwidth limiting software, and ensure that you have learned the product with tutorials from the learn section.

Included in your purchase, and upgrades to the software direct you to the learn section. Start there to learn the product and understand the differences between the v3 and v4 controllers, as they are different products reflected by their names.

Feel free to post your project if you would like it reviewed for programming errors. It's always good to get a second set of eyes:)
#5  
Hi DJ,

Done the above. Tried 3 differ different wireless same result. I will probably revert back to V3 and use 4 V4 I have on different project I guess.

I will upload program I have soon.. Still in progress.

Thanks.
#6  
I have no issues whatsoever using the EZB4 to control the two inMoovs or any other project I have built for that matter... So there is something going on with your wifi, network and or code to be causing your problems.... If you post your code we can at the very least eliminate that as the source of your issues....
#7  
@jackphillips1953 I downloaded your project and had a quick look.... One thing I noticed right off the bat is that you are not using the autopositioner? The autopositioner was virtually made for an inMoov type project (a project with many servos)... You could get rid of all those scripts if you use the autopositioner instead? Is there any reason why you chose not to use it?
#8  
Hi Rich,

Never used that control. I will try and I am working on today. Left this project for about 6 months dealing with health issues. Going to work hard on in next couple of weeks.

Also found issues with EZ- Face and Speech recognition. I moved this project to another computer and upgraded to Win 10 and it is less powerful so dealing with a lot of issues, but this project seems to still run better using V3 for now.

Thanks.
#9  
ARC now has built in face recognition, so you don't need EZ-Face anymore. Justin has stopped updating it (it was just the kicker DJ needed to add the feature).

Alan