Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Continuous Rotation Servo

I installed a CR servo that came with my Dev kit. It works as it should in the ezb builder. I bought and upgraded HiTec Robot servo model HSR-2645CR and when I try it it starts moving in one direction but then I cant control it. It wont stop or switch directions. I am using port D0 and have tried others and get the same problem. I have not tried an ADC port.

#1  
Do not plug into the adc ports. It could be possible that your servo is broken.

Your ez-b could also be browning out. What else is connected to the ez-b? Try running it as the only thing connected to the ez-b.
#2  
I thought about that. Its the only thing plugged into the ezb. Its as wide input servo. 4.8-7.4v. Its a brand new servo and I'm not sure how to test it if it is bad.
#3  
You only bought one? What were you going to make with it?
PRO
Synthiam
#4  
1) there's a tutorial on the ports for the dev kit which explains the difference between digital and adc ports. I recommend reviewing the tutorial as a side note - to ensure you do not connect things to the wrong port and damage the ezb :). That wouldn't be good! The tutorial is step by step with great information and isn't very long. Each step should only take a few minutes of your time to read. Always smart to learn from facts rather than mistakes:)

2) if you connected the hitech servo correct with the ground and signal pin in the right orientation, used a brand new add control of a modified servo control, and it doesn't work as expected, I would assume the servo is damaged. Contact the supplier of where you got it from.
PRO
Synthiam
#5  
I should also add that there is a small chance the servo is not following standards. Well, there's an enormous chance that it isn't following standard - because not many servos do. Also, the servo May by a Chinese knock off of the Chinese hitech brand. It's real hard to tell the difference, sometimes impossible.

So if that's the case, you can try tweaking the values for the two directions. When you tweak the values in a modified servo movement panel, there's a test button. Try adjusting the values closer to each other and hitting test to see if you get expected behavior.
#6  
I only bought one of these types of servos because its for a BB-8 robot project. I have plenty of 180 servos. I wanted a high torque CR.
I have it plugged in correctly so its either something I'm not doing correctly in the builder or the servo is bad.
PRO
Synthiam
#7  
Try my second post - incase u missed it, about the values. See if tweaking helps.
#8  
What is odd is that if I set the servo up as a Horizontal servo and adjust the values to min 1 and max 180. It works as it should changing direction and continuous.
To stop it I have to bring it back to 108.
PRO
Synthiam
#9  
Please perform the steps that I had explained and referenced in my previous post. It's not weird because that's exactly what I asked you to do but in the correct place. I explained it already so please reference the above post.

For information on why that works, look at the servo tutorial on how a servo works in the developer tutorial.

Your servo is a Chinese knock off and that's why it's requiring tweaking. All servos are pretty much Chinese, but vary in quality. If you get it working by tweaking the values as I've previously mentioned, you're golden!
#10  
I tried the steps you posted. I have a fwd value 180 and reverse value 1. I do not see a Test button you referenced.

If this is a knock off shouldn't I return it. I shouldn't be paying $35 for a knock off servo.
#11  
I believe the control DJ wants you to use is the continuous servo control. When you hit the settings button(gear) you should find that there are areas with values for forward, backward, and at what speeds.
#12  
I did add the continous servo. The values that can be adjusted in the "gear icon" settings menu are just fwd and reverse. There is no test button. Ive tried to mess with the values and the the servo reacts the same each time once saved. Once I hit a button to move the servo its goes in one direction at same speed and nothing stops it unless I unplug it.
PRO
Synthiam
#13  
As i had mentioned and @mazehorizontech has repeated, use either the continuous rotation servo Movement Panel for the test button.

-or-

continue using the continuous rotation servo control which, as you have noticed, does not have a test button. Instead with this control, you change the value and press save, and use the direction buttons to test.

Which ever you use, find the values that work with that particular servo. These instructions have been provided numerous times in this thread for reference. Unfortunately, there is no additional assistance that can be provided on this topic than what has been specified in this thread. Try changing the values to find the values that work for that servo. Once you get it working, it will be clear:)

There is a very detailed tutorial on how a servo works which is part of the learning process. Here is the direct link: http://www.ez-robot.com/Tutorials/Lesson/48?courseId=6

Once you understand how a servo works, it will be clear of why the values are relevant. Specifically for after market servos.

The servo which you are using merely does not seem to behave with the standard pulse width range. So, changing the values will find a pulse width that works with that servo.