Welcome to Synthiam!

The easiest way to program the most powerful robots. Use technologies by leading industry experts. ARC is a free-to-use robot programming software that makes servo automation, computer vision, autonomous navigation, and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by DJ Sures!

Com Ports In Connection Control

This is a two part. One part may be best answered by EZ Robot but hoping someone may have insight. The second is probably Synthiam's. 

I'm trying to connect several EZB's through their camera ports via USB-to-TTL Serial Cable directly to a laptop USB ports. 

First,
When I was ready to connect the first EZB to ARC, Com 3 showed up in ARC's connection control and after picking it the connection worked.  Yah!

However a couple days later I restarted the robot and the laptop and now it won't connect to ARC through Com 3. After resetting the EZB back into AP mode I was able to connect through ARC over WIFI. Then I tried Client Mode WIFI through my home network and was also able to connected to ARC. Then after another EZB reset and I again set the unit up like last week to connect over USB. Com 3 was there in the connection control but ARC couldn't connect through it. No go. Nada. Nothing. 

Second,
When I connect tried to add a second EZB to my laptop using the USB-to-TTL Serial Cable a second Com port does not show up in ARC's connection control. This may sound like a dumb question but shouldn't a second com port show up and be used for a second EZB attached to the laptop through USB?

When I first plugged in each of the USB-to-TTL Serial Cables into the laptops USB ports, Win 10 told me they saw them and set each up and was ready to use. 

Any ideas would be welcome.


Related Hardware EZ-B v4
Related Control EZ-B v4 Info

ARC Pro

Upgrade to ARC Pro

Become a Synthiam ARC Pro subscriber to unleash the power of easy and powerful robot programming

AI Support Bot
Related Content
Synthiam
PRO
Synthiam
#1   — Edited
It worked and now it doesn’t:) . Check your settings - baud rate, port, wiring, common gnd, etc

You can connect as many ezb’s as you want. Up to 255 I think is the max for ARC.

oh, and if you connect the usb after ARC has loaded, you’ll need to press the refresh button next to the port selection on the connection control. That refreshes the list of com ports.
#2  
Thanks DJ. So each new ezb connected by USB to the computer will connect through a new and different com port?
PRO
Synthiam
#3  
That’s right. And windows will remember the com port for each adapter for next reboot. Just make sure you save the project so the ports and baud configuration are all saved.

what baud rate are you using? 25600 or 230400 is fine. Anything higher might produce errors
PRO
Canada
#4  
Did you install tho FTDI VCP drivers in windows?
#5  
Hey thanks for the info!

@Nink, I wasn't aware I had to install drivers. I thought Win 10 did that in the background when the adaptor cable was first plugged into the laptop's USB port. I was first trying to connect over USB to my onboard Rock Pi X but got frustrated thinking it was the SBC. I switched over to my Win 10 laptop that has ARC set up on it and got the same results. I had set up the SBC according to all the advice Synthiam gives along with the driver pack offered here. I guess looking into missing drivers is a good place to start along with Dj's advice given.

@DJ, I had tried several baud rates (setting them both in the EZB firmware and in the ARC Connection Control. When it was first working I picked the highest rate (9xxxxxxxxxx or something like that). Then when I couldn't connect anymore I changed it down to 230400 with no results. Maybe I'll trim it down a little more. 

Thanks again for the tips.
#6  
Found the reason I connected ok one day between EZB and the laptop over USB and not the next. Broken wire between the USB of the laptop and the camera port on the EZB. Wonky pre crimped jumpers. Ugh. 

Next I'll get the other EZB's connected through USB to the laptop. 

BTW, I found the FTDI drivers, downloaded them and installed into the win 10 laptop. The Driver website said Win 10 would do this automatically when the cable is plugged into a USB port. I don't know if they were working or not so I reinstalled anyway. 

Thanks for the help.
PRO
Synthiam
#7  
Right click on the start menu and select device manager to view your list of devices. A yellow icon will be beside devices that are missing drivers. 

If the icon isn’t there, no need to install drivers for it because it’s working. Installing drivers might be incorrect or older or viruses / you never know:)
#9   — Edited
I've got two different USB-to-TTL Serial Cables. Thanks @DJ I was able to see in Device Manage which one had the drivers installed. One had the drivers installed by Windows automatically and the other I had to go to the vendors website to get and install myself. Both are working nicely now.

This first one I'm using is an Adafruit USB-to-TTL Serial Cables. According to how they describe it on their website It seem superior to the other one I'm using. I sounds like it supports faster transfer rates and more baud rates. I have a lot of respect for these guys and their products. However Windows did not automatically install the drivers. I had to go to their website to get them. Adafruit did make the effort painless and quick though:
ADAFRUIT Industries 954 USB-to-TTL Serial Cable
User-inserted image



This other one I'm using is the one that installed automatically:
DTECH FTDI USB to UART TTL Serial 5V Adapter Cable

[url=https://www.amazon.com/gp/product/B08SM622VX/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1]
User-inserted image


Thanks for all the help on this.