Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked

Com Error When Download Configuration For EZ-B V3

Trying to get up and running on my EZ-B v3. Couldn't get a servo to work so I took a step back and tried to make sure things were talking. Added Debug control. Looked good. Added EZ-B v3 Configuration control and tried to download configuration. Debug results:

Code:

2020/09/25 19:10:09 -04:00 - Attempting connection on COM4
2020/09/25 19:10:19 -04:00 - Connected to COM4 at 9600
2020/09/25 19:10:19 -04:00 - Reports EZB v3 OS
2020/09/25 19:10:19 -04:00 - Firmware 'EZ-B v3 Native Firmware' on 'EZ-Robot EZ-B v3' supports the following capabilities:
- ADC with 8 Bit resolution
- Read/Write Digital I/O Ports
- I2C Master
- PWM Duty on digital ports
- PWM servos on digital ports
- PWM servos on digital ports can release their position
- servo speed for PWM servos on digital ports
- Transmit Uart TX on all digital ports
- Ultrasonic Ping distance sensor support
- Native Bluetooth Connectivity from ARC

2020/09/25 19:10:19 -04:00 - Connected
2020/09/25 19:10:30 -04:00 - Comm Err: The operation has timed out.
2020/09/25 19:10:30 -04:00 - BbytesToExpect: 1
2020/09/25 19:10:30 -04:00 - Received:
2020/09/25 19:10:30 -04:00 - Disconnected
How do I get this thing ticking?


Related Hardware EZ-Robot EZ-B v3
AI Support Bot
Related Content
Synthiam
PRO
Synthiam
#1  
reviewing the logs from your installation of ARC, it appears you may not have enough power correctly provided to the ezb v3. I would consult the ezrobot manuals or datasheet for the product from their website. What power supply are you providing the ezb v3?
#2  
I am using the battery pack/holder that came with the kit.