Asked — Edited

Can'T Get Voice Recognition To Work.

Hi All.

I can't figure out why this is not working for me.

It recognizes the command to enable and disable speech ok, so I don't seem to have a microphone issue.

I got it to say a phrase, but only once. I don't think I changed anything to make it stop working.

I can move my servo manually in the vertical servo panel (no problems with the servo), but I can't get it to move by voice, even using the exact phrase in the example (i.e. Servo(D14, 25)), with the servo obviously plugged into D14.
I even tried unplugging and reconnecting the EZ-b.

Can someone help me figure out what's wrong? It'd be nice to be able to see if the EZ-b is recognizing the speech at all.

thanks in advance,


User-inserted image


Upgrade to ARC Pro

ARC Pro is more than a tool; it's a creative playground for robot enthusiasts, where you can turn your wildest ideas into reality.

United Kingdom

First make sure the Pause box isn't checked on the speech recognition control Make sure your mic is plugged in, switched on, set up and that you have carried out the training from Windows Speech Recognition. If all has been done, check the black box next to config when speaking, it should give a "squiggly line" when speaking. If it doesn't you need to go in to Windows settings and set up the mic again, recording volume etc.



I had not yet set speech recognition up in Windows-- that did the trick:).


United Kingdom

You're more than welcome.

You will want to run through the speech recognition training a few times to get Windows used to your voice so it works better with the VR control. It only take about 10 minutes each time, the more you do it the better it gets.

It also helps if you train yourself on how to speak to the computer/robot so it understands you better too. Playing with it all does wonders:)


Rich, thanks! PS, give him the speel about the ? button next to the X:)


Hi, I've done all of this and my speech recognition does not work to move my robot in any way. I am using an HBridge PWM Movement panel. Arrow key movement works fine. Wii controller movement works fine. Joystick Movement works fine. Touch Pad movement works fine. Speech recognition works on my Windows 7 Laptop perfectly and has for years to control my computer and do dictation.

The Speech Recognition in ARC can also recognize the command to enable and disable speech ok, just like ftlum's did. I have never been able to get speech recognition to work since I received my EZB V3 at the beginning of this year 2013. I have installed over 10 versions of ARC and it has not worked in any of them.

Again, Speech recognition has been enabled and works in Windows 7 Pro 64 bit perfectly. I have over 10 hours of speech recognition training in it also.

What could be the issue?

United Kingdom

Post your project, I'd guess it's something with the commands set up in the sr control if everything else works OK.

United Kingdom

Yep that's how...

I'll have a look when I get a second (I had a quick look and it all seems fine... but it was only a quick look and no test). About to get some sleep though so it'll be tomorrow - unless someone else has any ideas or checks it out.

One thing I can think of is the voice recognition country setting, it must be on USA, I had problems as mine was on UK. It may be worth checking that out in Windows control panel.


It is set on USA. Checked that before. Thanks Rich. Get some sleep.


OK, I had a look at your project and it looks like you need to write the proper syntax commands in the Speech Recognition panel. For your commands you just have:

left(255, 1000) for the phrase "Robot Turn Left"

In the command section to the right of the Phrase section you need to identify the proper ports to turn on and off along with anything else you want the EZB to do. Here's a proper syntax example of your Arm servo you have attached to the D1 port turning on and moving to a point:

Servo(D1, 25)

The above example will start up the Arm servo attached to the D1 port and move it to the point 25 position.

To edit these values click on the "gear" icon at the top of the SR control and you'll see the areas you need to edit. IN the left section you enter the phrase you want to say to get a response and just next to it you enter the proper syntax EZ Code functions. You can enter multiple commands by clicking on the pencil icon all the way to the right of the command box and type in as many commands in the proper syntax as you like. This way you can have your robot excite many different things at the same time.

There are many examples in the cloud of this. Open a few to get an idea how it should look.

Also to the extreme left you will see a help section where you can get script help. That section holds all the proper syntax codes you can use and an explanation of how to use them. Rich has a tutorial somewhere on coding. It's a must read for those if us just starting out with this strange and wonderful but easy language.

Good luck, Dave Schulpius

United Kingdom

@Dave Left(), Right(), Forward(), Reverse() and Stop() don't need ports defined as they use the movement control panel so whatever is set up in there (ports, scripts etc.) is used.

All of the voice commands in the project are OK and should work so these are not the issue. In fact, they look like they are the default commands that are pre-entered when you add a speech recognition control.

I can't see that anything is wrong with the project however I did just try my Jarvis project (which I know was working) and it doesn't want to pick up my voice either. Can someone else confirm that the latest version of ARC (2013.12.02.00) works with their speech recognition?


Sorry for the bad info. I didn't know that. Thanks for the lesson.

#13 you need the ez-bv4 controller first to use voice recog.?


@nomad18.08 wrote " you need the ez-b controller first to use voice recog.?"

You used to. I don't think you do anymore.



so i can use voice recog whithout having the ez-bv4

United Kingdom



i can see my mic working.i dont hear it .i think something missing here.

User-inserted image

United Kingdom

Every control has a ? next to the X in the top right hand corner. Clicking on it will take you to the help page for that control where everything is explained.

Where you have written "missing something here" is not voice recognition it is the V4 sound board which does require the V4 to work correctly.

Take the time to familiarise yourself with all controls and read their help pages.


i found the mic and speakers.but voice recognition is not availble for duts languages.what now ? tired


@nomad18.08 That sucks dude... How well do you speak English (or another language that Windows works with)?


only englich a few words.there is a download in englich but i cant get it says download from pc update. but its not chowing there.i need a bluetooth speaker too.i dont want too ware a headset all the time. maybe i can by it somewhere.speech rocog is availeble for win8 and vista. mad