Germany
Asked — Edited
Resolved Resolved by CochranRobotics!

Cannot Connect In Wifi Client Mode

After configuring my Roli to client mode, it says that it connected successfully to my WLAN. But the ARC scan cannot find it :-( It may be a policy (firewall?) problem, but I have not installed or activated any AV software. [Using Win8]


ARC Pro

Upgrade to ARC Pro

ARC Pro is your gateway to a community of like-minded robot enthusiasts and professionals, all united by a passion for advanced robot programming.

#2  

Do you have access to the router to see the DHCP leases that have been handed out? You should be able to find the IP address that was issued to your EZ-B V4 there.

#3  

Reboot your pc and your ezb (cycle the power) and try again....

Germany
#5  

I've rebooted everything, but nothing changed. I also cannot hear a ping response while scanning. My router shows 2 MAC and IP addresses, dunno how to interpret.

#6  

Also check the default IP address in ARC and make sure it matches your network. By default it shows 192.168.1.1 and it would search for devices in that subnet and if your router is not configured for that it will never find any devices. My router's default subnet is 192.168.0.1 so I had to change the IP address entry in ARC to reflect that.

Germany
#7  

How can I find out the right network IP address? Shown is 192.168.1.1:23 as the default. Okay, the address seems to be correct.

OT: how can I read your answers when they are available? Some alert option, or manual retry required?

#8  

go to a command prompt and type IPCONFIG and hit enter. See what your machines IP address is. Ods are that your EZ-B will be on this same range.

if your IP address is 10.10.10.100 your scan range in ARC should be 10.10.10.1 to 10.10.10.254.

Germany
#9  

WLAN shown as 192.168.1.8, default gateway 192.168.1.1

Outch, the scan range is 192.168.42.xxx! That's the address of a VMWare local network.

How do I change the address to scan?

#10  

Another way to find your ip address of your computer is to right click on your network connection(wifi or wired) in your system tray (bottom right corner of your desktop) and choose Open Network and Sharing Center.

From there click Local Area Connection (blue text) then click the details button. Your IP 4v Address is the line you are looking for.

#11  

What kind of laptop do you have? I guess I should ask what kind of computer do you have.

#12  

"Outch, the scan range is 192.168.42.xxx! How do I change that?"

restart ARC, or you could go to your DHCP leases page on your router and find the IP address for the V4 and plug that into the connection box.

If your router shows only 2 leases, one of them is probably your computer (192.168.1.8). The other should be the EZ-B.

#13  

If you are running this in a VM, you are definitely going to have to manually enter the IP address.

Germany
#14  

ARC does not run in a VM, but VMWare has installed a couple of local networks, and the Builder seems to scan such a network - even if the Connection shows the right network address :-(

Again: how do I instruct Builder to use the right network?

#15  

VMware is controlling what your computer displays as networks.

There is no way to change this value in ARC.

Again, find the IP address on the leases page of your router and plug it into the connection in ARC and you will be fine.

Germany
#16  

How should a change in the router affect which network is scanned by Builder?

If the network is not configurable in Builder, the software is unusable for me.

Or do you mean that I should run the Builder in a VM, and adjust the VMWare network address to what Builder expects?

#17  

I'm not saying to change the router.

VMware is causing your issue, not ARC. DJ could change the software to allow you to enter the third octet in the scan range but this would probably cause more issues than trying to just fix yours.

The router is handing out the ip address. It knows it and will display it to you if you look. If you are unable to do this, you could try to connect to 192.168.1.9 assuming your router assigned you the next address in the range.

You could run through vmware which could solve your problem. The issue is that VMware uses bridging and routing to pass traffic through its virtual network port to your machines physical network port. The bridging is probably messing up ARCs ability to find the correct subnet to use.

I seriously doubt that running through VMWare will solve this for you. It would probably show up as an even more incorrect IP address range.

#18  

My first suggestion to look for the issued IP address in the router was an hour and a half ago. It is still what you need to do to correct the issue with your configuration. I am stepping away from this conversation and allowing the EZ-Robot team to address this and help you.

Germany
#19  

Can anybody suggest another method to scan the available devices on my network? My router seems not to offer means to show the connected addresses :-(

#20  

What type of router do you have? I will google for the instruction manual and send you the pages that have the instructions that you will need to follow.

Germany
#21  

It says: "o2 Box 4421", firmware version 1.01.20w

#22  

do you have teamviewer installed? If so, I could connect to your machine and figure it out. There are not any instructions online that go into this for your router.

if the screens are in German, I dont know that I will be of much help deciphering the language, but I know what I am looking for and will know it when I see it. It will probably take some clicking and trial and error, but, once I see the table, I will be able to tell you what your IP for the EZ-B is.

Germany
#23  

I tried to install TeamViewer right now, but it says that my system doesn't meet the minimum requirements. Perhaps it doesn't support Win8/64 right now ;-)

#24  

That is the same os and version I have and it runs fine. Did you download the 32 bit or 64 bit version?

#25  

sorry, I have a work issue that crept up. let me handle this and I will get back to you.

Germany
#26  

I found another version, which installed.

#27  

cool, what is your id in teamviewer? I am going to be juggling a little bit with work but this shouldnt take long.

will need that and the password in teamviewer, then after I get connected, we will edit your post to remove them.

#28  

do you have skype? if so, what is your skype name or email. I will call and it will make this go faster.

Germany
#29  

Skype has stopped working months ago. We also can chat, I've xchat running in a Linux VM.

#30  

If you launch teamviewer, you will see a section that says Allow Remote Control. It will have your ID and your password. post those here and then we can remove it after I get connected.

#32  

we found the IP and she is on her way on the lesson to building Roli.

Have fun!

United Kingdom
#33  

Good job Dave. :D :D

PRO
Canada
#34  

Awesome work @d.cochran!

Germany
#35  

Thanks, David, for your kind assistance :-)

Roli is already moving and dancing, and the camera works. Now I can start digging into the details...

Remains one question: can I assign the robot a static IP address? It seems to change with every power on. But I fear that this had to be done in the router, and that looks impossible to me right now.

#36  

Assigning a static IP does need to be done in the router (really a reserved IP, not a static IP. Sometimes called Static DHCP).

Alan

#37  

you can set the dhcp for that mac address to always get the same IP. Because I dont read German, it would be hard for me to find the right place in your router to configure. You are looking for something under home net that says Static Leases. You will want to get the mac address from the lease page we were on earlier. You would then assign that mac address to a specific ip in your dhcp range(192.168.1.3 for example).

#38  

@d.cochran Nicely done! So glad you were able to help. :D

Germany
#39  

Finally I also could locate the DHCP settings page in the router, well hidden in the menu. Now my Roli also has an name, and a fixed IP address :-)

#40  

Grats Dodi, and you learned where that is for when you get hooked and start buying more EZ-B's.