Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
United Kingdom
Asked — Edited

Camera Snapshot On Mobile Interface

This is mainly aimed at DJ, unless anyone else can help.

So I put this up as a bug report but it maybe an iOS or Android restriction. Anyway, here goes.

On the mobile interface running on an iPhone 7 Plus (iOS 11.2.5) , I’ve added a button for camera snapshot. After I took the very first photo, my phone asks for permission to access my iOS photo app. Once expected, I noticed photos were not being saved on my camera roll. I closed the iPhones photo app, took another snapshot... and it saved it to the camera roll.

So in a nutshell, what I’ve noticed is that if the iPhones photo app is running in the background, the snapshot ControlCommand() will not save photos. Closing the iPhones photo app then taking a snapshot will then save that shot to the camera roll. I then have to close the photo app again to save other snapshots. Same thing happens on an iPad too.

So just wanted to ask, is this a possible ARC bug, or is it an iOS restriction (haven’t tried it on an Android device?

Thanks.

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
PRO
Belgium
#1  
just try it.and its like you say.dont save foto's on ipad.
i gess there is no folder from ez mobil on your ios
PRO
Belgium
#2  
i just tested with skype cause there is a folder from skype in your foto's
when taking a pic you can save ,and it shows in folder skype.
PRO
Synthiam
#3  
This is _NOT_ a bug. This is the way iOS and mobile operating systems work. There is no such thing as "running in the background". An app that "runs in the background" is actually a different app than the one you're referring to. ARC does not have a background app.
United Kingdom
#4  
Its not a BUG then... that’s cool . As long as I know. Like I said, I wasn’t sure if it was a bug or the phone’s operating system which I was clear about from the start but I thought it was best to ask Just in case.

Just to be clear, Ill try explaining again. I said running in background as that’s what a lot of people call it... a prime example of this can be found in this link which took less than 10 seconds to find...

https://www.cnet.com/news/apple-exec-closing-background-apps-on-your-iphone-wont-help-battery-life/

Although I know that’s not an accurate statement, recently used apps in the iPhone multitasker are apps that are in a suspended state, or a kind of standby mode which is what I meant. Also, I never said ARC had a background app and don’t know why that was even mentioned. So, it’s the iOS photo app I am talking about (circled below)...

User-inserted image


To take a photo from the ARC mobile interface, and for it to save to my iPhones camera roll, I have to force close the photo app from the iPhones multitasker (double tapping the home button, then swiping the photo app up to close it)...

User-inserted image


It’s only then I can use the mobile interface to take a snapshot and have it save to the iPhones camera roll. With the photo app in suspended in the iPhone’s multitasker, snapshots will WILL NOT SAVE. I hope that made things clearer.
PRO
Synthiam
#5  
There is only one way to save a photo into the album, and that's with Apple's operating system calls. If you experience an issue with the photo album, there's nothing ez-robot would be able to help you with. This would be an Apple support question - specifically since their operating system has been receiving significant scrutiny, as you're aware, in the media with bugs and problems. This may be one of them.

This is not a bug with ez-robot.

I also doubt that photos has a background app, as i don't see it in the list of Settings -> General -> Background App Refresh

Nor does ARC have a Background App Refresh app.
PRO
Belgium
#6  
apple only provides support for devices only,not for apps.
i gess the problem is you cant make a ( new folder ) like on pc.
PRO
Synthiam
#7  
Nomad, that is not a problem because it is not a feature provided by ARC mobile. ARC does not advertise a feature of storing images in custom photo albums. ARC stores images in the main photo album, such as the camera, facebook, etc..
PRO
Belgium
#8  
atleast steve can save it in the end.
United Kingdom
#9  
@DJ.

Many thanks for taking the time to respond and explaining. Good ol iOS strikes again *eyeroll*. At least I know now it’s not a bug and it’s an Apple issue. I’ll get in touch with them (but won’t hold my breath for a response from them anytime soon).

The only reason I thought it might be a bug is that, using a similar example, I have a drone with built in camera which connects directly to the iPhone’s WiFi. I can take multiple photos with the drone and they are saved to the camera roll, and even with the photo app resting in the multitasker, photos from the drone can still be saved and wondered why that the EZ-Camera wasn’t doing the same in the EZ-mobile app. I’ve tried two iPhones and an iPad with same results (guessing Android phones don’t have this problem). Anyway, good to know it’s not a bug with EZ-Robot.

Anyway, thanks again for responding.:)

@nomad.

The photo app is a native Apple app supplied with all Apple mobile devices/iOS versions so they should provide support for this issue. I’ll give it a try anyway.
PRO
Belgium
#10  
thanks for telling steve.