Asked — Edited

Camera Question Question

I've received my EZ Dev Kit. The camera doesn't seem to work and customer service asked me to post my problem here in case anybody is able to help me. The only configuration setting I see is the camera's IP, which I set to the same IP as the EZ controller. The camera led shines steady blue. But when I click Start there is no image and an error is shown in ARC: 9/27/2014 1:29 PM - error camera: System.ArgumentException: Parameter is not valid. at System.Drawing.Bitmap..ctor(Stream stream) at EZ_B.EZBv4Video. (Byte[] ) at EZ_B.EZBv4Video. () Please advise: is the camera faulty or am I doing something wrong?

Thank you for any suggestions!


Upgrade to ARC Pro

Stay at the forefront of robot programming innovation with ARC Pro, ensuring your robot is always equipped with the latest advancements.


How is your ezb connected to ARC AP or Client mode?... The steady blue light on the camera is a good thing... that means it is getting power....


What version of ARC are you using? the latest is 12.20.00?


when you add the video device ip it should look somthing like this..

EZB:// the .177 should be different for your network User-inserted image


More importantly, can you control everything else?

I would make sure your connected to your ez-b. Then see if wiggling the cable gets it to work(bad solder joint detection).

Then try refreshing the camera list.


Thank you for the suggestions. I've now updated my software to the latest version and reseated cables and connectors. The cable doesn't have twists in it. All other sensors and motors are working, but not the camera.

I connect directly to the EZB wireless network (I wish EZB would be able to connect to my wireless network, but that is not working well for me, when I follow the instructions to do that, sometimes it can't connect, at other times it connects but loses the connection later). Anyways, connecting directly to the EZB wireless network using the default setting (EZB::// seems to work reliably.

The camera sadly is still not working and the software is still showing the same exception. I don't think it's a software problem because ARC can show the stream from the built-in laptop camera just fine, so my guess is the camera may be faulty? Or could it be the controller?


One last step is to uninstall the EZB software then re-install it and then perform the camera test again.


@topoline Just to be clear, you are using the same IP address for your camera as you are for your ezb (EZB::// If not, make sure they are the same...


@topoline, Did you get this resolved? I've had the exact same issue. I've searched and searched and my project requires two seperate EZB's so I just ordered and got my second camera. I was hopeful it would at least be fixed with one, which should make my warranty claim easier. No such luck... Both fail with the exact same message you are seeing. It fails regardless of which of my laptops is running ARC and it fails regardless of if I am on my home network or work network.

Its been a bummer of a last few weeks. My base/platform issue has been diagnosed to the point of me needing to return the platform back to Yudjin Robotics for replacement, it seems as if I am being affected by the nasty Dynamixel issue, and as of today, I have two non-functional cameras:)

United Kingdom

@topolino and seanb.

Did you manage to get your cameras working? I had an issue with my camera recently and figured out what was causing it not to work, and got it streaming again. So, with a couple of additional tips, this will hopefully help you.

Disconnect then reseat the camera ribbon cable to the camera and EZ-B, insuring the cable is connected the correct way around.

Insure you have the latest version of the ARC software.

Make sure you have established a connection with your EZ-B and computer.

Once connected, make a note of the EZ-B's IP address from the "Connection" control. It will be something like this. EZB://

Open the camera control and click on the "Video Device" box and delete the IP address that is in the box. If it is a new project, the IP address will be the default EZB://

Enter the EZ-B's IP address in to the now empty box, but leave off the last two numbers so, (using my EZB:// example above), it now reads EZB://

Now press "Start" and hopefully you will now see a live streamed picture.

If you have already tried all these steps then I apologise, but if not then I hope this helps you get going. :)


@Steve... It's much easier than that.... the camera ip address will always be the same as your ezb4's ip address and should automatically be listed... You shouldn't have to fiddle with the numbers...

United Kingdom


I know what your saying. I never really had any problems with my camera, except when I was playing with some settings on a new project to add a webcam recently, then couldn't re-establish my EZ-B's camera connection for a bit. I thought breaking it down for the poster might help with troubleshooting. :)


Ahh, ok I see what you were doing now...

Cheers Richard


Not to hijack but I've always wondered why the camera needs an IP address? It is connected to the controller hard wired which has an address already. Thanks! Chris


topolino, This is what I did when camera did not show live on my EZRobot Observation car project. Delete camera from ARC project. On ARC go to project, add, camera device, which automatically assigns correct address and it works. Steve S


@kamaroman68 the camera has an IP address because it is a separate connection - this is because you can connect many cameras to a project.


Thank You for sharing that D.J. Having multiple cams might be a cool option to a single project. Thank You, Steve S


Hi, sorry to jump in on this I've had my EZ-B for about a month know and have been doing the lessons when time permitted. Everything runs well enjoying the simplicity and applaud DJ and the team for the ease and simplicity that make this a solution that NOOBS like me can jump in and take control of ideas without much understanding of code, thank you. I have finally got to the stage were I wanted to use the camera. There is a problem with me trying to connect the "Humanoid Head with Camera & RGB Eyes". As soon as I press the "camera device" button from "add control", i get a popup "error at loading of ippSP library"-"no DLLs found in the Waterfall procedure". I think this is a driver issue.

User-inserted image

The software informs me the software is up to date, so are the drivers somewhere else? My OS is Win8.1 Pro 64bit, i5 with 8gig ram.

I've also gone and checked continuity to the cable from the camera=ok and reseated camera pcb's and cable connections. The blue LED on camera PCB flashes a few times and stays on when EZ-B is turned on. Any help would be appreciated. Thanks confused


@ALT3R3D Do you have Go Pro camera software installed...? I think (if memory serves me) that this is causing the problem...


Here's the search result for that issue with GoPro cameras - it's a known issue with their software and they have yet to fix it... Sadly, there is nothing we can do on our end:


Thanks Richard and DJ for the quick respond. I am trying the guide now.


Excellent, thanks again. If everything was that easy! Know to take over the world..... :D


Thank you for the wealth of suggestions! I've tried them all, and everything seems configured correctly and I have no problems communicating with the other sensors and motors, but still no luck with the camera, it refuses to work and continues to give the same error. confused Is anybody able to use the camera while connected to the EZB's wireless network? (i.e. with the EZB in AP mode rather than having the EZB connecting in client mode to the home wireless).


Topolino, after the driver issue I had that conflicted with my go pro camera, I get no problems receiving the telemetry over wi-fi. I hope you get yours going soon.


I've waited a bit as I knew I would get a new laptop of a different brand at work. I've now tried using the camera again with the new laptop and the latest version of ARC, but again, all sensors are working except for the camera. At this point it looks like something in the hardware (camera, cable or controller board) I received must be defective.


Hey @topolino,

I'm in s similar situation... I even purchased an additional camera but got the same result, same error. Everything else is working as it should. The only thing I haven't replaced during the diagnosis is the ezb4 itself.