Asked — Edited

Brookstone Rover Camera Not Seen In ARC

I was configuring a project last night and at one point the camera in the brookstone rover quit being read in the ARC panel. Previously I had it chasing a ball,etc and it worked fine. I double checked the camera with the IPAD and it works fine. I have changed batteries in the rover and rebooted my PC, etc. The ARC panel is setup for brookstone rover, but all I get is a black screen.

I boot the s/w in this order...

  1. make sure I am connected via bluetooth to the ez B
  2. connect wireless to the brookstone rover
  3. boot the ez B software
  4. connect to the ez B
  5. open the brookstone rover Movement Panel and connect
  6. open the camera panel and change to brookstone rover

At this point, the camera feedback stays black.

I am at a loss as to why its not connecting. Help!

Skip to comments


Upgrade to ARC Pro

Unleash your robot's full potential with the cutting-edge features and intuitive programming offered by Synthiam ARC Pro.


Sounds like you did everything right. I used the rover just the other day out in my front yard. I drove it around using the 3d augmented reality glasses:) its fun!

But I don't know what the problem you are experiencing is.


Dj, I am honored to speak directly with you. I learned to disconnect and reconnect the Movement Panel connection. It seemed to grab the video for the camera then and work.

I am having voice control issues as well. It does not seem to hear me. Checked w7 controls as you show in video. Can speak and see bars go up and down. However, can't get robot to respond to voice commands. Do I have to trane to my voice in w7? Are you using an external mic? I notice my version of easy builder has an enable and disable command with no reference scripts. Your video on line does not have these. Am I missing doing something?


I'm having the same problem but connecting/disconnecting did not help. It has never worked on my Rover. Any ideas would be greatly appreciated. Thanks, Nelson



@mstephens_42 thank you:) i try to help on the forum as much as i can. Sometimes you may need to train the speech recognition. I haven't ever needed to, but there is a video floating around of a child using it and she had to train it. Follow the Tutorial section for speech recognition and i talk a little about configuring the mic volume.

@nyaple We tested the brookstone rover just now and it works great. I'm unsure what could be different within your configuration or wifi connection.


I'll try another computer and WiFi setup. The movement works fine, just no video. Very strange. I'll let you know what I find. Thanks.


Hmmmm... That is strange. I am actually sitting outside right now driving the brookstone rover around with my Augmented Reality glasses on! It's totally a new experience controlling it this way. I drove it down the street into someone's back yard - when they aren't home. It's like being on another planet. So surreal


I have the same problem with the camera. I can control the robot using the Movement Panel but no video has ever been seen.

Can someone suggest something to try?


Looks like it might be related to it running on a 64 bit system? anyone else have this running on a 64 bit system?


I develop the software on 64 bit windows. I'm using the rover again yesterday with no trouble. Perhaps there is wifi inference or a third party application affecting it. Also ensure you have the latest ARC:)


I so I installed ARC again in a virtual machine and it works Windows 7 so I guess I will just use it there for now. Not sure why it would not show the video in the regular OS since it works with webcams etc.. just not with the rover


i have my working perfect in windows xp pro,i see there are some problems others are having with WINDOWS 7 i started a project called MY ROVER project,stopped awhile on it.for parts but also want badle to get my omnibot project made


glad to hear you solved the problem!:)

There are no known issues with Windows 7, as it is the recommended OS to be supported. @RobotMaker is providing inaccurate information, please dismiss his response. The only platform dependent feature within the ARC application is the Speech Recognition.


DJ i dont thats very fair,i didnt say windows 7 has problems with EZB ,i only said that others are having problems with windows 7 ,doesnt meen its on this forum


Okay good to know. I read your response in regards to ARC having issues with windows 7. Thanks for the clarification.:)


most of problem people have in windows 7,and not talking about people in EZ FORUM ,is where to place the files,there is 32 bit windows 7 and 64 bit windows 7 and have different folders is use then windows xp pro only one folder ,like one main folder is called the WOW folder and another folder is called something else I NEVER use windows 7 with EZB so dont know if any problems if any there is

i like mostly WINDOWS XP PRO for a lot of reasons ,mostly found out it faster,but to compare it to WINDOWS 7 you need the same cpu ,same memory ,same 32 bit software now on windows 64 bits it a lot faster there are tweaks you can do to windows 7 or xp pro to make it faster,mostly setting resources i have windows 7 used at home for programming ,and another one for video