Asked — Edited

Brand New Six Hexapod Stops Working


I just got a Six Hexapod a couple of days ago. Everything worked fine for the first 2-3 days, recharged the robot when i heard the battery reminder (after waiting a while for the battery), etc. wifi, remote control, etc. was all working nice and everything.

The other day is was shooting a video and the robot's moves were jerky. The motors would start a movement, then stop for a couple 100s of second, then start again very fast (as if trying to complete the movement as fast as possible). Surprisingly it was more noticeable when moving slowly than when moving fast (keyboard control from ARC). I suspected wifi latence (even before i read, did a bit of netsurveyor wifi diagnostics and changed channel (but still same problem and i have a very good signal).

Then at some point, the robot stopped mid-move and seems entirely unresponsive. I tried the following:

  • turning it off and on back again
  • waiting for a while, recharging the battery and trying again
  • removing all cables, leaving just the board on the body and trying again

It doesn't light up, make any sound, move or anything else.

Battery seems ok (i have the blue charger, red led when connected to power outlet, green led when connected to battery, green goes off after a while when charged, etc.) but the board seems dead.

Any ideas of what is going on and what i could do to test different scenarios ?



Upgrade to ARC Pro

Harnessing the power of ARC Pro, your robot can be more than just a simple automated machine.


Not sure about the jerky movements, but since you say the board is now dead.... have you checked the main 20amp fuse to see if it is blown and/or if the ezb4 is making good contact with Six's base?


I did check the contact with the board, everything seems normal between body and board.

No, I didn't check the fuse before - i'm more of a software person :-). I opened the body and took out the fuse. Looks normal (not burnt, no black marks) but maybe the small wire inside isn't connected ciompletely (hard to see through the yellow plastic actually). Maybe also a light ozone smell (but hard to tell apart from the brand new smell).

I'll try to find a new one tomorrow and test it out. Should I buy like a whole box or is it a rare incident ? Also, does it mean that the evil battery is outputting to much power ?

Coule the jerky movements before be linked to the fuse dying out ? But wouldn't the small power drops make the board reboot ?


Power drops do make the robot reboot if too many amps are drawn at one time. There are quite a few servos on this robot and all of the servos moving at the same time could draw too many amps and cause a brown out.

Were you using example ARC project when this happened or are you using one that you have created or modified?


There was a recent thread where someone's SIX was having jerky movement and servos stopped working. He had run the servo wires through the rectangular hole in the lever servo mount, and it was restricting the movement (and possibly causing the wires to pull out of the servo). Make sure your Servos have full freedom of movement. If they were binding it would cause the symptom you were seeing and possibly cause the fuse to blow.

At least in the US, most car parts stores carry these fuses in boxes of 5 or 10 for just a few dollars, so not a bad idea to have a few on hand even if you never need them.

If you don't have a multi-meter to test if the fuse is good, take the one from six with you to the car parts store and they can probably test it (although, if you are going to be doing any robot building beyond using your SIX I would highly recommend buying a multi-meter and a book on basic electronics).



I was using the Six Example Project (walk forward or fast walk forward i don't remember exactly whih one).

How many servos is too many on this board ? If i add claws for example on my Six, does it mean i just have to watch that all servos are not running at the same time ?


It's not the board but the ability of the battery to deliver enough amps to the board. With the lipo that is in the robot, you are fine with moving all of them in quick bursts like the stand up reutine. Constantly moving all 12 at the American time could cause an issue. The walking uses 6 at a time I think.

I would check binding cables to the servos as Alan suggests.


After hunting for the right fuse (one shop only had 15A, the other only 25A), i finally got a couple of 20A fuses. Put them in and it boots up again (cool).

But... i still have the jerky motion (which i am sure i didn't have the first few days). I tested with both AP Wifi and Client Wifi. Good wifi conditions in both cases, same room, laptop less than 2 meters away, wireless router less than 3 meters away, etc. In that room, with my smartphone on wifi, i get a stable 150mbps download and 110 upload speed.

I made a simple test routine, one servo, 2 frames between 10 and 170 degrees and it stops and starts again very often. See videos below:

Fast movement 0.01, stalls when going up 0.11, stalls again when going up (longer) 0.16, takes longer than usual to reverse 0.20, stalls twice when going down 0.26 longer stall when going down 0.31 stalls going down 0.41 stalls going up 0.46 stalls going up 0.51 stalls going up 0.56 stalls longer going up 1.01 stalls before reversing 1.06 stalls when going down

Slow movement 0.56, mega stall

  • lots of smaller ones

Any idea what could be causing these stalls ?


@d.cochran @thetechguru Regarding freedom of movement for the servos and wires, as you can see in the videos, it doesn't seem to be the problem, although i must admit it hurts my eyes a little bit to see the wires sticking out of the back of the servo and touching the back of the holding plastic thingy. If it bothers me too much, i will someday have someone print me parts with a larger comfort zone behind the servos so as not to feel pity for the poor cable at every movement :-)


Note: if i should open a new discussion since i can't change the title, please tell me.