Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
USA
Asked — Edited

Bad Servos

The Revolution Six robot I purchased has loss six servos and can no longer move with assistance and makes a lot of gear grinding noise. I ask about it the past but never heard back on it. So I am asking again where and how to I replace the defective servos on the robot? For the amount paid for the robot it is a sad fact for it just to sit and the shelf collecting dust.

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
PRO
Belgium
#1  
jfew

use the Contact Us form.copie this topic and ez wil contact you.
any chance for a video from what is happening?
#2  
I have used the Contact Us form when I posted this. I will recharge the robot's battery and create a video of it attempting to move. I use one of DJ's example programs as it gives a great deal of movement. *confused*
United Kingdom
#3  
When you used the "Contact Us" form, did it pass you back to here to the forum, or did you manage to write a "Product Warrenty" claim and send it to customer service? I only ask as some people who use the Contact Us link sometimes forget to check the little box saying "I confirm that this message is not asking for technical assistance" which will bring them back to the forum.
#4  
@jfew
Losing 6 servos is, indeed, troubling. If I may, I like to ask a question or two. Did the loss occur all at once or over a period of time and usage with the servos going one by one? Or was this something that never worked because of the six servos being bad out of the box? Thanks.
#5  
the Contact Us took back to the forum. I did submit a claim and never heard back. The five servos worked fine for a while, had one from the box bad (would operate once in a while, other times just make noise. The robot has never worked correctly out of the box and was used only for demos at AITP student chapter meetings (once a month or two).
#6  
If you were redirected here automatically, and you didn't get a response, then they didn't get your request. Be sure to check the "I am not asking for technical support" checkbox and cut and paste the url of this thread into your warranty request. You will get an automated response within a few hours (probably within a few minutes). If you don't see the automatic response check your spam/junk folder. EZ-Robot always responds to warranty requests, even if it is to reject them. They won't leave you hanging without an answer.

Alan
#8  
From your video (really dark so it's difficult to tell) it looks to me that 1 maybe 2 servos are giving you issues.... Just curious where do you get 6 from? Servos can strip if the they bind on anything ... meaning if they held or prevented in some way from moving....

Looks like your Six is more than 8 months old so not sure what can be done... However, either way you should take the advice above and send EZ Robot an email about this...

***EDIT*** As jeremie mentioned metal gear servos probably won't strip due to having metal gears. What is more likely to happen is they will strip the plastic splines in their brackets or burn out....
PRO
Canada
#9  
The ezrobot HD servos aren't very likely to strip due to being all metal gears. The issue from the video seems to be intermittent contact. It could be as simple as the servo is not plugged into the ez-b far enough or it could be that the connection where the wire enters the servo is frayed.

@jfew Thanks for the video, another test you could try is touching the problem servo to see how hot it is compared to the other servos.

On an unrelated note, @Richard R not seeing your Fry avatar threw me off, lol.
#10  
@Jeremie Well, I thought I would show my artistic ability and use a picture of an inMoov I drew when I was building Andrew... You know, as a build aid of sorts....:P
PRO
Belgium
#11  
i think putting the wires thru the holes of the brackets is not so good idea.
PRO
Canada
#12  
@nomad TMBS great observation! I can't believe I missed that.

@jfew unfortunately because you ran your servo wires through the hole in the servo brackets, the servos themselves are likely are tugging their own wires right out of the servo causing intermittent contact to the servo electronics. Or the wires are getting pinched between the body of the servo and the bracket.

Please change the way the servo wires are run back to the standard configuration.
User-inserted image
#13  
I missed where he ran the servo wires too.... Nomad has good eyes.... Anyway, where you routed your servo wires most definitely I can see would cause either the servos to bind or wire connection problems... My guess from the sound in your video one or more of the servos have stripped the plastic spline in their bracket housing....
PRO
Belgium
#14  
i saw this in the video


User-inserted image