Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Ax12 Led On/Off Command In Ez Script

Hello,

I set up one of my dynamixels tonight, used the plug in, wrote scripting to "exercise" this servo. All works fine. In EZ script there is an instruction AX12Led(port,on) and AX12Led(port,off). I cant make either of these work. Using the plug in I can turn the LED on the servo on and off. Is there a way via scripting to do this. During startup I would like to see these all come on and go off as a way of ok communications. Thanks

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
PRO
Canada
#2  
I have verified that there's an issue with the AX12Led() command, it won't compile.

The error comes up as: "Error on line 2: Unknown function: AX12Led."

I'm pretty sure if @DJ has seen this post he's already on it.
PRO
Synthiam
#3  
Yeah it's been removed from the next release of ARC because it doesn't exist. It was accidentally left in the manual page when dynamixel was moved to a plugin.
#5  
So I am really unsure of what i'm missing here.... Downloaded the new dynamixel plugin. Installed it. The only thing I see different in the "cheat sheet" is under "show controls dynamixel". I do not see any way to turn the led on or off in any other way but the initial setup screen for the servo itself. I can not find any other documentation on turning the led on/off either. When looking through script help I do see that AX12Led instruction is still there. Can someone please provide an example in script on how to turn the led on? Thanks

Chris
PRO
Synthiam
#6  
1) As previously stated, the AX12Led EZ-Script command will be removed from the manual in the next release of ARC.

2) You will need to update to the latest Dynamixel plugin to obtain the ControlCommand() to control the LED's. Documentation is in the plugin. If the plugin was not updated, try again and pay attention to any error messages during the installation.

3) You must have the dynamixel plugin added to your project for dynamixel ControlCommands() in the Cheat Sheet to exist.
#7  
Hello,

Apparently I am getting many errors trying to install... I cant copy and paste though!

so.

Extracting file:dynamixel .dll(52659 bytes to 71168 bytes)
File exists, deleting
System.unauthorizedacessexception: access to the path c:\users\public\document\5edbbb5d-d9ef-4400-9ecf-858ec24b8746\dynamixel.dll is denied.
at system.io_error win io error(int32 error code,string maybe fullpath)
at system.io.file.internaldelete (string path, Boolean checkhost
at system.io.file.delete(string,path)
at ez_builder_plugin_manager.form1.egjphptai(string)


Any ideas?
PRO
Synthiam
#8  
Because you are attempting to install a plugin that is already in use.

1) Close ARC

2) Load ARC

3) Install the plugin update
#9  
Tried that, still doesn't work, same error.
#10  
How do I get this new control into my existing project.


EDIT:

Not sure how I did it but it is there now. Thanks Chris
PRO
Synthiam
#11  
1) Close ARC

2) Visit the ez-robot website at www.ez-robot.com and click on Software -> Plugins

3) Locate the plugin that you wish to install and press it's INSTALL button

4) Follow the installation procedure

5) Load ARC

6) If you have a project with an existing dynamixel plugin, it will load the updated plugin automatically. If you do not have a project with a dynamixel plugin, use the Project->Add Control->Plugins
#12  
So I have the updated plug in now. However the ControlCommand() for led control still does not work. From the setup page where I can address the dynamixels, the led on/ off works fine . As to my other thread in speaking with trossen robotics tech support today they have assured me that the mx 64 t servo uses the exact same protocol as the ax12a yet I cannot control the mx 64 t. The only difference I was told was that the mx 64t ships with a baud rate of 57,600 rather than the 1000000 ARC uses as default. I tried changing the baud rate in ARC to 57,600 but I don't believe it's actually changing anything. Anyone have any experience with this?
PRO
Synthiam
#13  
baud rate change works. unless you're not pressing the Force Init, the baud rate change does nothing

i'll check the led to see if there's somethign else
PRO
Synthiam
#14  
get the latest version of the plugin, i added help icons to assist you. I also added a button on the config menu so you can initialize from that menu to assist you.

Here are instructions to install/update a plugin:

1) Close ARC

2) Visit the ez-robot website at www.ez-robot.com and click on Software -> plugins

3) Locate the plugin that you wish to install and press it's INSTALL button

4) Follow the installation software by double clicking on the downloaded file

5) Verify there are no errors in the installer window

6) Load ARC and locate your plugin in the Add Controls menu
#15  
Hey Dj,

I hate to report another issue I just came about... with dynamixels ax12a. I may be doing something wrong so. Is there a way to adjust the speed of the dynamixel servo? I ask because when I tried to use the ServoSpeed(port,speed) command my ezb4 did something completely weird. I run my controller in AP mode. When I ran the script I created using the servo speed instruction the ezb4 started speaking "I have successfully connected to your network" I verified this twice, deleting the servo speed instruction-all fine, re inserting speed command and it spoke the message again. I did insert the servo speed instruction before the actual position command. Thanks again! Chris
#17  
Hey Dj,

Whatever you fixed now allowed me to communicate with my new MX-64 t servo. The led on/off also works. One last possible favor.....? The Mx-64 t is not even close to a full range of motion. I would say it travels about 45 degrees in either direction. This may be due to it being a bigger servo? The ax12a's work perfectly. Im wondering if I need to buy the usb2dynamixel adapter to set up this bigger servo? Thanks again! Chris
PRO
Synthiam
#18  
Might have to think about a way to add an adjustment for servo trim. Let me think about that...

Don't bother with USB - because that's just gonna require an onboard computer and no one wants that extra weight:)
#19  
Now I'm thinking maybe this servo has more steps? Like 1054 rather than the 255 limit?
As to the USB thing I was talking about , I believe with that unit you can enable and disable more options or functionality within the servo itself.