Asked — Edited

A Tiny Question

Yesterday I received my IoTiny's(3), after testing all of them I noticed that the first one didn't make the start up sound, however I was able to connect to it via the web client. But after I set it to client mode and copy pasted my network SSID/password it wouldn't connect to the network. Pressing the reset button didn't have any effect. My other IoTiny's also wouldn't connect to the network... I found out that the security password text box is limited to 20 characters. My password has 23... I have the same problem on my v4/2 EZ-Bs. Before upgrading to /2 I didn't have this problem. But I was able to work around this problem by modding the code of the textbox, extending it to 25 or just deleting the limiter, through the Chrome console and I got my V4/2's and 2 of my 3 IoTiny's working.

But to conclude, I have an IoTiny of which the web client can't be reset via the reset button and it is not visible as a WiFi connection. I don't know if there are any other issues with it, as far as I know the speaker output is not working, but I can't be sure until I'm able to connect to it and use it. Is there another way to reset or acces the IoTiny?


Upgrade to ARC Pro

ARC Pro will give you immediate updates and new features needed to unleash your robot's potential!


If your resetting with power connected, and it isn't working, it is either the reset button, or a faulty wireless chip. See if DJ or Jeremy pipe up, otherwise I would go to Contact Us and make a warranty claim.


IoTiny's need to be updated before use. The IoTiny that is no longer responding needs to be sent to ez-robot HQ to be manually programmed because it is now bricked.

Find the address in the Contact Us section


The first thing I immediately did right out of the box was to update all of my ioTiny's firmware... All 6 upgraded and are working perfectly.... Thankfully no "bricking" for any of mine...


The original firmware has a bug for when an invalid network authentication is entered that the reset button doesn't work.

Or, i guess you can fix it by temporarily changing your wifi password to be the 20 character limit - so it connects. Then reset it and update the firmware. That'll work:) Just thought of it!


Good info to know. Maybe a note with shipments would be useful or a sticky on the forums regarding this.


There's a post about it earlier - i suspect it was missed by some. I'll have an email sent to IoTiny owners.

  1. Connect to IoTiny WiFi network

  2. Load IoTiny Firmware Update Program (installed with ARC)

  3. Press CONNECT button

  4. Press UPDATE button and wait


@DJ I did not see the post stating I would have to update the firmware so I went for my usual and set it to client mode, because I mainly work from a desktop that doesn't have WiFi. The laptop I'm using to configure the EZ-Bs has this Windows 10 issue that it doesn't allow me to uninstall ARC. But to set it to client mode you don't need ARC so I figured I could set it to client mode, update it via my desktop and happily continue. Which worked for 2 IoTiny's and 2 EZ-B v4/2's after I worked around the password character limit.

Either tonight or tomorrow I will change the password of my router and see if I can update and fix it.


@budel0 Slightly off topic, but have we tried to troubleshoot your Windows 10 issue? Is it a machine from work and giving you an administrative rights issue? If so, I might have a solution. Let me know what error you are getting when you try to install, and I might be able to help you figure out the issue.



Thanks DJ. I remember that thread now. However live is full of distractions and I lost track in my mind. Not unusual these days. I'm glad I have this info now and will update my little guys this weekend. ;)


Upgraded mine this AM. All went smoothly. Easy Peasy!

Will do my V4/2 upgrades tonight for big R2.

User-inserted image


@Lumpy That's a lot of iOTinys...:D... I snagged myself 6 of them. However as soon as more become available I plan on buying a boat load more....:)


@DJ Unfortunatly no luck after changing the WiFi password, I tried serveral times without any results. I even tried with different versions of the cut-off password, yielding the same result. Are there other possiblities?

@TheTechGuru I mainly use the laptop for work, but it's mine personally, I have all the rights etc. But it's the "windows 10 uninstall a program problem where it'll ask for a non existing .msi file", the same happens when I try to uninstall it by installing the newer version. The internet told me to solve it by deleting it through the Regedit, but that didn't have any effect. I haven't had the time to try other possible solutions, but if you have any other suggestions to solve this problem I will greatly appreciate them.


I'll do some research to see if I hve any suggestions.




The new /2 comm boards when installed on old v4, also need a firmware update? I wish this forum has stickies.


The /2 comm boards do not need a firmware update. As per the email you received as an IoTiny user, only the IoTiny requires update.


Somehow missed an email. Thanks for the info. The IO Tinys are amazing. Installing one in ALAN now to test! Great job by all!


Can someone forward me that email for the IoTiny


Josh, where did you get an IoTiny? Fangle give in or someone?


Like Frank said lol , I traded him a roomba He got a awesome deal.:)


Damm, If I thought you would have taken that offer I would have offered it.


@ Dave I still got a few robots left! If your interested email me.


Thanks but the only one I wanted to "steel" from you was the roumba. ;)


I would like to thank everyone for their input so far. Unfortunatly the IoTiny is still down. If no one has any further ideas to resolve my issue I'd like to close this thread and continue on with the customer support and get the IoTiny to EZ-Robot.