Asked — Edited

@Dj Or? Sound Servo(Ezb Playback)

I've been testing Rich's led tutorial

I've been able to get it to work on, sound movement, sound servo(PC Mic), sounds servo(PC Speaker) but not able to get it to work with sound servo(EZB Playback). I have also noticed when hitting the? On the sound servo(EZB Playback) goes to the webpage talking about the sound servo(PC Mic). ?

Also when I use the sound servo(EZB Playback) and play something [sayezb(" test test test", 3) i hear this on the ezb speaker but the level on the sound servo(ezb playback) shows 0 never changes.

Well maybe I'm not understanding but I thought the sound servo(ezb playback) is used for the sound coming out of the speaker of the EZB controller to control a servo or in this case the LEDs.



Upgrade to ARC Pro

Experience early access to the latest features and updates. You'll have everything that is needed to unleash your robot's potential.


I also noticed in the Learn section under ARC manual, audio, it only lists sound server(EZB)

So maybe I missed that part by DJ and professors E. blush confused


@merne Do you have the Sound servo v4 control referencing the correct board? By default it is set to board 0. In your sayezb example above however you are using ezb4 board 3....

sayezb(" test test test", 3)


@Richard R,

[qoute] Do you have the Sound servo v4 control referencing the correct board? [/quote]

Yes I do.


That's strange as it works for me... Maybe try using it on board 0....


Ok, I just tried it on both V4 & V41/2 board 3 trying it on board0


@Richard R.

That's very interesting. I just tried on board 0 and it does work! It only seems to work using the default board 0. On a sidenote, I personally do not use this but I have learned trying to help someone else.

Maybe the Robert Overloard wrote it only for board 0? Lol

Thanks again Richard.


@richard r, are you saying it works on any board number or only on board zero


I only tested it on board 0... I will try after dinner on another board connection...


It's interesting on the Sound Servo(EZB Playback) it doesn't matter if you have board 0, 1, 2, 3 or 4 selected it still works as long as you are connected to EZB controller board 0. No other controller board 1 thru 4 will work?

So is this a bug or a feature?

@Richard R please verify. Thanks


Just tested this and yes, it looks like it only works on board 0