Asked — Edited
Resolved Resolved by Niek!

Camera Controlcommand Error With The Camerarecordstart Command

Hi, since a recent update (I don't know which one exactly), the ControlCommand "CameraRecordStart" returns a Camera ControlCommand Error and interrupts the script. The "CameraRecordStop" command returns no error.

All I can tell is that this command worked with the 2013.07.03.00 release... It is probably a small bug on the road to Revolution;)


Upgrade to ARC Pro

Elevate your robot's capabilities to the next level with Synthiam ARC Pro, unlocking a world of possibilities in robot programming.


Are you sure you used quotation marks around "Camera"? I tried

ControlCommand("Camera", CameraRecordStart)

and had no problems.

United Kingdom

I tried last night and had the same problem on an older version (a couple of updates behind at most).

When I tried I used the Click & Paste to add it to the script from the controls part of the EZ-Script dialogue so it should have been 100% correct, I honestly don't know if it had quotes or not though.

I'll have another go later with the latest version.


@Niek, like Rich did, I have used Click & Paste from the Controls. I have verified and the quotation marks are present. Moreover, the same script worked well with the 2013.07.03.00 release, so it is a recent issue... Are you using the last version as well ?

United Kingdom

@fredebec, I just updated to the latest (2013.08.19.00) and it worked fine.

Have you tried uninstalling and reinstalling ARC?


@fredebec I used the latest version and clicked under the ControlCommand tab. It should be fixed in the latest version;)


Ok, I found the problem !

First I tried to reinstall ARC, with no success... So, I tried to create a new project (in spite of creating a new script in my existing project) and then in worked ! At first, I didn't see any difference between the two projects, but there was:

When you create a new project and add the Camera, in the "Media" part of the Camera preferences, there is automatically "" with quotation marks entered in the "Title Text" field (see the screenshot)

User-inserted image

But in the previous version of ARC I used, was automatically entered without the quotation marks... and the new version don't like it !

So, I just had to add quotations marks in the Title Text field of my old project, and voilĂ , everything works again.

Thanks @Niek and @Rich for your help (PS: As it was a quotation marks issue, after all, I think Niek deserves the credit of the "resolved topic" ;) )

United Kingdom

Ah, I remember another topic which brought that up now you've mentioned it. I didn't even think to check in there to be honest, now I know for next time it happens (if there is a next time).


@fredebec well that's a sneaky bug! Glad you figured out a solution.


The exact error message you received would tell you of the error:)

It's always best to screenshot or write down the exact error when asking for help.

But, glad you figured it out:)


@DJ, I know it is usually the case, but this time the only error message (in a new windows) was "Camera ControlCommand Error", that's all. And the script only stopped, with no info in the debug screen. So it was hard to define exactly what the problem was...