Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
United Kingdom
Asked — Edited
Resolved Resolved by CochranRobotics!

Windows 8 Speech Synthesis And Ez Builder Question

Hey guys.

I have asked this question in another thread, but I decided to create a new "assistance required" thread as my issue relates to Windows 8, where as the other thread was really related to Windows 7, plus I'm still having problems. I really hope someone can help with this.

The issue

I'm in the middle of a transition from moving from a Win 7 to Win 8 laptop, and I'm having a real pain in the butt issue using speech synthesis voices with the new Windows 8 machine and new ARC install.

As Richard may remember, I mentioned in the other thread that I copied the .exe file for a Cepstral voice from my Win 7 machine, reinstalled it on to the Win 8 laptop, and added the activation key. The voice worked on Narrator and other 3rd party apps such as screen readers, but it never worked on EZ Builder so I thought that was the problem. I have since reset the laptop back to the "Out of the box" state, and started again.

My new Windows 8 Toshiba Satellite laptop comes with three pre-installed voices, but only one of them works with EZ Builder. I have installed a fresh version of a trial Cepstral voice and a 30 day trial of an Ivona voice, and neither one works with ARC either.

I have tried each and every variation of the "Speech synthesis" settings for each voice and they have made no difference whatsoever, and keeps using the one Windows voice. The only thing that does change is the "Rate".

Have any of you guy's faced this issue with Windows 8, and/or does anyone know what can be done so I can use the voices I want to use? I really want to get this working and I don't see why I'm having these problems, as using Cepstral with EZ Builder on Windows 7 was no problem at all. Please help. *confused*

Many thanks.

Steve.:)

United Kingdom
#110  
@David.

Well thanks a bunch. Now I've gone and broken everything now. Only joking. As you can tell by the banter, I have had some interesting results. Here they are...

I was unable to delete MS Hazel from the registry as it came up with an error. So I went via C:\Windows\Speech\Engines\TTS\en-GB and deleted the entire file. I then went to "Control Panel", "Speech Recognition" then "Text to Speech" to see if I did break anything. Hazel was still there but didn't work anymore. I had sent her packing. I then tried Heera and Zira. Phew, they were still working. So I then opened a new ARC project to see if everything was working there. I tried Heera and Zira and..... THEY WORKED :D. I could change them in the Speech synthesis setting and the spoke with there corresponding voice. So next test.

I downloaded Cepstral trial and Ivona trial. Again they worked in Windows so tried ARC again, but would you believe it..... THEY WORKED TOO.:D:D:D

So, after 110 posts and a lot of head scratching, what I originally had a feeling about actually got scorching results. I'm going to try this again now on my main (new) Acer laptop but I can't see me having any issues, I hope. I'll leave an update in a bit.;)
#111  
That is great. so..... in thinking about this.....

Hazel was a GB voice. The others are US voices. I wonder if the GB voice was having issues due to globalization. It is interesting that the others started working. It is also good news.
#113  
ROFL @Richard R. I was drinking some water and you choked me...
#114  
@David... sorry buddy...:)

@Steve.... problem finally solved... Awesome...! You're one persistent dude....:)
United Kingdom
#115  
Maybe, just maybe that's what it is. Well, I have done the same thing on the Acer, all voices working in Windows. But hiw did they get on with ARC...

MS Hazel... Looking for a new job, and the nearest bar to drown her sorrows. *mad*

MS Heera... WORKING.:)

MS Zira... WORKING.:)

Ivona Brian... WORKING:)

Cereproc William... WORKING:)

And finally
Cepstral Lawrence... WORKING :D. (K-9 will be happy)

So there we have it. David, you may be on to something about Microsoft UK voice globalization. To some this may not be an ideal solution, but it is certainly proven now using two Windows 8.1 machines. Well there's not much else to say now. Patches must be a lucky charm lol. Thank you though to everyone who has chimed in with your ideas, trials and sharing your issues. I can't of course credit myself marking this as resolved, so I'll give it to you David as you were the one who gave me the info for deleting, er, what was her name again?

NOTE.

Anyone else having similar issues who decide's to try what I did, as d.cochran correctly stated, you do so at your own risk. I was willing to risk it and yes, it worked out for me. Although this wasn't a registry change, you are still deleting files, so only do this if you know what your doing, and at your own risk. Okay, lecture over.:)

Thanks again everyone.:D
United Kingdom
#116  
@Richard.

Mate, you have no idea lol. This was one thing I REALLY wanted to get solved. Two of my projects were relying in it.:)
#117  
@Steve... No doubt about it ... this ones all David's....
#118  
Thanks Steve. Im just glad you have some sort of resolution.
#119  
I'll try this evening or tomorrow to do the same thing with the Microsoft David that seems to own my machine and post results here for those of us in the US.

Alan
United Kingdom
#120  
Let us know how you get on Alan.
#121  
edited to remove long post about partial success. it was only temporary....
#122  
@thetechguru,

Did you check to make sure the language was still gone from the hard drive? You know as well as I do that Microsoft likes to try to protect you from yourself a lot.
#123  
OK. Now I have partial success. If I install Cepstral and then reboot, and then delete the en-US engine, Lawrence works in windows and ARC. Can't use any of the voice effects like Old Robot, and no other voices work in EZ, but Lawrence does. (even though Hazel does in Windows).

Same results on both 32 and 64 bit machines (although using the trial Cepstral license on 64 bit)

Alan
#124  
Partial success is much further than we have made it up to this point. I wish there was an overall solution to it but partial is better than nothing. Maybe Windows 10 will have better luck but I am not holding my breath.
United Kingdom
#125  
@Alan.

When I opened C:\Windows\Speech\Engines\TTS\en-GB, I deleted the four files I had one by one.

M2057HAZ.Keyboard.NUS
M2057HAZ
MSTTSLocENGB.dat
M2057HAZ.APM


Technically Hazel (the four files above) isn't out looking for a new job just yet, but she has been banished and resides in the recycle bin at the moment. To get the Cepstral effects working on ARC....

Open your (c: ) drive,

Then Program files,

Cepstral,

Sfx,

Copy the effect you want to use,

Go back to cepstral,

Voices,

Open "Lawrence" file,

Paste the sfx file,

Rename the effect to "default.sfx",

And that should be it. Open ARC and Lawrence should use the effect. Hope that helps Alan.:)
#126  
Awesome Steve.

So Microsoft has really borked up Sapi, but at least we have workarounds.

Alan
#127  
That worked great (copying the effect file). I'll probably wind up using dizzy droid or pvc pipe so that our K9's will sound like cousins instead of twins. I'll write a little batch file to make it easier to switch until I make up my mind.

Alan
United Kingdom
#128  
No worries Alan. Pleased you got it sorted. I use the PVC pipe effect with my little fella. He's just happy he can talk again (& so am I).:D
United Kingdom
#129  
UPDATE:

A couple of weeks ago, I upgraded to Windows 10 from 8.1. While troubleshooting somebody else's ARC project, I found that this same issue occurs. The new OS install reinstalled the Hazel files which had to be deleted again. It was a simple case of copying and pasting C:\Windows\Speech\Engines\TTS\en-GB in to the "Cortana" taskbar search window, and deleting the files again.

The Tutorial On Fixing Voice Synthesis Problem With Windows 8.1 and 10 has been updated to show this.