United Kingdom
Asked — Edited
Resolved Resolved by CochranRobotics!

Windows 8 Speech Synthesis And ARC Question

Hey guys.

I have asked this question in another thread, but I decided to create a new "assistance required" thread as my issue relates to Windows 8, where as the other thread was really related to Windows 7, plus I'm still having problems. I really hope someone can help with this.

The issue

I'm in the middle of a transition from moving from a Win 7 to Win 8 laptop, and I'm having a real pain in the butt issue using speech synthesis voices with the new Windows 8 machine and new ARC install.

As Richard may remember, I mentioned in the other thread that I copied the .exe file for a Cepstral voice from my Win 7 machine, reinstalled it on to the Win 8 laptop, and added the activation key. The voice worked on Narrator and other 3rd party apps such as screen readers, but it never worked on ARC so I thought that was the problem. I have since reset the laptop back to the "Out of the box" state, and started again.

My new Windows 8 Toshiba Satellite laptop comes with three pre-installed voices, but only one of them works with ARC. I have installed a fresh version of a trial Cepstral voice and a 30 day trial of an Ivona voice, and neither one works with ARC either.

I have tried each and every variation of the "Speech synthesis" settings for each voice and they have made no difference whatsoever, and keeps using the one Windows voice. The only thing that does change is the "Rate".

Have any of you guy's faced this issue with Windows 8, and/or does anyone know what can be done so I can use the voices I want to use? I really want to get this working and I don't see why I'm having these problems, as using Cepstral with ARC on Windows 7 was no problem at all. Please help. confused

Many thanks.



Upgrade to ARC Pro

With Synthiam ARC Pro, you're not just programming a robot; you're shaping the future of automation, one innovative idea at a time.


@Steve... so within ARC if you set the voice to be the voice from Cepstral it still speaks in the default Windows built in voices?

United Kingdom

Yeah that's right. I can change it to Cepstral, Ivona, Windows #2 voice, or Windows #3 voice within speech settings, but keeps using Windows #1 voice, even changing Gender, Age or Emphasis to any variation of settings doesn't change this.


@Steve.... Wish I could help you more.... I have one of Ceraproc's voices on 2 of my win8 machines... I have no issues going back and forth with any of the voices... including the default Windows voices... Sorry I couldn't be more help dude...

United Kingdom

No worries Richard. I appreciate your input never the less:). I just hope someone else will chime in with a solution or some advice. I'm sure I'm not the only one who has faced this, and if I am, then maybe it's something to do with the new laptop (which I don't think it is).

If it was just the 3rd party voices not working I could kind of understand it to some degree, but the fact ARC is not using two of the three pre-installed Microsoft voices is baffling.


Just a thought... Do you have the option of installing your Cepstral voice as administrative?... Right click the file and select Run Via Administrative? A while back I had Paul (Cepstral voice) and I can't really recall but I vaguely remember having to do something like run as administrative or run in Win 7 compatible mode or something like that in order to get it to work....

I am probably way, way off so I wouldn't hold your breath.... Worth a check, maybe?

United Kingdom

Ok thanks dude. It's worth a look as I will try anything at this point. Still, that wouldn't explane why the Ivona and two Microsoft voices are not working.


Ooops. you're right forgot about that.... What happens if you go into Windows settings and set your Cepstral voice as window's default voice?

United Kingdom

No difference. Other system or third party apps will use whatever voice I select, (Cepstral for example), but ARC will still refuse to use it.


That so is weird... I assume you've uninstalled ARC then downloaded a fresh copy and then reinstalled it....?


i use swiftalker from cepstral.it has some settings and works whit. win7 and 8


United Kingdom


Yeah it's a fresh install on the new machine. Do you reckon un and re-installing it migh work? It's worth a go I guess.


Thanks for replying. I have Cepstral Lawrence working on my Windows 7 machine with no problems at all, even with robot sound effects. But ARC point blank refuses to use anything except the one voice mentioned earlier on Windows 8.


Is your Windows 8 32 or 64 bit? What about the Win 7 where it is working? I haven't tried voices yet on my 64 bit machine, but I absolutely can't get autohotkey to work correctly on it (even the 64 bit version).

If I get some free time in the next day or two, I will try the demo version of Cepstral and see if it works for me on either a 32 or 64 bit windows 8 install.



My HP PC is Win 8.1 64bit and speech works with all my installed voices, both 3rd party and built in...


Another thought is maybe it is a locale/region/language preference issue. ARC has issues with some functions when the locale settings are for other countries than North America. I wouldn't think it would have an issue with UK locale settings, but it is probably worth looking into.



Ignore my suggestion about locale settings.

Both 32 and 64 bit Windows 8.1, for me, ARC ignores the Windows default TTS engine and uses Microsoft David.

When changing speech settings in ARC, the only change I can make that has any impact at all is between male and female. If I switch to Microsoft Hazel, it is actually playing the female version of microsoft David, not the Hazel voice. Switching to Zira male or female play male Microsoft David, as does the trial download of Cepstral Lawrence.

Richard R, what 3rd party voice are you using?




I am using Cereproc (William, I believe)

Hmm.. they don't have a trial license. Hate to spend $40 USD just to test, although if it works, the Giles voice is close to what I want for my K9 (1899).


United Kingdom


It's a 64 bit system, as is the Win 7 laptop. I've just got home so I will try reinstalling ARC, but I don't hold out much hope as I think I tried this before, before I reset the laptop.

But thinking about it this goes back to what I said earlier in post #7. Before I installed the two 3rd party voices I tried selecting all three Microsoft voices with various settings and could only use one if them, so I don't see a reinstall making any difference. confused



But thinking about it this goes back to what I said earlier in post #7. Before I installed the two 3rd party voices I tried selecting all three Microsoft voices with various settings and could only use one if them, so I don't see a reinstall making any difference. confused

I agree. I am duplicating this on two different machines, one 32 bit and one 64 bit, and the 32 bit machine is a couple of releases behind in ARC versions, so I am pretty sure this is an ARC issue.

I also tried changing my regional settings to Canada on one of the machines since Richard R says it works for him, and certainly it has worked at least in the past for DJ (he has been on Windows 8 since the tech preview), but that didn't help.



Ok, did some tests... The only issue I seem to have is that Hazel and Zira have the same voice... I can switch between all the voices, though... So with exception of the Hazel/Zira problem I have no trouble changing voices within ARC... I did notice I have to set the voice as female if using a female voice and male if using a male voice...


And hazel has a british accent for you? for me, when I select Hazel, it is really the female version of David (US English accent) but in Windows Hazel is a UK English accent and Zira is a different US female voice completely.

however this gives some hope that maybe the Cereproc voices work. Need to decide if I want to spend that money on a chance they do, when the Cepstral voices are half the price.


United Kingdom

Thanks for testing and replying guys. Ok, so I have removed and reinstalled ARC, no change. I have also changed the Regonal setting to US (worth a shot), no change. I have also set one of the 3rd party voices to the TTS default voice, yep, you guessed it, no change. It continually uses Hazel and nothing else. This is getting a little frustrating now as you can imagine. mad


No Hazel and Zira seem to have an American accent... This is within ARC... I'll check windows and see if the accent changes...


Ok so Hazel has an English accent outside of ARC, however Hazel has an American accent within ARC (which is the same as Zira's)? So to add to the confusion, Zira's voice is the same inside and outside of ARC (American)... confused David and William (Cereproc) are as normal inside and outside of ARC...

United Kingdom

I really appreciate your input so far Richard and Alan, but it just ain't happening. So here's what I've tried so far...

Tried all three installed Microsoft voices,

Installed and tried Cepstral,

Installed and tried Ivona,

Un and Re-installed ARC three times now,

Used UK, United States, and Canadian Regonal settings,

Tried every speech synthesis setting configuration for each voice,

Disabled anti virus (just in case),

Set different voices to default in the laptops TTS settings (applied and and saved),

Restarted laptop several times after doing all the above,

And now I'm fresh out of ideas.

All voices work outside of ARC, but only Hazel UK (with English accent) works with ARC with every setting variation that can be done. I'm really hoping someone from EZ Robot HQ might have some suggestions. stress


OK, so on UK version of Windows, only Hazel UK works for you. On a North America version of Windows only David really works (Richard R, if you set David to Female in ARC, it will be the same voice as Zira is in Windows....).

It appears that at least for Richard, Cereproc (which is different from Cepstral) works in ARC, so I guess it will be up to EZ-Robot to figure out how it interacts differently from the others, but I think this is clearly an EZ-robot issue to fix.

Not sure if you want to drop 25 pounds on a Cereproc voice just to see if it works. They do seem to have some decent UK accent voices. I think I'll wait for an ARC fix before spending anything. Microsoft David works well enough for my current needs. If I get my K9 built before it is fixed, I'll reconsider.


United Kingdom


Not sure I want to fork out £25 to test another voice out just yet. I think I'll wait to hear from the EZ Robot guys first to hear their take on things, and find out whether its a bug that needs to be looked at or if there's another solution to solve this.

@DJ and Jeremie.

So what do you guys think could be causing these voice issues, and have you come across something like this before?


@Steve G I have exactly the same Voice problem as you - I'm stuck with just one voice on 4 different Windows installations - Win7-64 on a PC, Win7-32 on an old Dell, Win8-64 on a PC and Win 8.1-64 on a tablet. In all cases I can change the voice within Windows but ARC does not allow any change. ARC "Speech Settings" displays the available Windows voices (which varies for my 4 installations) but will not change to any of the listed voices. As with yours, the only thing that can be changed is the rate. Yes, my Hazel has a "pommie" accent too! I have not tried any 3rd party voices.

United Kingdom


Thanks for posting and letting us know, and sorry to hear your suffering from the same problem too. Strange your having problems with Windows 7 installations as I've never had a problem with that. But saying that, it's also strange that's it not working with windows 8 as well. It's not nice to hear your having these issues, on two Win 8 systems no less, but I'm glad I'm not the only one. So maybe the is a bug of some sort. confused


@Steve G I must clarify that my Windows7 only has one voice - Anna, whereas Windows8 comes with David, Hazel & Zira, Windows 8.1 comes with Heera instead of David. In all cases though Gender, Age and Emphasis cannot be adjusted in the ARC Speech Settings panel. In 8 & 8.1 the voice can't be changed between the 3 available voices. Yes, they can be "changed" in the panel but they all sound the same!

If I was confident that a 3rd party voice would work in Win8 or preferably my 8.1 tablet I'd pay for and use that option. Having only the one fixed voice makes for a pretty boring robot in the speech department, and I feel like my JD needs to be wearing a skirt!

United Kingdom


I feel you buddy. My K-9 robot was using Cepstral Lawrence with robot effect on Win 7 which has become a big part of his personality, and the move to Win 8 with ARC has pretty much killed that off for the time being, along with my new robo project that was going to use the Ivona voice I chose for it.

Using a female voice (and not a great one at that) is not what I want for either robot:(. I'm still hoping to hear from someone at EZ HQ in regards to this as I really want, and need to get this issue solved as I'm sure you do too.

United Kingdom

Okay, so this morning I tried another 3rd party voice which was a free one from NVDA. It's a screen reader but comes with a selection of free to use voice synthesisers which I have used successfully on Win 7 64 bit and worked with ARC. With Win 8 64 bit, NO JOY AGAIN:(.

As before, it shows up in the speech synthesis settings list, tried different variations of settings, but ARC still uses MS Hazel.

This is getting desperate now as my Win 7 laptop has almost given up working, and I have a charity event at a school I'm supposed to be taking K-9 too this Saturday, as having him conversing with the kids there was meant to be one of the attractions. I can't take him with a poor sounding female voice as it ruins the effect, besides, I have sound files that include Cepstral Lawrence which would mean he would be speaking with two voices.

I'm really at a loss of things to try now. confused stress


Assuming that DJ doesn't see this, find a bug, and fix it before the weekend, you could try contacting Cereproc (which works for Richard) to see if they have a trial license available.

No mention of it on their web site, but I saw from a google search some old references to getting a trial coupon from Cereproc. If any of their voices sound like they would work for you, you could email them to see if they still do that so you could try before buying. (William didn't sound too different from Lawrence to me. Not a great match to your sound files, but not as jarring as changing genders).

I don't know if they have the "robot" effect on their voices. None of the Microsoft voices have it, at least on my machines.


United Kingdom

It's worth a go a guess. I'll try anything at this point. Thanks Alan.

United Kingdom

I just fired off an email to Cereproc to see if they will offer a trial period licence. Fingers crossed X X.


I am tempted to bite the bullet and just buy a license, figuring that if it doesn't work, DJ will eventually fix it and it will. I don't want my K9 to sound exactly like your's anyway because that would just be weird, but I do like the Lawrence voice with the robot effect. If Cereproc also does robot effect I would be happy with the William voice, but without it, it sounds TOO human. Their website is woefully thin on details unfortunately.

The only thing that is holding me back is that success on a North America Windows install doesn't necessarily translate to success on a UK install, so I might buy it, have it work, and then you might follow suit and not have it work (main concern being that we have different results just using Microsoft voices due to our regional settings). I can't handle the responsibility:)


United Kingdom

Don't worry Alan. You are hearby exempt from all responsibility:D. Joking aside, I agree that the Cereproc website doesn't give much away in regards to details and features. I'm still hoping the guys at HQ will chime in with some advice.


I believe Rich has a Cereproc voice as well... @Rich, I assume you are using it (and it is working) in ARC?

The voice you hear in my Inmoov video is Cereproc William...


@Richard R,

does it support voice effects like "Old robot" in the Windows settings?



@Alan, where do I set that? In text to speech I can choose the default window's voice but there is no other settings... Settings button is greyed out for some reason (for all the voices)...


If it is greyed out then it doesn't support effects. The default Windows voices don't. Cepstral does.



One thing that @DJ pointed out that may play a factor is that ARC is a 32-bit program so on a 64-bit computer, 32-bit voices may have to be installed instead. Even the default voices (Hazel & Zira) may have to be reinstalled.

I was able to get the trial version of Cepstral William (US english) working when I downloaded it from here.

United Kingdom

Okay. So as we are all baffed to why I'm having these issues, I emailed Aislinn this morning (not the correct procedure I know, but it's a one off) to ask for some extra assistance.

She very kindly just got back to me saying that Jeremie has confirmed that there are issues using certain voices with both Windows 7 and 8. The issue is now under investigation, but as we all know DJ is a busy bee, so will look in to this further when he gets a chance.

In the mean time, if anyone else is having issues using voices with ARC, please post your operating system and voice details here on this thread so we can compile a list to narrow down issues that may help with the investigation. Also, if anyone has any further ideas to a workaround or possible solutions, then please feel free to share your ideas to hopefully help those of us having problems.

And a quick, but BIG thank you to everyone who has tried to help. You know who you are. :P


United Kingdom


Thanks for your reply and to yourself and DJ for looking in to this. What operating system did you install Cepstral William on, and was it a 32 or 64 system?


I'm running 64-bit Windows 8.1

United Kingdom

Interesting. Thanks Jez.


Jeremie, We have already ruled out 32 vs 64 bit. Having exactly the same issues on both of my machines, one of each.

When you used Cepetral William, did the voice actually change? ARC will speak when I select it, but it is the same as the MS voice.



I don't think we can rule out 32 versus 64-bit as it seems @RR, yourself, @Steve, and I are seeing different results.

Yes, the voice changed when I used "Cepstral William" in ARC but didn't change when Hazel and Zira were selected (stayed as the David voice).

United Kingdom

A bit of an update which is mainly directed at Alan, but maybe of interest to others.

I received an email today from Cereproc, and in a nutshell they said that they don't normally offer free trial versions of their software, but If were willing to leave some feedback for their blog they would be willing to supply me with a trial package ($250+VAT if I don't leave any eek). So I just fired off a reply saying I would be happy to do so and waiting on their response. I'll let you know how I get on.

In regards to a workaround, I read in this thread about downloading Microsoft Speech SDK which apparently worked on a Win 7 system. Not knowing anything about SDK's, I was just wondering what steps (apart from downloading if course) are involved to get voices to work with ARC? I might give it a try later just to find out.


Wow, $250, they must be talking about a trial of either their ask or their commercial use license. Individual license is only $40.

I would caution against trying to install an older version of the MS voice SDK. The reason we were doing it on Win 7 was to get voices that were in XP but left out of 7. Most of those are back in win 8. Unless you are prepared to fully reinstall win 8 if something goes wrong I would avoid trying that. The downloadable versions are a couple of revisions back from the current one included in Win 8.


United Kingdom


A paragraph of the email...


If you do not provided feedback on the trial, then CereProc will issue an invoice for £250 + VAT for the trial to cover our associated costs.

I though that was a LITTLE steep, but I don't mind leaving some feed back in order to try it out. In regards to the SDK, I hear you loud and clear and will stay away from playing around with that. Thanks for the heads up.:)

United Kingdom

Another update although there's nothing much to report.

I managed to squeeze some life out of my Win 7 laptop Friday night/Saturday morning and made a load of Cepstral Lawrence voice samples that I loaded up on to my Win 8 system on a sound board for Saturday's charity event K-9 and myself attended.

Just to say that the event went really well and K-9 was a big hit with the kids (and adults) there. The sound files sounded great and the kids were convinced K-9 had a mind of his own. I was just informed by my friend that the whole event, for Epilepsy research, managed to raise £6250 which I'm really pleased about as it was only a moderate sized event that only lasted just over three hours. I also managed to drum up some business for EZ-Robot, with at least five people I spoke to saying they were going to place orders at the end of the month either for Revolution bots (JD was most popular) or dev kits, and a few more who really liked the website and we're going to read more when they got home. So a really good day all in all.:D

Anyway, back to the subject in hand. I've decided to ditch and return the AMD Toshiba laptop as I wasn't very pleased with it, so I'm replacing it with an Acer Aspire, 8 Gig, 64 bit, i5 system with Win 8.1 which will be with me before the end of the week. Then I will be testing all the voices again with ARC to see if they manage to work with the new machine. As the "bit" size doesn't seem to make a difference, I'm wondering if another make of laptop and another make of processor will make a difference. Either way I'll keep you informed of the results.

Fingers crossed, again.;)


Well done @Steve G ! I think Epilepsy research is a very worthy cause. I'm pleased that you were able to give your cute K-9 a voice and make it such a hit at the charity event. Rewarding for the charity, Ez-Robot and yourself! Good luck with the Acer Aspire!

United Kingdom

Thanks Tony. I must admit that I'm on a bit of a high right now because of yesterday. The kids that were there were just great, and a lot of fun.:)


@Steve, that's awesome Steve... Not the same thing but my girlfriend and I rescued a cat from the brutal cold.... He was pretty banged up and had lost a lot of weight... We call him Patches and I had been feeding him for maybe 4 years now...However, living out side all these years (probably a barn cat) had now finally taken it's toll on him.... He came 2 days ago at 2am in the morning and was just sitting in the shelter I had built for him... I took one look at him and I knew he needed to be rescued... He is a tough boy, but he had had enough...

Got him to the vet... found out although no serious diseases he was invested with mites and had a nasty open wound on his right cheek... He is also in dire need of dental surgery... His two upper k-9 were broken and most is not all of the remaining teeth need to come out... The vet estimates over $2000 worth of medical... This is on top of the initial vet visit yesterday...I am not complaining I will of course pay to get him fixed up... My girlfriend has posted his story on Facebook so maybe some people will help by donating money towards his vet bill.... Facebook link... Sue Benoit or suebenoit@yahoo.ca

User-inserted image

User-inserted image

United Kingdom


Cheers buddy. Yeah I'm really pleased with Saturday's result. A great day. Thanks for sharing Patches story. I see what you did there... K-9 (robot dog), k.9 (cat teeth) lol:P.

Seriously though that's a sweet story and kudos to you and your girlfriend for taking in and looking after the little fella. Very cute. I was going to ask if you could post a Facebook link, then I see that you added one. I couldn't find anywhere where I could make a donation to help though.

Anyway back on subject. Cereproc got in touch again today with a promo code of sorts that I can use to download one of their voices for a 60 day trial. What I think I'll do though is wait for the new laptop to arrive before I use it incase I have trouble coping the voice over between laptops.


@Steve seriously Thanks.... I hate asking for help.... You don't have to, but you can send whatever via paypal to suebenoit@yahoo.ca .... Again, I am not trying to solicit help and I feel really bad as the cat is my responsibility and was my choice to help him... I just couldn't let him die.... I would have never forgiven myself...

I owe you buddy....

United Kingdom


Hey, no worries dude. I love cats myself and would love to help. I can't afford much but every little helps right? I know what vet bills are like when I had my dog a while back (a real one that is):P ). Robot dogs are much cheaper to treat and I can do the surgery myself, except his voice that is eyeroll :)


@Steve that is great to hear! I am glad everything worked out. :)

@Richard what an amazing story. Good for you guys! That story was great to read, I am so glad Patches found you two! I sent a few $ over to Sue. ;)


@Aislinn... I don't know what to say... except thank you so much... Tell DJ I said you need a raise... :)

@Steve... You didn't have to but Sue will be very happy to hear that you guys have given something... thanks so much...:)

United Kingdom

Your welcome Richard.;)

United Kingdom

@Richard. ..

Yes this thread has been highjacked a bit with your story! :)

BUT its quite amazing story and we are a big cat lover in our family, in fact our 'British Blue' cat named Saffy is treated in our house better than the kids! :) I'll too will make a donation and send some money over to Sue.


@Cem... I realize that... so sorry Steve... I owe Steve for not only his donation but because I did highjack his thread... It's hard to un-ring the bell....

@Cem... thank you so much.....

The thing is I wasn't trying to solicit donations, didn't even occur to me until Steve offered...... I do feel bad for highjacking Steve's thread... so I owe him some Canadian beer or some other gift...:)

We had everything set up on facebook (Sue does facebook, I don't) as Sue has more friends than I can keep track of... We were expecting a fair bit of help from them, so I wasn't even going to mention Patches plight on here... Funny, only a couple of her so called friends stepped up to help so far... I don't want to seem ungrateful as I am fully aware I am going to foot most of the bill and I am of course ok with that... But you guys who barely know me are way more generous and kind... I am a little bit (ok a lot) of a cynic, but when I say that the people on the ez robot forum are the best in the world, I even believe now...

Again thanks

United Kingdom

Hey, this is MY thread, and I say... It's all good. :D:P:D. And at least it keeps the thread alive for anyone facing the same issues on the main topic. Err, what was it about again? ? ?


I just read the rest of your last post. A small gift you say... Well I've always fancied a Roli. But a Canadian beer sounds just as good, IF I'm ever over your neck of the woods.


I sent a little something too (poor kitty).



Thanks @Alan, seriously appreciated.... I will start another thread later this week after he gets his surgery... We're thinking it might be on Friday...

@Steve, I can make you a cardboard cut out of a Roli and mail it to you?... You can make robot sounds while you push it around...:D

I will keep everyone posted...


@Richard R

I sent you guys a few dollars. Tell Patches some folks down In Alabama are pulling for him to get well.


@Zap.... Thanks!... Just for that I am personally coming down to Alabama to take our Canadian cold air back...:D

United Kingdom


Time to get back on point. I'm back home after my business trip, and what was waiting for me when I got home... my shiny brand new laptop.

User-inserted image

So I got straight to it, done all the necessary updates, installed ARC, and got testing with the voice synthesis.

I started off with Microsoft voices and there was no change. ARC still used MS Hazel and not the other two voices. Same thing with Cepstral and Ivona as well. Then I moved on and installed my free trial version of CereProc with high hopes. They were soon dashed. It works fine on Windows Narrator but not with ARC:(.

So I went back and opened up all three laptops I have, and spent the last 2 hours un-installing then re-installing all the voices I have and did some final testing. Again there was no change. I went one further step and went in to one of the laptops registry to try and change some of the MS voice settings, even to the point where I made a copy of MS Hazel then tried to delete it from the system to see what would happen, but it wouldn't allow me to.

In the following post, I have given all the information I came across with the hopes that other members who are facing the same issues will follow suit and supply their info for the DJ and the guys at EZ HQ to hopefully help them troubleshoot the issue. If you guys at the office would like any more info then please let me know.


United Kingdom

Below is a list of laptops with the latest ARC software version installed, using Microsoft and 3rd party SAPI voices I have tried. All the voices have been tried with both setting the voices as the default TTS system voice, and setting the Microsoft voices as default system voice. Hopefully this info will help the guys at the office with their troubleshooting.;)

HP 650 notebook. Windows 7 Home Premium, 64 bit, 6 Gig RAM, 320G HDD, Intel Pentium CPU B790 processor.

Microsoft Anna In Windows Narrator... Working. In ARC... Working.

Cepstral Lawrence. In Windows Narrator... Working. In ARC... Working. With sound effects... Working.

Ivona Brian. In Windows Narrator... Working. In ARC... Working.

CereProc William. In Windows Narrator... Working. In ARC... Working.

Toshiba Satellite C50D-B-120 Windows 8.1, 64 bit, 4 Gig RAM, 500G HDD, AMD E1-6010 processor.

Microsoft Hazel In Windows Narrator... Working. In ARC... Working.

Microsoft Heera In Windows Narrator... Working. In ARC... Not working. Every speech synthesis setting variation tried.

Microsoft Zira In Windows Narrator... Working. In ARC... Not working. Every speech synthesis setting variation tried.

Cepstral Lawrence. In Windows Narrator... Working. In ARC... Not working. Every speech synthesis setting variation tried.

Ivona Brian. In Windows Narrator... Working. In ARC... Not working. Every speech synthesis setting variation tried.

CereProc William. In Windows Narrator... Working. In ARC... Not working.
Every speech synthesis setting variation tried.

Acer Aspire V3 572PG Windows 8.1, 64 bit, 8 Gig RAM, 500G HDD, Intel i5-4210U processor.

Microsoft Hazel In Windows Narrator... Working. In ARC... Working.

Microsoft Heera In Windows Narrator... Working. In ARC... Not working. Every speech synthesis setting variation tried.

Microsoft Zira In Windows Narrator... Working. In ARC... Not working. Every speech synthesis setting variation tried.

Cepstral Lawrence. In Windows Narrator... Working. In ARC... Not working.
Every Speech synthesis setting variation tried.

Ivona Brian. In Windows Narrator... Working. In ARC... Not working. Every Speech synthesis setting variation tried.

CereProc William. In Windows Narrator... Working. In ARC... Not working.
Every speech synthesis setting variation tried.


That is so bizarre Steve... I have 3 Win 8 pcs (Asus, Acer and an HP) and one win8 Acer w3 tab and all of them have no issues switching between windows voices including my Ceraproc voice. All this within ARC....

United Kingdom


I know. It's the craziest thing right? It's like MS Hazel is holding every other voice back within ARC. Did someone upset her or something confused.

United Kingdom


I know all machines are different and this probably won't make any difference as I've tried all the settings, but just out of curiosity what are the ARC settings you have on you Acer that uses the Cereproc voice?

United Kingdom

@DJ and Jeremie.

Hey guys. I know that you've been busy, but I'm just wondering if you have had a chance to look in to this ARC speech synthesis issue yet? I am even more curious now to why I am having these problems, along with Alan and Tony1952 as well.

So what I know is, Rich uses Cereproc but I don't know what OS he's using, DJ has successfully used voices with Win 8, and Richard is using Cereproc with Win 8 on three machines, one of them an Acer, and I'm sure there's other members successfully using 3rd party voices too. Alan tried Cepstral on Win 8.1 with no luck and cannot change MS voices, and Tony can't change MS voices on two Win 8 systems. And of course I've tried two Win 8.1 laptops with no joy with MS or 3rd party voices. There's just too much conflicting information here to work anything out, works for some, not for others using same OS, same voices, and make of machine.

I really hope your on your way to finding out what the problem could be as using these voices are important to my projects, and at the moment I can't really use large parts of my projects such the chatbot and reading RSS feeds ect, and especially when I get round to trying out Dave Cochran's EZ-AI with the voices I want and have purchased.

Thanks guys and I really appreciate your help with this.



@Steve sorry for the late reply... didn't notice your post until now...

User-inserted image

United Kingdom

No worries Richard. Thanks for the picture. Yep, I did them settings.:(


I still think this may have something to do with regional settings or regional versions of Windows. The only people having success are in Canada. Your symptoms and mine are identical except that you can't change from the default UK voice and I can't change from the default US voice.

I tried setting my region to Canada, but was not successful, but I may have missed something, or there may actually be a difference in the install when you first select your region.



I run windows 8.1 and can change voices. I am in the US. I will buy a Cepstral voice tomorrow and give it a try.


I'm running Windows 7 but I'm wondering if you go into speech recognition under Advanced speech options text to speech and change that to your program and see if that works. this is what I had to do to get mine working (cepstral duncan)

with my windows 7 this is what I had to do to make it work in ezb



Windows 7 works fine. It is only Windows 8.1 we are having an issue with.

@d.cochran, I can change the gender of the one voice that works. Steve can't because the voice that works for him only comes with one gender.

Will be very interested if Cepestral works for you. They do have a free trial if you want to try that before buying.



I am downloading Cepstral David Windows now. I will try it out and let you know the results.


Okay, so here is what happened.

I closed ARC. Everything was working fine with voices (just the standard windows voices and being able to change them).

Installed Cepstral David Windows

I opened a new project and added the Speech Setting and Speech Synthesis controls.

I set the voice to Microsoft David male and clicked the Say button on the Speech Synthesis control. It sounded normal.

I set the voice to Female with the same voice and it sounded like a female.

Every other voice I choose sounds like Microsoft David, either Male or Female.

Id say there is an issue. I will dig into it more tomorrow to see if there is something else that is causing it. I also have .net developer studio so I will play with it within an application to see if there is something that can be done in code to make the other voices work.


Okay, so yes, these will not work with the us version of 8.1.

It did work in windows 7 but not in windows 8.1 if you have a US version of the OS. This has to do with .net developer studio and specifically the System.speech.Synthesis.SpeechSynthesizer object that is included with the version of windows you are running. This component has nothing to do with EZ-Robot, but is a limitation of 8.1. They will work fine if someone has written a driver to make them work (which is why they work in other areas outside of .net 4.5.0 or 1). They will work fine on your system but will not work natively with the System.Speech.Synthesis.SpeechSynthesizer object that .net 4.5.x is running off of on specifically Windows 8.1.

I will see if there is another object that can be used but I doubt that DJ will see the need to change this out. You need to find specifically TTS voices and not something that is trying to be converted to TTS.

As to what is happening? My assumption is as follows. In ARC, there is a try catch and finally around the part that loads the voices into the list.

Probably something like this but a drop down list,

foreach (InstalledVoice voice in ss.GetInstalledVoices())

This part of the code works fine. But when you try to do

SpeechSynthesizer.SelectVoice("Cepstral David");

there is an error, so what happens is it keeps the default name. The error that happens is System.ArgumentException: Cannot set voice. No matching voice is installed or the voice was disabled.

at System.Speech.Synthesis.SpeechSynthesizer.SelectVoice(String name) at EZ_AI.SpeechTest.SpeechTest_Load(Object sender, EventArgs e) in whatever path to the CS file:line whatever line it is

This is odd because the list is being populated with the installed voice names and the user is selecting the name from the list. Unfortunately this doesn't work right in the US..

I am working on how to get it fixed right now because even with an uninstall of the voices, it doesn't fix ARC. I was able to change names in my little test app as long as I didnt select the non TTS voice.

Going to bed now. I will dig in more in the morning.

United Kingdom


Thanks for your response. I really appreciate you looking in to this, and I wish you luck finding a solution. Interesting to see you encountered issues as well. Really curious why it works for some and not for others using the same OS.


Thanks for your input my friend. As Alan has already stated the issue is for Windows 8.1, but I mentioned earlier that I have also tried setting all the voices to the system default voice within "Speech recognition" > "Text to Speech" to no avail. Just to say though that I never had any problem with windows 7. In fact, I could leave another TTS voice as system default and Cepstral would still work in ARC. I think the settings were Male Senior.


It's still niggling at me thinking it's something to do with Regonal settings. But I have tried changing the them with no joy, although I havn't tried this with system set up as I thought it amounted to the same thing. Maybe it doesn't. Like you say, most People in Canada do not seem to have an issue, but then there's Rich, in the UK, the using Cereproc for Javis (although not sure what operating system he is using with this). I'm just hoping the guys at the office are in the process of figuring something out, but it certainly looks like David C is on the case.


@Steve.... You got me curious too why it seems to work for me.... I am probably way off (as usual LOL) but Canada has 2 official languages.... That being said maybe that has something to do with why mine works?

United Kingdom


Your way way way WAY off. Only joking bud. You may have a point. I didn't know Canada has two official language's. But then in the UK, why does Rich's work and mine doesn't? Same voice, and assuming same OS.


@Steve... Yep English and French are Canada's two official languages.... Not sure you should create another thread but maybe you can ask others to start posting there results in adding voices to use with ARC? I think we need more people to comment so we might be able to see some sort of pattern develop...

United Kingdom


Doh, I actually knew that about the English/French Canadian sleep.

Anyway yeah, I'm hoping some other members will come forward with what they are using and post some details like I did in post #71. @Rich. If your reading this, what OS are you using Cereproc with?


The only way that I see a change coming is for EZ-Robot to change their speech engine from the one that is supplied with windows to another one that is able to convert these voices. I dont know if that is a possibility. It would require quite a bit of work I would suspect and would require the purchase of a speech SDK.

I am still looking for a way to get the microsofts speech engine back to normal after installing the voices that we have.

United Kingdom


Thanks David. So in your eyes, what do you reckon the problem actually is? I not that experienced in such things but I wouldn't have thought the guys changing their speech engine would solve it, as it's working for some people and not others using the same voices, ARC version, operating system, and in some cases the same make of computer. If it didn't work for everyone then I could kinda understand it.

But I could be wrong of course.


I am using the same development platform that I believe they are using.

The issue is that this platform works with TTS voices, which the ones installed are not TTS voices. This causes them to have to go through a separate driver to be converted to TTS. This isn't working with the current version of the objects that are available to the current development platform.

The reason that these work with some apps on your system and not others is because these are converted using a custom driver in that software that is able to convert these to TTS. This happens at runtime for the application.

The reason that it works on some computers and not others could be a couple of things. 1. The version of the controls that are being used are not the same, 2. There is something catching this conversion and handling the conversion to TTS on their system that is not on ours, or 3 They are using different voices that are true TTS voices.

A different SDK with a list of supported voices would eliminate this issue. The problem is that EZ-Robot would have to check and approve voices as they came out. I dont think this is the best use of their time by any means.

I am trying a voice from the company that Rich has used to see if that works. I will let you know what I find out. It may be that they use a different "driver" that will catch these and convert them better.

The only voices supported natively by the speech synthesizer that is probably being used by EZ-Robot on Windows 8.1 are the native Windows voices. I am not surprised by this at all as Microsoft would have to verify and validate voices as they were being produced. I personally think that there should be some sort of voice verification group at Microsoft if they ever want their speech engine to really take off, but who am I? This would allow voice vendors to put something on their voices saying "Microsoft Approved" or something like that. I will find the version of the DLL that is on my system that is used for the speech synthesizer. It may help to point to a possible solution.



It seems from your results that Microsoft has probably broken the SAPI API in 8.1. These 3rd party voices all follow the MS SAPI 5.x standard. (note: I have the problem with the broken MS voices on a machine that I did not attempt to install Cepstral on. Just MS, no 3rd party voices).

I am not actually surprised if Microsoft broke SAPI (unintentionally, but through neglect). I have some inside information about how they started to move in a different direction for speech, abandoned that, and now are going in yet another direction with Cortona. SAPI has not had any Microsoft love for a while.

(edit: I was typing this before you entered post #93. leaving in place as I still think this is the issue, but it seems more intentional, with the current SAPI requiring "signed" voices, and perhaps the 3rd parties have not done that).



I suspect the version of system.speech.dll that they are using is from .net framework 4.5.0 and is product version 4.0.30319.17929.

.net Framework 4.5.1 has version 4.0.30319.18402. This is the version that I am testing with but would be happy to setup a .net 4.5 project and test the other one. I might setup a project that uses a later version of .net framework and see if it makes a difference. I doubt that it will.

I dont know if any of the .net framework service packs have changed this DLL but I suspect that they have. It is possible that those who have these versions working have a different version of this DLL.

This dll can be found in C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework.NETFramework\v4.5 or whatever version you want to look in on your machine. I believe that ARC is compiled to be 32 bit so this should be the correct location.

United Kingdom


Thanks for your insight my friend. The voice that Rich uses is from Cereproc which I have a 60 day trial period for, and that's not working for me in ARC either. It would be interesting to see what results you have with it. Still another curiosity is that a lot of us can only use one of the three native Microsoft voices with Win 8.1.


I am looking to see if the Speech.Speech.xml file was messed up by the install. It may also be buried in the registry. One thing is for sure, there is not much information on the internet that offers any help.

United Kingdom


Tell me about it. I've looked myself. Beleive me I've looked a lot.


I bought and downloaded the CereProc Adam voice and installed it. I then went to the control panel and went to Speech Recognition. I choose the Text To Speech from the left side, and then choose the Text to Speech tab. I set CeneVoice Adam - English (East Coast America) as the voice selection and clicked OK.

I launched ARC and now all speech from ARC uses this voice no matter which voice is selected in the speech settings dialog. This voice is now at the top of my list. I think the default windows voice is first in the list in ARC.

While this isnt a total fix to the issue, it might offer you a solution to how to get a voice other than the default windows voices. It looks like the first voice in the dropdown is being used. I suspect that the first voices I downloaded and installed have messed up the VoiceChanged property of the speech synthesis DLL based on this information.

United Kingdom

That is interesting. That is exactly what I have tried with Cereproc voice (even tried again just now) and it doesn't work for me. stress


Does this voice appear at the top of the list in ARC? Also, did you try a new project in ARC or is this one that was already in existence? I am just curious.


one more thing... I uninstalled the first voice that I had tried prior to installing the second voice. That may be a difference.

United Kingdom


When I selected Cereproc as default Windows voice, it did appear at the top of the speech synthesis settings list. And it is a new project I'm trying it with. I will delete the other two voices and see what happens.

United Kingdom

Ok, so I just un-installed Cepstral and Ivona, restarted the laptop and tried again. I set the TTS default voice to Cereproc and opened a new project. Went through all the setting variations... still no change. It still insists on using MS Hazel.

United Kingdom

How do I go about deleting Microsoft Hazel from my laptop? I want to try this to see what happens with the other two MS voices and Cereproc when I try using them in ARC.

United Kingdom

Thanks David.


I cant find a supported method of doing this. now to look at hacks to make this happen.


This is purely up to you and I don't know what the results will be, but here it goes. I take no responsibility if things break so think about it before you do it. If you are looking at an OS rebuild anyway, it wouldn't hurt to try.

BEFORE YOU DO THIS, I would make a backup of your registery. REBOOT IN SAFEMODE to give you the ability to change this I suspect.

In the registry under Hkey_Local_Machine\Software\Microsoft\speech\voices\tokens there are the voices that I have installed.
TTS_MS_EN-GB_HAZEL_11.0 could be deleted to see if that causes the others to work. I would also check to see if there are any of the old voices listed in there and remove them.

Also, the Hazel voice is stored in C:\Windows\Speech\Engines\TTS\en-GB

you could rename this directory to C:\Windows\Speech\Engines\TTS\en-GB_Backup

Reboot your machine and keep your fingers crossed.

United Kingdom

I've got a win 8 system I can try this on wish me luck.

United Kingdom


Well thanks a bunch. Now I've gone and broken everything now. Only joking. As you can tell by the banter, I have had some interesting results. Here they are...

I was unable to delete MS Hazel from the registry as it came up with an error. So I went via C:\Windows\Speech\Engines\TTS\en-GB and deleted the entire file. I then went to "Control Panel", "Speech Recognition" then "Text to Speech" to see if I did break anything. Hazel was still there but didn't work anymore. I had sent her packing. I then tried Heera and Zira. Phew, they were still working. So I then opened a new ARC project to see if everything was working there. I tried Heera and Zira and..... THEY WORKED:D. I could change them in the Speech synthesis setting and the spoke with there corresponding voice. So next test.

I downloaded Cepstral trial and Ivona trial. Again they worked in Windows so tried ARC again, but would you believe it..... THEY WORKED TOO.:D:D:D

So, after 110 posts and a lot of head scratching, what I originally had a feeling about actually got scorching results. I'm going to try this again now on my main (new) Acer laptop but I can't see me having any issues, I hope. I'll leave an update in a bit.;)


That is great. so..... in thinking about this.....

Hazel was a GB voice. The others are US voices. I wonder if the GB voice was having issues due to globalization. It is interesting that the others started working. It is also good news.


ROFL @Richard R. I was drinking some water and you choked me...


@David... sorry buddy...:)

@Steve.... problem finally solved... Awesome...! You're one persistent dude....:)

United Kingdom

Maybe, just maybe that's what it is. Well, I have done the same thing on the Acer, all voices working in Windows. But hiw did they get on with ARC...

MS Hazel... Looking for a new job, and the nearest bar to drown her sorrows. mad

MS Heera... WORKING.:)

MS Zira... WORKING.:)

Ivona Brian... WORKING:)

Cereproc William... WORKING:)

And finally Cepstral Lawrence... WORKING:D. (K-9 will be happy)

So there we have it. David, you may be on to something about Microsoft UK voice globalization. To some this may not be an ideal solution, but it is certainly proven now using two Windows 8.1 machines. Well there's not much else to say now. Patches must be a lucky charm lol. Thank you though to everyone who has chimed in with your ideas, trials and sharing your issues. I can't of course credit myself marking this as resolved, so I'll give it to you David as you were the one who gave me the info for deleting, er, what was her name again?


Anyone else having similar issues who decide's to try what I did, as d.cochran correctly stated, you do so at your own risk. I was willing to risk it and yes, it worked out for me. Although this wasn't a registry change, you are still deleting files, so only do this if you know what your doing, and at your own risk. Okay, lecture over.:)

Thanks again everyone.:D

United Kingdom


Mate, you have no idea lol. This was one thing I REALLY wanted to get solved. Two of my projects were relying in it.:)


@Steve... No doubt about it ... this ones all David's....


Thanks Steve. Im just glad you have some sort of resolution.


I'll try this evening or tomorrow to do the same thing with the Microsoft David that seems to own my machine and post results here for those of us in the US.


United Kingdom

Let us know how you get on Alan.


edited to remove long post about partial success. it was only temporary....



Did you check to make sure the language was still gone from the hard drive? You know as well as I do that Microsoft likes to try to protect you from yourself a lot.


OK. Now I have partial success. If I install Cepstral and then reboot, and then delete the en-US engine, Lawrence works in windows and ARC. Can't use any of the voice effects like Old Robot, and no other voices work in EZ, but Lawrence does. (even though Hazel does in Windows).

Same results on both 32 and 64 bit machines (although using the trial Cepstral license on 64 bit)



Partial success is much further than we have made it up to this point. I wish there was an overall solution to it but partial is better than nothing. Maybe Windows 10 will have better luck but I am not holding my breath.

United Kingdom


When I opened C:\Windows\Speech\Engines\TTS\en-GB, I deleted the four files I had one by one.

M2057HAZ.Keyboard.NUS M2057HAZ MSTTSLocENGB.dat M2057HAZ.APM

Technically Hazel (the four files above) isn't out looking for a new job just yet, but she has been banished and resides in the recycle bin at the moment. To get the Cepstral effects working on ARC....

Open your (c: ) drive,

Then Program files,



Copy the effect you want to use,

Go back to cepstral,


Open "Lawrence" file,

Paste the sfx file,

Rename the effect to "default.sfx",

And that should be it. Open ARC and Lawrence should use the effect. Hope that helps Alan.:)


Awesome Steve.

So Microsoft has really borked up Sapi, but at least we have workarounds.



That worked great (copying the effect file). I'll probably wind up using dizzy droid or pvc pipe so that our K9's will sound like cousins instead of twins. I'll write a little batch file to make it easier to switch until I make up my mind.


United Kingdom

No worries Alan. Pleased you got it sorted. I use the PVC pipe effect with my little fella. He's just happy he can talk again (& so am I).:D

United Kingdom


A couple of weeks ago, I upgraded to Windows 10 from 8.1. While troubleshooting somebody else's ARC project, I found that this same issue occurs. The new OS install reinstalled the Hazel files which had to be deleted again. It was a simple case of copying and pasting C:\Windows\Speech\Engines\TTS\en-GB in to the "Cortana" taskbar search window, and deleting the files again.

The Tutorial On Fixing Voice Synthesis Problem With Windows 8.1 and 10 has been updated to show this.